Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Yet another USB Headset thread
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message

Joined: 27 Oct 2013
Posts: 6

PostPosted: Sun Oct 27, 2013 5:13 pm    Post subject: [Solved] Yet another USB Headset thread Reply with quote

Hello everyone! My first post here, from an old time Slacker.
After leaving slackware and trying fedora, suse, ubuntu, then debian(which most of my servers are with),
I switched to Gentoo as my desktop distro about 2 years ago. With some help from friends I managed to learn a lot about this distro and I fell in love with it.
Yet I've never had a problem that I couldn't solve with sufficient time googling, or searching in forums. But this one went way too long.
The USB headset I am trying to have properly working has rocking loud and clear sound on Windows, Debian and Mint 15. I love them even they are not some famous HiFi brand.
I have integrated soundcard (intel), HDMI audio and my USB Headset. I want to have my USB headset as PRIMARY input and output device.
c0@home ~ $ lsusb | grep Head
Bus 003 Device 006: ID 05e1:2010 Syntek Semiconductor Co., Ltd ARCTIC Sound P261 Headphones

c0@home ~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0]
card 3: Device [USB VoIP Device], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

c0@home ~ $ cat /etc/kernels/kernel-config-x86_64-3.10.7-gentoo-r1 | grep SND_USB
# CONFIG_SND_USB_US122L is not set
They are working with applications like Skype in which I can manually choose output/input device(they have mic too), firefox and flash do not produce sound

After I try playing aplay like this, which is the most frustrating part:
c0@home ~ $ aplay -D hw:0,3 M1F1-int32-AFsp.wav #which is a sample wav file
aplay: main:722: audio open error: Device or resource busy
I get this one above. It becomes worse

c0@home ~ $ sudo /etc/init.d/alsasound restart
* WARNING: you are stopping a boot service
* Storing ALSA Mixer Levels ... [ ok ]
* Restoring Mixer Levels ...
alsactl: set_control:1461: Cannot write control '3:3:0:Playback Channel Map:0' : Device or resource busy [ ok ]

I am not sure what is [ok] with restarting the service while the device is busy.
I thought that having the CONFIG_SND_USB module built-in into the kernel messes up, so i just had rebuild the kernel and the module, marking it as a separate instead building it into the kernel.
Actually i marked the whole CONFIG_SND tree as separate modules.
did genkernel all as usual. (yes I am lazy sysadmin, and i love it)
Yet there is no change, makes the same mess.
Tried various things and combinations with /etc/asound.conf, /etc/udev/udev.conf, ~/.asoundrc, with no success, reverting to default values.
ALSA and friends are built, tested and working, for about a year over 4 completely different systems.
It's just that I never tried USB Audio peripherals on my Gentoo. So I am kinda ... out of options for now
I am open to any suggestions :)

Last edited by badc0d3d on Mon Oct 28, 2013 1:15 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 27 Oct 2013
Posts: 6

PostPosted: Mon Oct 28, 2013 1:14 pm    Post subject: success. Reply with quote

Nevermind. I got it working.
I am not sure whether jack plays really a key role, but enabled "jack" use flag.
Even though, pavucontrol DIDN'T see the headphones at all!

reemerged alsa-plugins, PulseAudio and pavucontrol
[ebuild R ] media-sound/pulseaudio-4.0 USE="X alsa asyncns caps dbus gdbm glib gtk ipv6 jack orc ssl tcpd udev webrtc-aec -avahi -bluetooth -doc -equalizer -gnome -libsamplerate -lirc (-neon) (-oss) -qt4 -realtime (-system-wide) -systemd {-test} -xen"
[ebuild R ] media-plugins/alsa-plugins-1.0.27 USE="jack pulseaudio -debug -ffmpeg -libsamplerate -speex"
[ebuild R ] media-sound/pavucontrol-1.0 USE="nls"

stumbled upon
pasted the first code block into /etc/modprobe.d/alsa.conf


pavucontrol had enumerated the headphones, so i was finally able to select them as output/input device
Everything works like a charm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum