Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
vlc & ffmpeg can not be installed on the same system?[solved
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 762
Location: Tri-Cities, WA USA

PostPosted: Mon Nov 04, 2013 12:29 pm    Post subject: vlc & ffmpeg can not be installed on the same system?[so Reply with quote

I need ffmpeg and I like vlc. What can I use instead of vlc to play mp4 and mov?
I'm using totem player now. Gnome player does not work.

azzerare ~ # emerge vlc
Calculating dependencies... done!
[ebuild N ] media-libs/libpostproc-0.8.0.20121125 USE="mmx -3dnow (-altivec) -mmxext -pic -static-libs"
[ebuild N ~] media-video/vlc-2.1.0 USE="X a52 alsa avcodec avformat dbus dts dvbpsi dvd encode ffmpeg flac gcrypt gnome libnotify mmx mp3 mpeg ncurses ogg opengl png postproc qt4 sdl sse svg swscale truetype vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -avahi -bidi -bluray -cdda -cddb -chromaprint -dc1394 -debug -dirac -directfb (-directx) -dvb (-dxva2) -egl -faad -fdk -fluidsynth -fontconfig -gme -gnutls -growl -httpd -ieee1394 (-ios-vout) -jack -kate -kde -libass -libcaca -libsamplerate -libtar -libtiger -linsys -lirc -live -lua (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) -matroska (-media-library) -modplug -mtp -musepack (-neon) -omxil -opencv -optimisememory -opus -projectm -pulseaudio (-qt5) -rdp -rtsp -run-as-root -samba -schroedinger -sdl-image -sftp -shout -sid -skins -speex -taglib {-test} -theora -tremor -twolame -udev -upnp -v4l -vaapi -vcdx -vdpau -vlm -wma-fixed -zvbi"
[blocks B ] <media-video/ffmpeg-1.2:0 ("<media-video/ffmpeg-1.2:0" is blocking media-video/vlc-2.1.0)
[blocks B ] media-video/ffmpeg:0 ("media-video/ffmpeg:0" is blocking media-libs/libpostproc-0.8.0.20121125)
[blocks B ] media-libs/libpostproc ("media-libs/libpostproc" is blocking media-video/ffmpeg-1.0.7)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(media-video/vlc-2.1.0::gentoo, ebuild scheduled for merge) pulled in by
vlc

(media-video/ffmpeg-1.0.7::gentoo, installed) pulled in by
>=media-video/ffmpeg-0.10.3:0[X?,encode?,gsm?,jpeg2k?,mp3?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?] (>=media-video/ffmpeg-0.10.3:0[X,encode,mp3,sdl,threads,truetype,x264]) required by (virtual/ffmpeg-0.10.3::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
_________________
Without diversity there can be no evolution:)


Last edited by cwc on Sat Nov 16, 2013 3:04 am; edited 1 time in total
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1360

PostPosted: Mon Nov 04, 2013 12:43 pm    Post subject: Reply with quote

Read the blocker output more carefully; always consider _what_ is blocking _what_ and what alternatives you have, I'll be trying to get Portage to output this so it doesn't have to go manually.

Quote:
[blocks B ] <media-video/ffmpeg-1.2:0 ("<media-video/ffmpeg-1.2:0" is blocking media-video/vlc-2.1.0)


Left hand side: ffmpeg versions lower than 1.2 cannot be used; so, you need to upgrade ffmpeg to at least 1.2.
Right hand side: vlc version 2.1.0 has this restriction; so, others might not and if you cannot upgrade ffmpeg then consider to downgrade vlc.

Quote:
[blocks B ] media-video/ffmpeg:0 ("media-video/ffmpeg:0" is blocking media-libs/libpostproc-0.8.0.20121125)


Left hand side: ffmpeg versions in SLOT 0 cannot be used; so, you need to use a different slot of ffmpeg or use libav instead (a recent enough version).
Right hand side: libpostproc has this restriction in every version; so, you could consider if you actually need the libpostproc pcakage at all.

Quote:
[blocks B ] media-libs/libpostproc ("media-libs/libpostproc" is blocking media-video/ffmpeg-1.0.7)


Left hand side: Do you need libpostproc?
Right hand side: ffmpeg has this restriction in every version.

So, it seems you will want to upgrade media-video/ffmpeg to at least 1.2 and remove media-libs/libpostproc as media-video/ffmpeg attempts to cover that.
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 762
Location: Tri-Cities, WA USA

PostPosted: Mon Nov 04, 2013 12:59 pm    Post subject: Reply with quote

excellent! Thanks for the help. I'll work on it.
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum