Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems installing WICD and WPA_SUPPLICANT
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
BinaryNation
n00b
n00b


Joined: 16 Oct 2013
Posts: 12

PostPosted: Fri Oct 25, 2013 10:25 am    Post subject: Problems installing WICD and WPA_SUPPLICANT Reply with quote

So I'm trying to install WICD and WPA_SUPPLICANT but I'm getting an error when I try to install them and I'm not sure how to fix it. Below is what I get when I try 'emerge wicd' and 'emerge net-wireless/wpa-supplicant'.

Code:
# emerge wicd

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies  ... done!

!!! The ebuild selected to satisfy "net-wireless/wpa_supplicant" has unmet requirements.
- net-wireless/wpa_supplicant-2.0-r2::gentoo USE="ap dbus eap-sim fasteap gnutls (multilib) p2p (-ps3) qt4 readline (-selinux) smartcard ssl wimax -wps" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    fasteap? ( !gnutls !ssl )

  The above constraints are a subset of the following complete expression:
    fasteap? ( !gnutls !ssl ) smartcard? ( ssl )

(dependency required by "net-misc/wicd-1.7.2.4-r2" [ebuild])
(dependency required by "wicd" [argument])


Code:
# emerge net-wireless/wpa_supplicant

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies

!!! Problem resolving dependencies for net-wireless/wpa_supplicant
... done!

!!! The ebuild selected to satisfy "net-wireless/wpa_supplicant" has unmet requirements.
- net-wireless/wpa_supplicant-2.0-r2::gentoo USE="ap dbus eap-sim fasteap gnutls (multilib) p2p (-ps3) qt4 readline (-selinux) smartcard ssl wimax -wps" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    fasteap? ( !gnutls !ssl )

  The above constraints are a subset of the following complete expression:
    fasteap? ( !gnutls !ssl ) smartcard? ( ssl )
Back to top
View user's profile Send private message
Tractor Girl
Tux's lil' helper
Tux's lil' helper


Joined: 16 May 2013
Posts: 100

PostPosted: Fri Oct 25, 2013 8:12 pm    Post subject: Reply with quote

Code:
The following REQUIRED_USE flag constraints are unsatisfied:
    fasteap? ( !gnutls !ssl )

It means that you cannot set both faststep ,gnutls and ssl flags at the same time. Disable faststep and it should work. If fact you probably don't need all those flags here. I have only ssl and readline for example. Also be aware that qt4 flag will install GUI for wpa_supplicant (I don't if you want it).
BTW why do you want both wpa_supplicant and wicd - they do the same stuff (wpa_supplicant is much more reliable imo)
Back to top
View user's profile Send private message
BinaryNation
n00b
n00b


Joined: 16 Oct 2013
Posts: 12

PostPosted: Tue Oct 29, 2013 11:52 am    Post subject: Reply with quote

I guess I misunderstood the usage of the two, I was under the impression that WICD is used to access/find wireless networks and WPA_Supplicant is needed for WPA/WPA2 networks. Also thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum