Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Abandon] Gentoo et driver BNX2 qui drop des paquets
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Mythy
n00b
n00b


Joined: 17 Jul 2012
Posts: 59

PostPosted: Wed Oct 23, 2013 7:39 am    Post subject: [Abandon] Gentoo et driver BNX2 qui drop des paquets Reply with quote

Bonjour à tous !

Après 2 jours de recherche sur mon problème, j'en arrive à comprendre qu'en faite le driver BNX2 pour Gentoo semble avoir quelques soucis dans son fonctionnement par default.

En faite, la carte réseau fonctionne, mais plein de paquets sont dropés plus ou moins aléatoirement.

Étant donné que c'est pour mettre un OpenVPN dessus, les performances sont juste horribles...

J'ai trouvé quelques infos à ce sujet mais rien de bien concluant pour le moment :/

Une fois de plus je compte sur votre aide pour m'aider à résoudre ce schmilblik :)

Voici quelques informations au sujet du dédié et du réseau :

Quote:
# lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/Ivy Bridge DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a4)
00:1f.0 ISA bridge: Intel Corporation C202 Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 Serial Attached SCSI controller: LSI Logic / Symbios Logic SAS2008 PCI-Express Fusion-MPT SAS-2 [Falcon] (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5716 Gigabit Ethernet (rev 20)
02:00.1 Ethernet controller: Broadcom Corporation NetXtreme II BCM5716 Gigabit Ethernet (rev 20)
03:03.0 VGA compatible controller: Matrox Electronics Systems Ltd. MGA G200eW WPCM450 (rev 0a)


Quote:
# ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
ether d4:ae:52:c8:b1:cf txqueuelen 1000 (Ethernet)
RX packets 113149 bytes 12371357 (11.7 MiB)
RX errors 0 dropped 1589 overruns 0 frame 0
TX packets 8467 bytes 1606677 (1.5 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


Quote:
# ethtool -k eth0
Features for eth0:
rx-checksumming: on
tx-checksumming: on
tx-checksum-ipv4: on
tx-checksum-ip-generic: off [fixed]
tx-checksum-ipv6: on
tx-checksum-fcoe-crc: off [fixed]
tx-checksum-sctp: off [fixed]
scatter-gather: on
tx-scatter-gather: on
tx-scatter-gather-fraglist: off [fixed]
tcp-segmentation-offload: on
tx-tcp-segmentation: on
tx-tcp-ecn-segmentation: on
tx-tcp6-segmentation: on
udp-fragmentation-offload: off [fixed]
generic-segmentation-offload: on
generic-receive-offload: on
large-receive-offload: off [fixed]
rx-vlan-offload: on
tx-vlan-offload: on
ntuple-filters: off [fixed]
receive-hashing: on
highdma: on [fixed]
rx-vlan-filter: off [fixed]
vlan-challenged: off [fixed]
tx-lockless: off [fixed]
netns-local: off [fixed]
tx-gso-robust: off [fixed]
tx-fcoe-segmentation: off [fixed]
tx-gre-segmentation: off [fixed]
tx-udp_tnl-segmentation: off [fixed]
fcoe-mtu: off [fixed]
tx-nocache-copy: on
loopback: off [fixed]
rx-fcs: off [fixed]
rx-all: off [fixed]
tx-vlan-stag-hw-insert: off [fixed]
rx-vlan-stag-hw-parse: off [fixed]
rx-vlan-stag-filter: off [fixed]


Quote:
# ethtool -c eth0
Coalesce parameters for eth0:
Adaptive RX: off TX: off
stats-block-usecs: 999936
sample-interval: 0
pkt-rate-low: 0
pkt-rate-high: 0

rx-usecs: 18
rx-frames: 12
rx-usecs-irq: 18
rx-frames-irq: 2

tx-usecs: 80
tx-frames: 20
tx-usecs-irq: 18
tx-frames-irq: 2

rx-usecs-low: 0
rx-frame-low: 0
tx-usecs-low: 0
tx-frame-low: 0

rx-usecs-high: 0
rx-frame-high: 0
tx-usecs-high: 0
tx-frame-high: 0


Quote:
# ethtool -g eth0
Ring parameters for eth0:
Pre-set maximums:
RX: 2040
RX Mini: 0
RX Jumbo: 8160
TX: 255
Current hardware settings:
RX: 255
RX Mini: 0
RX Jumbo: 0
TX: 255

_________________
Mythy'Zone - Blog technique / Jeux vidéos


Last edited by Mythy on Fri Oct 25, 2013 8:29 am; edited 1 time in total
Back to top
View user's profile Send private message
StinGer_Uesugi
Tux's lil' helper
Tux's lil' helper


Joined: 12 Nov 2010
Posts: 125
Location: Milky Way > Solar System > Earth > France > Paris > Home

PostPosted: Wed Oct 23, 2013 8:41 am    Post subject: Reply with quote

Heuu juste une question.

Est-ce que ta machine qui fait office de serveur VPN est NATée ? Si c'est le cas, tes clients VPN ont un double NAT à traverser : celui du serveur, puis celui de la passerelle qui relie le serveur VPN à Internet. Typiquement, cela arrive quand c'est une "box" ou une passerelle qui te donne l'accès à Internet et pas un simple modem piloté par le serveur. En gros, quand tu as :
Code:
client VPN ---> serveur VPN ---> gateway ---> Internet


Si tu es dans ce cas, ce qu'il se passe c'est que le double NATage rajoute trop d'overhead dans les paquets réseau, qui dépassent donc le MTU. D'où le drop (à mon avis).

Pour résoudre ce problème, il faut faire du traversial NAT (NAT-T) et diminuer le MTU sur le serveur VPN. On trouve des tutos et des explications sur le pourquoi/comment de tout ça.


Maintenant, si les paquets qui n'ont rien à voir avec le VPN sont perdus (genre en désactivant le VPN et en naviguant simplement sur Internet), tout ce que je viens de dire ne sert à rien et le problème vient d'ailleurs...
_________________
Why drink and drive when you can smoke and fly ?
Back to top
View user's profile Send private message
Mythy
n00b
n00b


Joined: 17 Jul 2012
Posts: 59

PostPosted: Wed Oct 23, 2013 8:59 am    Post subject: Reply with quote

Merci pour ton aide et ta réponse rapide ;)

En faite il 'agit d'une dedibox de chez SAS Online donc il n'y a pas de soucis du genre je pense

J'ai déjà 2 serveurs dédiés chez OVH qui font office de serveur VPN et il n'y a aucun problème avec le même type d'install de Gentoo etc...

La dedibox de chez SAS online (celle qui déconne avec BNX2) a aussi été installé sur le debian proposé par SAS Online, j'y ai ajouté un serveur OpenVPN et ça marche super bien.

Par contre, avec cette dedibox qui marche nickel sur debian, pas moyen de la faire bien marcher sur Gentoo.

Ayant 8 serveurs sur Gentoo, j'aimerais vraiment utiliser que Gentoo, d’où mon besoin de résoudre ce problème de BNX2 sur Gentoo :?

Et là pour tester, j'ai lancé un emerge --sync, il perd 4 paquets

PS: J'adore ta signature
_________________
Mythy'Zone - Blog technique / Jeux vidéos
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2862
Location: Paris

PostPosted: Wed Oct 23, 2013 7:50 pm    Post subject: Reply with quote

StinGer_Uesugi wrote:
Heuu juste une question.

Est-ce que ta machine qui fait office de serveur VPN est NATée ? Si c'est le cas, tes clients VPN ont un double NAT à traverser : celui du serveur, puis celui de la passerelle qui relie le serveur VPN à Internet. Typiquement, cela arrive quand c'est une "box" ou une passerelle qui te donne l'accès à Internet et pas un simple modem piloté par le serveur. En gros, quand tu as :
Code:
client VPN ---> serveur VPN ---> gateway ---> Internet


Si tu es dans ce cas, ce qu'il se passe c'est que le double NATage rajoute trop d'overhead dans les paquets réseau, qui dépassent donc le MTU. D'où le drop (à mon avis).

Pour résoudre ce problème, il faut faire du traversial NAT (NAT-T) et diminuer le MTU sur le serveur VPN. On trouve des tutos et des explications sur le pourquoi/comment de tout ça.


Maintenant, si les paquets qui n'ont rien à voir avec le VPN sont perdus (genre en désactivant le VPN et en naviguant simplement sur Internet), tout ce que je viens de dire ne sert à rien et le problème vient d'ailleurs...


Si j'en conviens, le coup de la MTU est un bonne idée, j'ai comme l'impression que le reste est un peu flou (en tout cas pour moi ;)). Le coup du NAT-T, ça ne concerne pas OpenVPN. C'est une technique liée à IPsec, si je ne m'abuse. Ensuite, le fait d'avoir des équipements qui routent successivement les paquets ne signifie pas que "plus il y en a, et plus il faut baisser la MTU".
Ceci dit, j'ai peut être mal compris ce que tu voulais dire :)

Autre piste, il y a parfois des firmwares qui vont avec les puces broadcom. Il n'est pas inenvisageable que charger le firmware à jour corrige un bug hardware (c'est du microcode pour le matériel, après tout).
_________________
-PC: 2500K/P8Z68V, 8Go DDR3 1600 1.35V, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC + NF9D-2700, 4Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RDNU2000
Back to top
View user's profile Send private message
Mythy
n00b
n00b


Joined: 17 Jul 2012
Posts: 59

PostPosted: Thu Oct 24, 2013 9:09 am    Post subject: Reply with quote

En faite sur Debian TOUT est nickel, avec MTU à 1500 (comme sur Gentoo)

Quote:
DEBIAN eth0 Link encap:Ethernet HWaddr d4:ae:52:c8:b1:cf
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:5366 errors:0 dropped:0 overruns:0 frame:0
TX packets:2810 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:1016706 (992.8 KiB) TX bytes:455750 (445.0 KiB)
Interruption:16 Mémoire:c0000000-c0012800


J'entame le 4e jour de recherche et je vous avoue que les résultats sont impressionnants (mais pas dans le bon sens), j'ai testé une 15aine de conf/kernel/driver différents (réglages ethtool, disable_msi, copie de driver, etc...) et y'a rien à faire oO

Encore là je viens de réinstaller en mettant bnx2 et bnx2x, il me fait un truc en plus avec bnx2x mais ça change rien :/

Quote:
sd-51340 ~ # cat /var/log/messages | grep -a bnx2
Oct 24 10:43:41 sd-51340 kernel: [ 9.505232] bnx2x: Broadcom NetXtreme II 5771x/578xx 10/20-Gigabit Ethernet Driver bnx2x 1.78.17-0 (2013/04/11)
Oct 24 10:59:54 sd-51340 kernel: [ 9.505049] bnx2: Broadcom NetXtreme II Gigabit Ethernet Driver bnx2 v2.2.3 (June 27, 2012)
Oct 24 10:59:54 sd-51340 kernel: [ 9.505926] bnx2 0000:02:00.0 eth0: Broadcom NetXtreme II BCM5716 1000Base-T (C0) PCI Express found at mem c0000000, IRQ 16, node addr d4:ae:52:c8:b1:cf
Oct 24 10:59:54 sd-51340 kernel: [ 9.506783] bnx2 0000:02:00.1 eth1: Broadcom NetXtreme II BCM5716 1000Base-T (C0) PCI Express found at mem c2000000, IRQ 17, node addr d4:ae:52:c8:b1:d0
Oct 24 10:59:54 sd-51340 kernel: [ 9.506801] bnx2x: Broadcom NetXtreme II 5771x/578xx 10/20-Gigabit Ethernet Driver bnx2x 1.78.17-0 (2013/04/11)
Oct 24 10:59:54 sd-51340 kernel: [ 15.143667] bnx2 0000:02:00.0: irq 44 for MSI/MSI-X
Oct 24 10:59:54 sd-51340 kernel: [ 15.143673] bnx2 0000:02:00.0: irq 45 for MSI/MSI-X
Oct 24 10:59:54 sd-51340 kernel: [ 15.143676] bnx2 0000:02:00.0: irq 46 for MSI/MSI-X
Oct 24 10:59:54 sd-51340 kernel: [ 15.143679] bnx2 0000:02:00.0: irq 47 for MSI/MSI-X
Oct 24 10:59:54 sd-51340 kernel: [ 15.143684] bnx2 0000:02:00.0: irq 48 for MSI/MSI-X
Oct 24 10:59:54 sd-51340 kernel: [ 15.181414] bnx2 0000:02:00.0 eth0: using MSIX
Oct 24 10:59:57 sd-51340 kernel: [ 18.019919] bnx2 0000:02:00.0 eth0: NIC Copper Link is Up, 1000 Mbps full duplex


La seule différence que je vois pour le moment, c'est Debian qui utilise un ancien driver par rapport à Gentoo :

Quote:
GENTOO sd-51340 ~ # ethtool -i eth0
driver: bnx2
version: 2.2.3
firmware-version: 7.4.8 bc 7.4.0 NCSI 2.0.11
bus-info: 0000:02:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: no


Quote:
DEBIAN root@sd-51340:~# ethtool -i eth0
driver: bnx2
version: 2.1.11
firmware-version: 7.4.8 bc 7.4.0 NCSI 2.0.11
bus-info: 0000:02:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: no

_________________
Mythy'Zone - Blog technique / Jeux vidéos


Last edited by Mythy on Thu Oct 24, 2013 9:10 am; edited 1 time in total
Back to top
View user's profile Send private message
Mythy
n00b
n00b


Joined: 17 Jul 2012
Posts: 59

PostPosted: Thu Oct 24, 2013 9:10 am    Post subject: Reply with quote

El_Goretto wrote:
Autre piste, il y a parfois des firmwares qui vont avec les puces broadcom. Il n'est pas inenvisageable que charger le firmware à jour corrige un bug hardware (c'est du microcode pour le matériel, après tout).


Tu pourrais m'en dire plus ? ^^
_________________
Mythy'Zone - Blog technique / Jeux vidéos
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2862
Location: Paris

PostPosted: Thu Oct 24, 2013 9:51 am    Post subject: Reply with quote

Mythy wrote:
El_Goretto wrote:
Autre piste, il y a parfois des firmwares qui vont avec les puces broadcom. Il n'est pas inenvisageable que charger le firmware à jour corrige un bug hardware (c'est du microcode pour le matériel, après tout).


Tu pourrais m'en dire plus ? ^^


:)

Code:

[I] sys-kernel/linux-firmware
     Available versions:  20130421 ~20130530 ~20130711 20130728 **99999999 {savedconfig}
     Installed versions:  20130728(17:16:23 21/10/2013)(-savedconfig)
     Homepage:            http://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git
     Description:         Linux firmware files

# ls /lib/firmware/bnx2*
/lib/firmware/bnx2x-e1-4.8.53.0.fw  /lib/firmware/bnx2x-e1-5.2.7.0.fw    /lib/firmware/bnx2x-e1h-5.2.13.0.fw
/lib/firmware/bnx2x-e1-5.2.13.0.fw  /lib/firmware/bnx2x-e1h-4.8.53.0.fw  /lib/firmware/bnx2x-e1h-5.2.7.0.fw

/lib/firmware/bnx2:
bnx2-mips-06-4.6.16.fw    bnx2-mips-06-6.2.3.fw      bnx2-mips-09-6.0.17.fw  bnx2-rv2p-06-5.0.0.j3.fw   bnx2-rv2p-09-6.0.17.fw
bnx2-mips-06-5.0.0.j3.fw  bnx2-mips-09-4.6.17.fw     bnx2-mips-09-6.2.1a.fw  bnx2-rv2p-06-6.0.15.fw     bnx2-rv2p-09ax-5.0.0.j10.fw
bnx2-mips-06-5.0.0.j6.fw  bnx2-mips-09-5.0.0.j15.fw  bnx2-mips-09-6.2.1b.fw  bnx2-rv2p-09-4.6.15.fw     bnx2-rv2p-09ax-5.0.0.j3.fw
bnx2-mips-06-6.0.15.fw    bnx2-mips-09-5.0.0.j3.fw   bnx2-mips-09-6.2.1.fw   bnx2-rv2p-09-5.0.0.j10.fw  bnx2-rv2p-09ax-6.0.17.fw
bnx2-mips-06-6.2.1.fw     bnx2-mips-09-5.0.0.j9.fw   bnx2-rv2p-06-4.6.16.fw  bnx2-rv2p-09-5.0.0.j3.fw

/lib/firmware/bnx2x:
bnx2x-e1-6.0.34.0.fw  bnx2x-e1-7.0.29.0.fw  bnx2x-e1h-6.0.34.0.fw  bnx2x-e1h-7.0.29.0.fw  bnx2x-e2-6.0.34.0.fw  bnx2x-e2-7.0.29.0.fw
bnx2x-e1-6.2.5.0.fw   bnx2x-e1-7.2.16.0.fw  bnx2x-e1h-6.2.5.0.fw   bnx2x-e1h-7.2.16.0.fw  bnx2x-e2-6.2.5.0.fw   bnx2x-e2-7.2.16.0.fw
bnx2x-e1-6.2.9.0.fw   bnx2x-e1-7.2.51.0.fw  bnx2x-e1h-6.2.9.0.fw   bnx2x-e1h-7.2.51.0.fw  bnx2x-e2-6.2.9.0.fw   bnx2x-e2-7.2.51.0.fw
bnx2x-e1-7.0.20.0.fw  bnx2x-e1-7.8.17.0.fw  bnx2x-e1h-7.0.20.0.fw  bnx2x-e1h-7.8.17.0.fw  bnx2x-e2-7.0.20.0.fw  bnx2x-e2-7.8.17.0.fw
bnx2x-e1-7.0.23.0.fw  bnx2x-e1-7.8.2.0.fw   bnx2x-e1h-7.0.23.0.fw  bnx2x-e1h-7.8.2.0.fw   bnx2x-e2-7.0.23.0.fw  bnx2x-e2-7.8.2.0.fw


Normalement chargé par le driver au boot de la machine.
_________________
-PC: 2500K/P8Z68V, 8Go DDR3 1600 1.35V, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC + NF9D-2700, 4Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RDNU2000
Back to top
View user's profile Send private message
Mythy
n00b
n00b


Joined: 17 Jul 2012
Posts: 59

PostPosted: Thu Oct 24, 2013 10:50 am    Post subject: Reply with quote

Oui si je dis pas de bêtises il charge bnx2-mips-09-6.2.1b.fw

Mais comment je peux dire au kernel d'en charger un autre ?

(J'ai mis le driver dans le kernel, pas en module)
_________________
Mythy'Zone - Blog technique / Jeux vidéos
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2862
Location: Paris

PostPosted: Thu Oct 24, 2013 3:04 pm    Post subject: Reply with quote

Je ne saurais pas te dire comment spécifier explicitement un firmware plutôt qu'un autre, car en général, il n'y en a pas plusieurs mais un seul qui convient.
Exemple pour le driver broadcom tg3:
Code:
# ls /lib/firmware/tigon/
 tg3.bin  tg3_tso5.bin  tg3_tso.bin


Pour bnx2, c'est super bizarre, on dirait qu'il y en a plusieurs versions (noms des fichiers? on dirait du <driver>-<archi chip>-<ID chip>-<version>.fw). Et bizarrement, sous debian wheezy c'est pareil:
Code:
$ ls /lib/firmware/bnx2/
bnx2-mips-06-5.0.0.j3.fw  bnx2-mips-06-6.2.3.fw     bnx2-mips-09-6.2.1a.fw  bnx2-rv2p-06-5.0.0.j3.fw  bnx2-rv2p-09-5.0.0.j3.fw  bnx2-rv2p-09ax-5.0.0.j3.fw
bnx2-mips-06-6.2.1.fw     bnx2-mips-09-5.0.0.j3.fw  bnx2-mips-09-6.2.1b.fw  bnx2-rv2p-06-6.0.15.fw    bnx2-rv2p-09-6.0.17.fw    bnx2-rv2p-09ax-6.0.17.fw


--
edit: peut être une explication: http://packages.debian.org/wheezy/firmware-bnx2
Il semble que les firmwares ne soient pas retrocompatibles, donc à chaque version noyau correspond une certaine version du firmware. Mais normalement, le driver devrait prendre le bon au chargement.
_________________
-PC: 2500K/P8Z68V, 8Go DDR3 1600 1.35V, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC + NF9D-2700, 4Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RDNU2000
Back to top
View user's profile Send private message
StinGer_Uesugi
Tux's lil' helper
Tux's lil' helper


Joined: 12 Nov 2010
Posts: 125
Location: Milky Way > Solar System > Earth > France > Paris > Home

PostPosted: Thu Oct 24, 2013 4:43 pm    Post subject: Reply with quote

Totalement hors du sujet, désolé. :oops:

El_Goretto wrote:
Si j'en conviens, le coup de la MTU est un bonne idée, j'ai comme l'impression que le reste est un peu flou (en tout cas pour moi ;)). Le coup du NAT-T, ça ne concerne pas OpenVPN. C'est une technique liée à IPsec, si je ne m'abuse.

Oui j'y ai pensé après, je me suis mélangé entre OpenVPN et OpenSwan.

El_Goretto wrote:
Ensuite, le fait d'avoir des équipements qui routent successivement les paquets ne signifie pas que "plus il y en a, et plus il faut baisser la MTU".
Ceci dit, j'ai peut être mal compris ce que tu voulais dire :)

Non, pas du tout, sauf quand tu fais du IPSec, pour des raisons que j'ai un peu oubliées, dès que tu fais 2 NAT, il faut réduire le MTU. Je crois déjà que ce n'est vrai qu'en mode transport où le payload seulement est crypté mais où un NAT/PAT causerait une modification du hash. Du coup, encapsulation dans un autre paquet, overhead NAT-T et si le paquet encapsulé faisait déjà 1500 octets -> pan t'es mort parce que le paquet final déborde.
Mais honnêtement, j'ai oublié les détails donc je peux totalement me planter.

Et sinon pour en revenir au sujet, j'aurais jamais pensé aux blob binaires... Mais du coup, en renommant les fichiers/versions que tu ne veux pas, ça ne pourrait pas le faire ? C'est saaaaaaaaaaale je le reconnais, mais comme j'ai aucune idée non plus de comment spécifier au kernel quel firmware prendre exactement...

PS @Mythy : je précise que quand je parle de "smoke and fly", je fais référence à ça. Nan parce que sinon on va me prendre pour un drogué. :)
_________________
Why drink and drive when you can smoke and fly ?
Back to top
View user's profile Send private message
Mythy
n00b
n00b


Joined: 17 Jul 2012
Posts: 59

PostPosted: Fri Oct 25, 2013 8:29 am    Post subject: Reply with quote

Merci pour m'avoir lu et répondu

Mais malheureusement ça ne m'aide pas des masses à résoudre ce problème avec mes connaissances :/

J'ai donc abandonné l'idée de mettre le serveur VPN sur ce dédié Classic + Gen2
_________________
Mythy'Zone - Blog technique / Jeux vidéos
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2862
Location: Paris

PostPosted: Fri Oct 25, 2013 9:19 am    Post subject: Reply with quote

Pour ma culture, tu as dit avoir fait des tests avec des kernels, (c'est peut être idiot) mais tu as pu booter la gentoo en utilisant le kernel debian ("qui marche")? C'est pour savoir si c'est lié à la configuration le l'OS ou au matériel/drivers.
_________________
-PC: 2500K/P8Z68V, 8Go DDR3 1600 1.35V, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC + NF9D-2700, 4Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RDNU2000
Back to top
View user's profile Send private message
Mythy
n00b
n00b


Joined: 17 Jul 2012
Posts: 59

PostPosted: Fri Oct 25, 2013 9:23 am    Post subject: Reply with quote

Non je ne l'ai pas fais vu que je ne savais pas que c'était possible :)

Mais ça me semble une piste intéressante !

Tu pourrais me dire cmt je retrouve le kernel en place depuis Debian ?
_________________
Mythy'Zone - Blog technique / Jeux vidéos
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2862
Location: Paris

PostPosted: Fri Oct 25, 2013 9:31 am    Post subject: Reply with quote

Ah, j'imaginais que tu étais en dual boot sur cette machine.
Ben l'idée est de prendre le noyau et l'initrd de la debian (que tu rapportes avoir validé sur ce matériel), et de "merger" la config des bootloaders (grub?): partir de la conf débian mais en spécifiant les partitions/disques correspondant à ceux contenant la gentoo (visible dans la conf du bootloader en charge de la gentoo).

C'est peut être une grosse bêtise, ceci dit, je ne l'ai jamais fait moi-même :)
Mais là, comme çà, je ne vois pas ce qui pourrait bloquer techniquement.
_________________
-PC: 2500K/P8Z68V, 8Go DDR3 1600 1.35V, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC + NF9D-2700, 4Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RDNU2000
Back to top
View user's profile Send private message
Mythy
n00b
n00b


Joined: 17 Jul 2012
Posts: 59

PostPosted: Fri Oct 25, 2013 9:37 am    Post subject: Reply with quote

Pas de soucis mais je ne suis qu'en dédié même en local ;)

Par contre j'utilise grub:0 et je n'utilise pas d'initrd etc...

Sur la Debian dans /boot j'ai ça :

config-3.2.0-4-amd64 grub initrd.img-3.2.0-4-amd64 lost+found System.map-3.2.0-4-amd64 vmlinuz-3.2.0-4-amd64

Et sur Gentoo dans /boot j'ai que le kernel en un fichier

Comment je peux faire du coup ? :? Il y a moyen de récupérer le .config de la debian qq part ?
_________________
Mythy'Zone - Blog technique / Jeux vidéos
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2862
Location: Paris

PostPosted: Fri Oct 25, 2013 9:44 am    Post subject: Reply with quote

Je ne vais pas avoir le temps de te détailler tout point par point (de toutes façons, un peu de recherche, c'est bon pour ta culture aussi ;)), mais pour debian, c'est une config grub 2 qui est générée et visible sous /boot/grub/grub.cfg (je prends des raccourcis, pas taper ceux qui connaissent debian et grub2).
Pour gentoo, c'est du grub 1, et c'est /boot/grub/menu.lst (de tête).

Comme je disais, debian utilise un noyau ( vmlinuz-3.2.0-4-amd64 ) et un initrd (initrd.img-3.2.0-4-amd64) qu'il te faut prendre en compte dans la configuration de grub 1 que tu vas écrire (pour cela, je te renvois à la doc gentoo sur les bootloader, prends le cas ou tu as kernel+initrd.)
_________________
-PC: 2500K/P8Z68V, 8Go DDR3 1600 1.35V, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC + NF9D-2700, 4Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RDNU2000
Back to top
View user's profile Send private message
Mythy
n00b
n00b


Joined: 17 Jul 2012
Posts: 59

PostPosted: Fri Oct 25, 2013 12:09 pm    Post subject: Reply with quote

Sans grand espoir j'ai testé ça :

Copier le contenu de config-3.2.0-4-amd64 dans le .config sur Gentoo et compiler

C'est une config 3.2 et sur Gentoo je suis en 3.10.7, ça a bien compilé et installé

Par contre ça boot pas (pas de /var/log/messages), mais laissez tombé ça me gonfle ct'histoire ^_^'

Merci quand même pour votre aide :)
_________________
Mythy'Zone - Blog technique / Jeux vidéos
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5268
Location: ~Brussels - Belgique

PostPosted: Fri Oct 25, 2013 12:12 pm    Post subject: Reply with quote

Logique : tu dois d'abord faire un make oldconfig, puis vérifier la configuration avec make menuconfig : des trucs ont changé de nom, ont été restructurés, et il faut vérifier à la main. Ou prendre la même version de noyau, ce qui est plus sage pour commencer ;)
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2862
Location: Paris

PostPosted: Fri Oct 25, 2013 2:49 pm    Post subject: Reply with quote

Surtout, recompiler un noyau gentoo à partir d'une une config kernel debian est moins pertinent que prendre le noyau debian direct: en effet, on n'est pas à l'abri d'un patchset différent (probablement le cas d'ailleurs).
Donc si ça déconne toujours, on ne peut pas en conclure grand chose. :/
_________________
-PC: 2500K/P8Z68V, 8Go DDR3 1600 1.35V, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC + NF9D-2700, 4Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RDNU2000
Back to top
View user's profile Send private message
Mythy
n00b
n00b


Joined: 17 Jul 2012
Posts: 59

PostPosted: Sat Oct 26, 2013 12:34 pm    Post subject: Reply with quote

Oui certes mais bon après 5 jours @ 10heures/jour la dessus

Une pause s'impose :)
_________________
Mythy'Zone - Blog technique / Jeux vidéos
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum