Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
how can I completly mask ruby-rails-4 to use redmine?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
SteveYin
Tux's lil' helper
Tux's lil' helper


Joined: 20 Oct 2004
Posts: 88

PostPosted: Tue Oct 22, 2013 7:28 am    Post subject: how can I completly mask ruby-rails-4 to use redmine? Reply with quote

I'm using redmine as our project management system. today I've run emerge -uDN world to update my system.

But this make my ruby and rails upgraded to rails-4, so that my redmine stopped working.
Code:

rake aborted!
`attr_protected` is extracted out of Rails into a gem. Please use new recommended protection model for params(strong_parameters) or add `protected_attributes` to your Gemfile to use old one.
/var/lib/redmine/app/models/issue_relation.rb:73:in `<class:IssueRelation>'
/var/lib/redmine/app/models/issue_relation.rb:18:in `<top (required)>'
/var/lib/redmine/lib/redmine/helpers/gantt.rb:28:in `<class:Gantt>'
/var/lib/redmine/lib/redmine/helpers/gantt.rb:21:in `<module:Helpers>'
/var/lib/redmine/lib/redmine/helpers/gantt.rb:19:in `<module:Redmine>'
/var/lib/redmine/lib/redmine/helpers/gantt.rb:18:in `<top (required)>'
/var/lib/redmine/lib/redmine.rb:51:in `<top (required)>'
/var/lib/redmine/config/initializers/30-redmine.rb:4:in `<top (required)>'
/var/lib/redmine/config/environment.rb:16:in `<top (required)>'
Tasks: TOP => db:migrate => environment


I'm upgraded to redmine-2.3.2 version which supports the ruby-2.0, but I don't want rails-4, the only ruby thing I need is redmine, so with rails-4 installed, I can not use redmine any more.

I really don't know how to mask the rails-4, so I'm asking here hope I can get some help. Thanks.
_________________
Steve Yin
Back to top
View user's profile Send private message
SteveYin
Tux's lil' helper
Tux's lil' helper


Joined: 20 Oct 2004
Posts: 88

PostPosted: Tue Oct 22, 2013 7:29 am    Post subject: Reply with quote

according to the info, there is another solution, which is add 'protected_attributes' to the Gemfile, but, which Gemfile should I add this?

Redmine don't have any Gemfile.
_________________
Steve Yin
Back to top
View user's profile Send private message
SteveYin
Tux's lil' helper
Tux's lil' helper


Joined: 20 Oct 2004
Posts: 88

PostPosted: Tue Oct 22, 2013 2:34 pm    Post subject: Reply with quote

well, I have to emerge -C `ls /var/db/pkg/dev-ruby/`, then I use redmine's bundle install to install all these depends.

because redmine is the only ruby application I need.
_________________
Steve Yin
Back to top
View user's profile Send private message
weyerma
n00b
n00b


Joined: 26 Dec 2005
Posts: 11

PostPosted: Fri Oct 25, 2013 8:58 am    Post subject: Reply with quote

I recommend you, to create a redmine user and install RVM in its home.

https://rvm.io/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum