Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
OpenGL startx can not load correct intel video driver
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
lvii
n00b
n00b


Joined: 28 May 2012
Posts: 16

PostPosted: Tue Oct 22, 2013 2:39 am    Post subject: OpenGL startx can not load correct intel video driver Reply with quote

---

hi guys,

my laptop: thinkpad x230
Code:

    $ lspci -v

    00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Lenovo Device 21fa
        Flags: bus master, fast devsel, latency 0, IRQ 40
        Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 5000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [a4] PCI Advanced Features
        Kernel driver in use: i915

startx log:

Code:
libGL error: failed to load driver: i965


kwin failed using OpenGL backend with this error.

but my video driver is i915 :

Code:
    gentoo ~ # ls -l /usr/lib64/dri/i9*
    lrwxrwxrwx 1 root root 20 Oct 16 21:55 /usr/lib64/dri/i915_dri.so -> ../mesa/i915g_dri.so
    lrwxrwxrwx 1 root root 20 Oct 22 10:03 /usr/lib64/dri/i915g_dri.so -> ../mesa/i915g_dri.so
    lrwxrwxrwx 1 root root 19 Oct 16 21:55 /usr/lib64/dri/i965_dri.so -> ../mesa/i965_dri.so


the i965_dri.so didn't exist. it's a broken link file. '/usr/lib64/mesa/i965_dri.so' file didn't exist.

Code:
    # ls -l /usr/lib64/mesa/
    total 35404
    -rwxr-xr-x 1 root root   361432 Oct 22 10:03 i915_dri.so
    -rwxr-xr-x 1 root root 17993400 Oct 22 10:03 i915g_dri.so
    -rwxr-xr-x 1 root root    27016 Oct 22 10:03 swrast_dri.so
    -rwxr-xr-x 1 root root 17864792 Oct 22 10:03 swrastg_dri.so


my make.conf:

Code:
    gentoo ~ # grep intel /etc/portage/make.conf
    VIDEO_CARDS="intel"


mesa's USE just active the intel, I add i915 USE emerging the mesa

Code:
    # emerge -avj mesa
   
    [ebuild   R    ] media-libs/mesa-9.1.6  USE="bindist classic egl gallium llvm nptl shared-glapi -debug -gbm -gles1 -gles2 -openvg -osmesa -pax_kernel -pic (-r600-llvm-compiler) (-selinux) -vdpau (-wayland) -xa -xorg -xvmc" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6" VIDEO_CARDS="i915* intel -i965 -nouveau -r100 -r200 -r300 -r600 -radeon (-radeonsi) -vmware" 0 kB



when I restartx , this error didn't disappear.

Code:
    gentoo ~ # eselect mesa list
    i915 (Intel 915, 945)
      [1]   classic
      [2]   gallium *
    i965 (Intel 965, G/Q3x, G/Q4x)
    r300 (Radeon R300-R500)
    r600 (Radeon R600-R700, Evergreen, Northern Islands)
    sw (Software renderer)
      [1]   classic
      [2]   gallium *


how could I make the startx use i915 not i965 driver. thx :)

---
Back to top
View user's profile Send private message
nemectic
Apprentice
Apprentice


Joined: 20 Aug 2004
Posts: 181

PostPosted: Tue Oct 22, 2013 3:57 am    Post subject: Reply with quote

i915 is the correct kernel driver.
Mesa needs to be emerged with JUST the i965 driver.
xorg with intel driver.

It seems really backwards choosing a different driver in each place but it works. I also have an x230 & found the answer somewhere on these forums previously.

Hope that's everything you needed to know?


[edit]

Just for clarity, set VIDEO_CARDS="intel i965" in /etc/portage/make.conf, then:

Code:
VIDEO_CARDS=i965 emerge -av mesa


I'm sure there's a neater way of doing this, but it works none the less.
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 737
Location: Montréal

PostPosted: Tue Oct 22, 2013 4:39 am    Post subject: Reply with quote

Why not include all Intel related graphic cards in the variable
Code:
VIDEO_CARDS="i915 i965 intel"

than
Code:
emerge -aDNuv world

and let the Xorg Intel driver and the Mesa library pick the Opengl version they want? You can activate the uxa USE flag for the xf86-video-intel. It will make this acceleration method available and often use with the Intel driver.
Code:
echo -n 'x11-drivers/xf86-video-intel uxa' >> /etc/portage/package.use

_________________
Paul
Back to top
View user's profile Send private message
nemectic
Apprentice
Apprentice


Joined: 20 Aug 2004
Posts: 181

PostPosted: Tue Oct 22, 2013 4:46 am    Post subject: Reply with quote

There was an issue with the i965 mesa driver not working properly if the other drivers were available too...That may have been fixed by now though, I haven't honestly checked.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum