Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] how to use net printer vendor HP
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 85
Location: JiangSu,China

PostPosted: Wed Oct 16, 2013 2:38 pm    Post subject: [Solved] how to use net printer vendor HP Reply with quote

my office use a HP printer , HP LaserJet Professional M1216nfh MFP
it's used as net printer , just connect it to the office LAN ,then it can be used ,no more local host PC control.


I add USE=cups in make.conf

I find a application named " manage printers" in my system-tools menu
I clicked it

it open a webpage http://localhost:631
I click add printer,and cups discovered the net printer:
Code:

Add Printer
Local Printers:    
Discovered Network Printers:    HP LaserJet Professional M1216nfh MFP (HP LaserJet Professional M1216nfh MFP)
Other Network Printers:    Internet Printing Protocol (https)
...
continue


then it ask me to choose printer model
as it's a black-white printer,so I choose "HP laserjet series PCL 6 CUPS" (or HP laserjet series PCL 4/5 ,I tried both)
and then finish

I think I'm able to use it now, but I am wrong
in text editor, like gedit ot evince or gnumeric , I open a file and click print , I can see the printer " HP LaserJet Professional M1216nfh MFP " idle
I choose it and click print, but nothing happened , I just see the printer LED flash

in http://localhost:631
show all jobs, I see these:
Code:

▲ ID ▲   Name   User   Size   Pages   State   Control
HP_LaserJet_Professional_M1216nfh_MFP-9     Unknown     Withheld     197k     Unknown     canceled at
2013年10月16日 星期三 22时17分19秒
"Filter failed"    
 
HP_LaserJet_Professional_M1216nfh_MFP-8     Unknown     Withheld     36k     Unknown     canceled at
2013年10月16日 星期三 22时17分24秒
"Filter failed"    
 
HP_LaserJet_Professional_M1216nfh_MFP-7     Unknown     Withheld     36k     Unknown     canceled at
2013年10月16日 星期三 22时17分22秒
"Filter failed"    
 
HP_LaserJet_Professional_M1216nfh_MFP-6     Unknown     Withheld     21k     Unknown     completed at
2013年10月16日 星期三 22时16分42秒     
 
HP_LaserJet_Professional_M1216nfh_MFP-5     Unknown     Withheld     48k     2     completed at
2013年10月16日 星期三 22时03分25秒     
 
HP_LaserJet_Professional_M1216nfh_MFP-4     Unknown     Withheld     36k     1     completed at
2013年10月16日 星期三 21时59分31秒     
 
HP_LaserJet_Professional_M1216nfh_MFP-3     Unknown     Withheld     36k     1     completed at
2013年10月16日 星期三 21时59分18秒     
 
HP_LaserJet_Professional_M1216nfh_MFP-2     Unknown     Withheld     36k     Unknown     completed at
2013年10月16日 星期三 21时57分42秒     
 
HP_LaserJet_Professional_M1216nfh_MFP-1     Unknown     Withheld     36k     Unknown     completed at
2013年10月16日 星期三 21时55分44秒     
 


how to use the printer ?


Last edited by double_crane on Fri Oct 18, 2013 8:59 am; edited 3 times in total
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1223
Location: 42.68n 85.41w

PostPosted: Wed Oct 16, 2013 2:40 pm    Post subject: Reply with quote

your local system needs drivers... lucky you got hp...

as root
Code:

emerge hplip


then redo all that noise, there should be some wiki documentation about hp hplip & ethernet/wifi printing.
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
http://ecx.images-amazon.com/images/I/81Ku-vxIb3L._SL1500_.jpg
http://wiki.gentoo.org/wiki/Special:Contributions/666threesixes666
Back to top
View user's profile Send private message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 85
Location: JiangSu,China

PostPosted: Wed Oct 16, 2013 2:59 pm    Post subject: Reply with quote

666threesixes666 wrote:
your local system needs drivers... lucky you got hp...

as root
Code:

emerge hplip


then redo all that noise, there should be some wiki documentation about hp hplip & ethernet/wifi printing.


thank you

I emerge hplip
and I find Driver: HP LaserJet Professional m1216nfh MFP, hpcups 3.13.9, requires proprietary plugin
when set device model

but when I print doc , cups log says status " stopped "Filter failed" "

how to solve ? thanks
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1223
Location: 42.68n 85.41w

PostPosted: Wed Oct 16, 2013 3:43 pm    Post subject: Reply with quote

so ive been told.... ie not from me, a filter is basically a printer driver. i have not taken the time to identify this as true or false.

net-print/cups-filters might be of interest?

requires proprietary plugin when set device model? i really don't have enough info to address this, and my strong suit is not printers. id try to get the printer to print local first with a usb cord though, then once that works migrate to ethernet, and then wifi if it supports it.

i think you can diagnose, and everything to the point of printing from the hplip utility so long as cups is running. "think" my 2 hp printers do this, but neither of them are network, and my old wifi network printing setup is @ my sisters house.
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
http://ecx.images-amazon.com/images/I/81Ku-vxIb3L._SL1500_.jpg
http://wiki.gentoo.org/wiki/Special:Contributions/666threesixes666
Back to top
View user's profile Send private message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 85
Location: JiangSu,China

PostPosted: Thu Oct 17, 2013 8:07 am    Post subject: Reply with quote

thank you

now I think it's caused by the plugin.
for the printer hplip need a proprietary plugin (*.run) , I've been searching it for 2hours,and don't konw where to get it.

I find in Arch wiki , there is a package named "hplip-plugin",but none for Gentoo.

I've started service avahi-daemon as Arch Wiki told and re-emerge cups with USE="-filters"

but the error status info is still "stopped,filter failed"

At this webpage : http://hplipopensource.com/hplip-web/plugin.html
says the proprietary plugin is required for m1216 , or the scan and print won't be supported.

use command hp-setup,or hp-plugins, it print
Code:

dc@K650C ~ $  hp-setup

HP Linux Imaging and Printing System (ver. 3.13.9)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: Fax setup disabled - Python 2.3+ required.
Searching... (bus=net, timeout=5, ttl=4, search=(None) desc=0, method=slp)
warning:  distro is not found in AUTH_TYPES
| / -- \ | / -- \.....

the process dies at last.

any ideas to download the HP proprietary plugin ?
Back to top
View user's profile Send private message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 85
Location: JiangSu,China

PostPosted: Thu Oct 17, 2013 8:31 am    Post subject: Reply with quote

seovikrama2z wrote:
you need drivers!!!!!


what do you mean ?

I just ask HP for support,ask them to send me the proprietary plugin ,but they told me to search http://hplipopensource.com/hplip-web/index.html , no more answers , oh, shit.

I know I need drivers ,hplip is not enough
but I don't know where to find the drivers.....

any help?thank you
Back to top
View user's profile Send private message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 85
Location: JiangSu,China

PostPosted: Thu Oct 17, 2013 8:49 am    Post subject: Reply with quote

I find the download address justly!!

I use ps -aux
Code:

dc@K650C ~ $ ps -aux |grep hp
dc        2205  0.0  0.5 382584 41716 ?        Ss   16:35   0:00 python2.7 /usr/bin/hp-systray -x
dc        2274  0.0  0.1 158720 13124 ?        S    16:35   0:00 python2.7 /usr/bin/hp-systray -x
dc        2275  0.0  0.1 129852 10604 ?        S    16:35   0:00 python2.7 /usr/bin/hp-systray -x
root      4030  0.0  0.0  64084  3056 pts/0    S+   16:38   0:00 sudo hp-setup
root      4031  0.0  0.4 284216 38652 pts/0    S+   16:38   0:00 /usr/bin/python2.7 /usr/bin/hp-setup
root      4109  0.0  0.1 152640 15712 ?        S    16:38   0:00 python2.7 /usr/bin/hp-pkservice
root      4118  0.0  0.2 232788 19012 pts/1    Ss+  16:38   0:00 /usr/bin/kdesu -- hp-plugin -u --required --reason 65 To_install_plugin_for_HP_Device
root      4124  0.0  0.4 272296 35496 pts/1    S+   16:38   0:00 python2.7 /usr/bin/hp-plugin -u --required --reason 65 To_install_plugin_for_HP_Device
root      4309  0.0  0.0  32968  2012 pts/2    Ss+  16:39   0:00 /usr/bin/wget --cache=off -P /var/log/hp/tmp http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.13.9-plugin.run
dc        4570  0.3  0.4 368376 33524 ?        Sl   16:39   0:01 /usr/lib64/firefox/plugin-container /opt/Adobe/flash-player/flash-plugin/libflashplayer.so -greomni /usr/lib64/firefox/omni.ja 3217 plugin
dc        7978  0.0  0.0  13536   960 pts/3    S+   16:44   0:00 grep --colour=auto hp


see? http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.13.9-plugin.run

but the plugin file doesn't exist !!!
that's why the hp-setup dies !!

#########################################################

maybe the file exist
I can't connect to www.openprinting.org

holy shit china garverment!!

can anyone download this file ?

send it to double_crane@qq.com or org.doublecrane@gmail.com ?, OK?
thank you

god bless you
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4563
Location: Saint Amant, Acadiana

PostPosted: Thu Oct 17, 2013 1:45 pm    Post subject: Reply with quote

openprinting.org seems to be down, try http://sourceforge.net/projects/hplip/
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 85
Location: JiangSu,China

PostPosted: Fri Oct 18, 2013 8:59 am    Post subject: Reply with quote

Jaglover wrote:
openprinting.org seems to be down, try http://sourceforge.net/projects/hplip/


thank you
but http://sourceforge.net/projects/hplip don't have plugins for download

thank god , openprinting.org is up today.
I download the hplip-plugin,and install it (eselect python 2.7) ,succeed.

Now I can print now.

thank you all.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum