Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] DBUS still wants HAL, which is now deprecated
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
xtz
Apprentice
Apprentice


Joined: 29 Oct 2007
Posts: 172
Location: Belfast, UK

PostPosted: Sun Oct 13, 2013 9:36 pm    Post subject: [SOLVED] DBUS still wants HAL, which is now deprecated Reply with quote

I'm using LXDE and every time I'm logging out I'm getting:
** (lxsession-logout:2061): WARNING **: dbus-interface.c:94: DBUS: The name org.freedesktop.Hal was not provided by any .service files

Since HAL has been deprecated for some time now, I'm not sure that it has a USE flag, but even if it does - it's not hal as I have -hal in make.conf just in case.
DBUS has been installed with only X enabled:
Code:
=================================================================
                        Package Settings
=================================================================

sys-apps/dbus-1.6.12 was built with the following:
USE="X -debug -doc (-selinux) -static-libs -systemd -test"
CFLAGS="-march=native -O3 -pipe -fomit-frame-pointer -ftree-vectorize -rdynamic"
CXXFLAGS="-march=native -O3 -pipe -fomit-frame-pointer -ftree-vectorize -rdynamic"

and nothing seems to be using hal:
Code:
Xecutor ~ # quse hal
dev-lang/erlang/erlang-15.2.3.1.ebuild compat-ethread doc emacs halfword hipe java kpoll odbc smp sctp ssl tk wxwidgets
dev-lang/erlang/erlang-16.1-r1.ebuild compat-ethread doc emacs halfword hipe java kpoll odbc smp sctp ssl tk wxwidgets
dev-lang/erlang/erlang-16.1.ebuild compat-ethread doc emacs halfword hipe java kpoll odbc smp sctp ssl tk wxwidgets
dev-lang/erlang/erlang-16.ebuild compat-ethread doc emacs halfword hipe java kpoll odbc smp sctp ssl tk wxwidgets

This is my .xinitrc file:
Code:
xtz@Xecutor ~ $ cat .xinitrc
exec ck-launch-session startlxde


Last edited by xtz on Mon Oct 14, 2013 10:08 am; edited 2 times in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5267

PostPosted: Sun Oct 13, 2013 9:39 pm    Post subject: Reply with quote

That message is safe to be ignored - it says only what it says.
If there's no other message, lxsession is most likely using upower.
Back to top
View user's profile Send private message
xtz
Apprentice
Apprentice


Joined: 29 Oct 2007
Posts: 172
Location: Belfast, UK

PostPosted: Sun Oct 13, 2013 9:42 pm    Post subject: Reply with quote

lxsession is in fact using upower, I explicitly remember enabling it:
Code:
=================================================================
                        Package Settings
=================================================================

lxde-base/lxsession-0.4.6.1 was built with the following:
USE="dbus nls upower"


Should this be reported as a bug :?:
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5267

PostPosted: Mon Oct 14, 2013 8:56 am    Post subject: Reply with quote

Nah, not really.
Perhaps upstream could have done it in a less noisy way, but as long as conditions are met, things work as they're supposed to.
Back to top
View user's profile Send private message
xtz
Apprentice
Apprentice


Joined: 29 Oct 2007
Posts: 172
Location: Belfast, UK

PostPosted: Mon Oct 14, 2013 10:08 am    Post subject: Reply with quote

Tnx, marking as solved then.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum