Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] URxvt and UTF8
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
eleanor
l33t
l33t


Joined: 01 Nov 2004
Posts: 664

PostPosted: Fri Oct 11, 2013 5:47 pm    Post subject: [SOLVED] URxvt and UTF8 Reply with quote

Hi,

I've been having problems with UTF8 support in my urxvt. Take a look at this pstree output:

Quote:

# pstree
─┬────ck-launch-sessi───awesome
├─urxvt───bash───urxvt───bash


The problem is that the UTF8 characters don't work in the first urxvt, but work in the second urxvt/bash. I've started the second urxvt rigth from the first urxvt, but the first urxvt was started directly by awesome WM by using this code.

Code:

function shortcut_console()
  scratch.drop("urxvt","top","left",1,0.58,1)
end


I've also checked and both urxvt instances are Interactive and are not login shells, so the env variables should be the same.

Any ideas why the problem occurs. I guess it has something to do with awesome spawning?


Last edited by eleanor on Sat Nov 23, 2013 3:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
mackal
Tux's lil' helper
Tux's lil' helper


Joined: 04 Aug 2011
Posts: 78

PostPosted: Fri Oct 11, 2013 6:26 pm    Post subject: Reply with quote

Just a guess, but is your locale settings set right? I could imagine if they're not set correctly when the first terminal is started it could cause problems (say you're setting it to *.utf8 in .bashrc or something)

I could also be completely wrong.
Back to top
View user's profile Send private message
eleanor
l33t
l33t


Joined: 01 Nov 2004
Posts: 664

PostPosted: Fri Oct 11, 2013 7:09 pm    Post subject: Reply with quote

Yes, I solved it. Before starting X by startx command, I executed the following command in the terminal:

Code:

LC_CTYPE=en_US.UTF-8


Now, I only need to add the same command in to the /etc/rc.local.
Back to top
View user's profile Send private message
mackal
Tux's lil' helper
Tux's lil' helper


Joined: 04 Aug 2011
Posts: 78

PostPosted: Sat Oct 12, 2013 2:34 am    Post subject: Reply with quote

http://wiki.gentoo.org/wiki/UTF-8#Setting_up_UTF-8_with_Gentoo_Linux

I would follow those instructions.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum