Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
urxvt and font problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
krax
n00b
n00b


Joined: 29 May 2011
Posts: 67
Location: Troy, MI

PostPosted: Thu Oct 10, 2013 2:21 pm    Post subject: urxvt and font problem Reply with quote

Hello ;
I don't know; maybe it started right after a world upgrade. Now urxvt does not start
Code:
 ~ $ urxvt
urxvt: unable to load base fontset, please specify a valid one using -fn, aborting.


Well more information :
i emerged it with XFT and lot more look:
Code:

eix rxvt-unicode
[I] x11-terms/rxvt-unicode
     Available versions:  9.18^t {256-color alt-font-width blink buffer-on-clear fading-colors +focused-urgency +font-styles iso14755 +mousewheel +perl pixbuf secondary-wheel startup-notification unicode3 +vanilla wcwidth xft}
     Installed versions:  9.18^t(05:36:51 PM 10/10/2013)(256-color alt-font-width focused-urgency font-styles mousewheel perl startup-notification xft -blink -buffer-on-clear -fading-colors -iso14755 -pixbuf -secondary-wheel -unicode3 -vanilla -wcwidth)
     Homepage:            http://software.schmorp.de/pkg/rxvt-unicode.html
     Description:         rxvt clone with xft and unicode support


i did urxvt -fn with many fonts in my font list but just urxvt -fn fixed works.
well i don't know what to do and it already took 3 days of me; any idea at this point will be appropriated.
Very much Thanks
Back to top
View user's profile Send private message
nemectic
Apprentice
Apprentice


Joined: 20 Aug 2004
Posts: 181

PostPosted: Thu Oct 10, 2013 2:56 pm    Post subject: Reply with quote

Try using xset to add the fonts to the directories it looks in ie:

Code:
xset +fp /usr/share/fonts/terminus/


That allows me to use the terminus font with urxvt.

Code:
urxvt -fn -*-terminus-*-*-*-*-*-*-*-*-*-*-*-*


Of course, it's easier to put the font in .Xresources when you decide which you're happy with.

Code:
eselect fontconfig


Is another option!
Back to top
View user's profile Send private message
krax
n00b
n00b


Joined: 29 May 2011
Posts: 67
Location: Troy, MI

PostPosted: Thu Oct 10, 2013 3:16 pm    Post subject: Reply with quote

the problem is :
some these fonts that I am trying to use aren't in portage or overlay; so i pasted them in the /usr/local/share/fonts and then i did fc-cache -fv.
Now in the case like me the mkfontdir /usr/local/share/fonts doesn't help because this utility only indexes some font suffixes(1) or X and .ttf fonts isn't one of them
So xlsfonts | grep conso* doesn not find consolas.ttf anywhere in my system. and urxvt -fn consolas returns error


(1)http://publib.boulder.ibm.com/infocenter/pseries/v5r3/index.jsp?topic=/com.ibm.aix.cmds/doc/aixcmds3/mkfontdir.htm


This is in my ~/.xinitrc
Code:
URxvt.termName: rxvt-unicode
!URxvt.imLocale: fr_FR.UTF-8
URxvt.saveLines: 5000
URxvt.cursorBlink: true
URxvt.foreground: #bcbcbc
URxvt.background: #4682B4   
URxvt.cursorColor: #e0e080
URxvt.throughColor: #8080f0
URxvt.highlightColor: #343434
!URxvt.transparent: true
URxvt.tintColor: #E6E6E6
URxvt.fading: 40
URxvt.visualBell: true
URxvt.urgentOnBell: true
URxvt.font: -*-Consolas-medium-*-*-*-12-*-*-*-*-*-*-*
URxvt.scrollBar: false
URxvt.scrollBar_right: false
URxvt.urlLauncher: luakit
URxvt.matcher.button: 3
URxvt.perl-ext-common: default,matcher
! colors
! link
URxvt.colorUL: #4E9A06
! black
URxvt.color0: #2E3436
URxvt.color8: #555753
! red
URxvt.color1: #CC0000
URxvt.color9: #EF2929
! green
URxvt.color2: #4E9A06
URxvt.color10: #8AE234
! yellow
URxvt.color3: #C4A000
URxvt.color11: #FCE94F
! blue
URxvt.color4: #3465A4
URxvt.color12: #729FCF
! purple
URxvt.color5: #75507B
URxvt.color13: #AD7FA8
! cyan
URxvt.color6: #06989A
URxvt.color14: #34E2E2
! white
URxvt.color7: #D3D7CF
URxvt.color15: #EEEEEC
Back to top
View user's profile Send private message
nemectic
Apprentice
Apprentice


Joined: 20 Aug 2004
Posts: 181

PostPosted: Thu Oct 10, 2013 3:52 pm    Post subject: Reply with quote

Code:
mkfontscale /usr/share/$FONTDIR
mkfontdir /usr/share/$FONTDIR
xset +fp /usr/share/$FONTDIR


The above works for me with .ttf fonts.

Obviously replace $FONTDIR with whatever the folder you're trying to load is.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum