Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
login hangs for normal user
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
difficultcho
n00b
n00b


Joined: 15 Mar 2013
Posts: 9

PostPosted: Mon Oct 07, 2013 11:14 pm    Post subject: login hangs for normal user Reply with quote

After the last "update @world", I am not able to see my desktop any more. The gdm can take me to the graphical login interface, but if I login with my account, it will just hang at the black (dark gray actually) screen. Though root account can login to the desktop.

/var/log/Xorg.0.log seems normal. There are only three "EE"s complaining no module "vesa", "modesetting" and "fbdev". I assume these are fine as I use an Intel graphics card (which is indeed loaded).

I am using: xf86-video-intel-2.99.903, xorg-server-1.14.3-r1, gnome-3.8.0 and kernel 3.11

I also deleted .Xauthority, .ICEauthority, .gconfd and so on files. It didn't help.

I found some warning from /var/log/gdm/:0.log about xkbcomp, so I tried
Quote:
setxkbmap -print


Interestingly, it complains
Quote:
Cannot open display "default display"


So I guess somehow my user cannot find the default display? Thanks a lot for any help in advance!
Back to top
View user's profile Send private message
difficultcho
n00b
n00b


Joined: 15 Mar 2013
Posts: 9

PostPosted: Tue Oct 08, 2013 2:49 am    Post subject: solved Reply with quote

ok, this link
http://www.mail-archive.com/gentoo-user@lists.gentoo.org/msg141426.html
saved my life
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum