Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Kernel 3.10, Xorg 1.14, Radeon HD 7850 Blank/Hang
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
edoceo
n00b
n00b


Joined: 29 Nov 2005
Posts: 2
Location: Seattle, WA

PostPosted: Mon Oct 07, 2013 10:13 pm    Post subject: [solved] Kernel 3.10, Xorg 1.14, Radeon HD 7850 Blank/Hang Reply with quote

With Gentoo Source 3.10, Xorg 1.14, ATI Radeon HD 7850 hardware the system would hang when loading X, or provide a blank/black screen.
I have this video card, in Intel i5 some ASUS mainboard, I forget which.
I saw few posts related to this, so I'll just collate them together.

While working on this issue I disabled startx from the default runlevel, just to make things easier and login as root to do my work.
Had to rebuild kernel, then xorg & drivers, and test at each few steps.

My make.conf has

Code:
VIDEO_CARDS="radeon radeonsi"


Had to cleanup the old junk

emerge -Cv radeon-ucode

Then, using gentoo-source for 3.10 I configured my Graphics settings like indicated in this thread

http://forums-web2.gentoo.org/viewtopic-t-965210.html?sid=48a3983218fd0e95b6cfe9914ee75c5a

After that kernel build, reboot. Then rebuild these and reboot once more

Code:
emerge -1av linux-firmware xorg-server ati-drivers xf86-input-evdev


Run these three at which point you should see an X cursor on a grey/black crosshatch background.
Press CTRL+ALT+BKSP or switch to VT1 again (CTRL+ALT+F1) and the ctrl+c to stop X.
If X fails to start here, examine the Xorg.0.log file.

Code:
eselect opengl set ati
aticonfig --initial
X -retro


Then this should give you a bare desktop environment, in my case Xfce, at which point I logout.
If X fails to start here, examine the Xorg.0.log file.

Code:
startx


It seems to be working so far so start via XDM to get Slim involved in the process.

Code:
 /etc/init.d/xdm start


Now it's all back to normal.

In the process my screens acquired new names so I had to replace

Code:
xrandr --output DVI-1 --right-of DVI-0


with

Code:
xrandr --output DFP7 --right-of DFP6
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 441
Location: Venice FL

PostPosted: Tue Oct 08, 2013 6:40 pm    Post subject: Reply with quote

for starters use gentoo-sources-3.11.3

There were some bugs fixed that affected the radeonsi cards.

I have a 7750.

and this may help as well.
http://wiki.gentoo.org/wiki/Radeon

George
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 441
Location: Venice FL

PostPosted: Tue Oct 08, 2013 6:43 pm    Post subject: Reply with quote

oops, disregard my post, you are not using the open source drivers. :oops:

George
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum