Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
net-fs/autofs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
leonixyz
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2012
Posts: 76

PostPosted: Thu Oct 03, 2013 5:59 am    Post subject: net-fs/autofs Reply with quote

Autofs doesn't mount and I have no idea why...

kernel is enabled...
# grep AUTOFS /usr/src/linux/.config
Code:
CONFIG_AUTOFS4_FS=y


configuration files seems to be ok...
# grep -v # /etc/autofs/auto.master
Code:
/mnt/   /etc/autofs/auto.misc

#grep -v # /etc/autofs/auto.misc
Code:
usb      -fstype=auto,async,nodev,nosuid,umask=000   :/dev/sdb1


the service is running...
rc-update | grep autofs
Code:
               autofs |      default


When I put an usb stick in, nothing happens...
I also have no idea what other information collect to resolv the problem
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1405
Location: Montréal

PostPosted: Thu Oct 03, 2013 6:58 am    Post subject: Reply with quote

I am not sure if it's better to say /mnt or /mnt/ as the root mount point of Autofs. You can try without the slash. A possibility is to use the ghost option to create the sub-directory usb before you enter in what start to mount the USB device. You can specify the delay of inactivity after which it will be umounted.

Your mount option umask say that /dev/sdb1 could be a Fat or Ntfs filesystem. So it can be more precise to say vfat,ntfs than auto or one of the two only, at least for tests.
_________________
Paul
Back to top
View user's profile Send private message
s_bernstein
Apprentice
Apprentice


Joined: 11 Mar 2006
Posts: 172
Location: Bremen, Germany

PostPosted: Thu Oct 03, 2013 8:26 am    Post subject: Reply with quote

Also, autofs will mount your drive on first access, so plugging in your usb drive is not enough. You must access /mnt/usb to get autofs to mount your drive.
Back to top
View user's profile Send private message
leonixyz
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2012
Posts: 76

PostPosted: Thu Oct 03, 2013 9:09 pm    Post subject: Reply with quote

s_bernstein wrote:
Also, autofs will mount your drive on first access, so plugging in your usb drive is not enough. You must access /mnt/usb to get autofs to mount your drive.


This solved my problem, thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum