Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Horrible performance/low fps in 3d...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
blackkstar
n00b
n00b


Joined: 14 Nov 2012
Posts: 11

PostPosted: Thu Oct 03, 2013 5:10 pm    Post subject: [SOLVED] Horrible performance/low fps in 3d... Reply with quote

I've been having very bad performance in 3d applications like TF2 native, LoL in WINE, and I've been having odd issues with my KDE desktop where it will start running very poorly. At worst windows contents won't update anymore and they start to flicker.

I'm seeing frame rates at about a third of what I normally see in Windows and I know this isn't right. I've looked up other folk's benchmarks online and they're pulling 200fps+ in TF2 in Linux with worse hardware than I have.

I don't really know where to start. I've tried to google and I haven't found much.

xorg.conf:
Code:
Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Monitor"
        Identifier   "0-DFP10"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
        Option      "PreferredMode" "2560x1440"
        Option      "TargetRefresh" "60"
        Option      "Position" "0 0"
        Option      "Rotate" "normal"
        Option      "Disable" "false"
EndSection

Section "Monitor"
        Identifier   "0-DFP9"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
        Option      "TargetRefresh" "60"
        Option      "Position" "2560 46"
        Option      "Rotate" "normal"
        Option      "Disable" "false"
        Option      "PreferredMode" "1920x1200"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        Option      "Monitor-DFP10" "0-DFP10"
        Option      "Monitor-DFP9" "0-DFP9"
        BusID       "PCI:1:0:0"
EndSection

Section "Device"
        Identifier  "amdcccle-Device[1]-1"
        Driver      "fglrx"
        Option      "Monitor-DFP9" "0-DFP9"
        BusID       "PCI:1:0:0"
        Screen      1
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Virtual   4480 2560
                Depth     24
        EndSubSection
EndSection

Section "Screen"
        Identifier "amdcccle-Screen[1]-1"
        Device     "amdcccle-Device[1]-1"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection


Running fglrx on a 7970. I have two monitors, one 1200p and one 1440p.

When playing TF2, when I enable multi-core rendering I get horrible mouse input lag and the sound can start stuttering at times. In LoL in WINE, the sound plays in slow motion and is very stuttery. I am running ALSA without pulseaudio if it matters, I don't have a .asoundrc file set up but it's being shared properly.

Any help would be appreciated. I shouldn't be getting 30fps to 70fps on TF2 with an overclocked 8350 and 7970. Thanks.[/code]

EDIT: I completely fixed this and it was much easier than I ever thought!

Apparently, KDE v-sync options apply to all the games you are running as well. So what I was seeing was KDE trying to limit TF2 frame rate to 60fps instead of the ~300fps I would normally see.

So much recompiling and digging for problems when it was a simple drop down option in:

System Settings -> Desktop Effects -> Advanced -> Tearing Prevention (VSYNC) -> None

Hope this helps someone else who wanders here in from google. [/b]


Last edited by blackkstar on Mon Oct 21, 2013 4:38 am; edited 2 times in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Thu Oct 03, 2013 6:40 pm    Post subject: Reply with quote

blackkstar,

Please post your /var/log/Xorg.0.log on a pastebin

xorg.conf tells what you asked Xorg to do.
The log tells what it actually did.

IS you normal user in the video group?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
blackkstar
n00b
n00b


Joined: 14 Nov 2012
Posts: 11

PostPosted: Thu Oct 03, 2013 7:27 pm    Post subject: Reply with quote

http://pastebin.com/7MAegCxh

Yes, I am in video group. No errors in xorg. I'm not sure if I'm missing any libraries or something. I installed the st3c one.

Wow, I think I just compiled the kernel wrong previously. I feel pretty derp.

http://wiki.gentoo.org/wiki/Fglrx

I must not have done something right last time. Playing now with 200fps+ Updated to latest kernel today and checked what I wrecked and it's all good.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum