Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]: Help needed with cfg80211 spamming logs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
hippy-ted
n00b
n00b


Joined: 13 Sep 2007
Posts: 24

PostPosted: Mon Sep 30, 2013 6:23 am    Post subject: [SOLVED]: Help needed with cfg80211 spamming logs Reply with quote

Hi, since upgrading from gentoo-sources-3.8.13 to 3.10.7-r1, my logs have been spammed with this every 3-5s:
Code:
kernel: cfg80211: Calling CRDA for country: 97
kernel: cfg80211: Calling CRDA to update world regulatory domain
kernel: cfg80211: World regulatory domain updated:
kernel: cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
kernel: cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
kernel: cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
kernel: cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
kernel: cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
kernel: cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

This is on a Thinkpad T420 with Centrino Advanced-N 6205 AGN wireless card, using the iwlwifi driver.

The wireless connection still seems to work, which distinguishes it from many similar reports on the web that I've seen.

/etc/modprobe.d/cfg80211.conf contains:
Code:
options cfg80211 ieee80211_regdom=UK

/etc/conf.d/net contains:
Code:
modules="!iproute2 !iwconfig"
modules_enp0s25="dhcp"
modules_wlp3s0="wpa_supplicant"
config_wlp3s0="dhcp"
dhcp="release"
wpa_supplicant_wlp3s0="-Dnl80211"

/etc/wpa_supplicant/wpa_supplicant.conf contains:
Code:
ctrl_interface=/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=1
country=GB
network={
        ssid="............."
        scan_ssid=0
        psk="..............."
        priority=5
}

These are my loaded modules:
Code:
Module                  Size  Used by
iwlmvm                 97018  0
acpi_call               4424  0
tp_smapi               16678  0
thinkpad_ec             4005  1 tp_smapi
btusb                  16933  0
bluetooth             219597  2 btusb
iwldvm                131694  0
mac80211              444760  2 iwldvm,iwlmvm
kvm                   408601  0
crc32c_intel           14215  0
microcode               7407  0
pcspkr                  2006  0
iwlwifi                85106  2 iwldvm,iwlmvm
cfg80211              462180  4 iwlwifi,mac80211,iwldvm,iwlmvm
thinkpad_acpi          70282  0
e1000e                196865  0
rfkill                 18530  4 cfg80211,thinkpad_acpi,bluetooth
shpchp                 26776  0

I have ensured that power management is off for wlp3s0 and Network Manager and wicd do not run as mentioned elsewhere.

What else should I check?


Last edited by hippy-ted on Mon Sep 30, 2013 2:22 pm; edited 2 times in total
Back to top
View user's profile Send private message
Terrere
n00b
n00b


Joined: 03 Sep 2006
Posts: 72
Location: Basel (CH)

PostPosted: Mon Sep 30, 2013 7:38 am    Post subject: Reply with quote

hi,

my X230 with Centrino Advanced-N 6205 AGN wireless card, (rev 34)
try:

/etc/conf.d/net:
Code:

...
wpa_supplicant_wlp3s0="-Dwext"
...

bb
Back to top
View user's profile Send private message
hippy-ted
n00b
n00b


Joined: 13 Sep 2007
Posts: 24

PostPosted: Mon Sep 30, 2013 1:00 pm    Post subject: Reply with quote

Hello Terrere, thanks for your help,
Terrere wrote:
try:
Code:

...
wpa_supplicant_wlp3s0="-Dwext"
...

I tried that but cfg80211 still spammed my logs. In fact the spam continues even when /etc/init.d/net.wlp3s0 is stopped.
So now I've built a new kernel with
Code:
CONFIG_CFG80211_REG_DEBUG=y
and syslog now endlessly reports:
Code:
kernel: cfg80211: Calling CRDA for country: 97
kernel: cfg80211: Timeout while waiting for CRDA to reply, restoring regulatory settings
kernel: cfg80211: Keeping preference on module parameter ieee80211_regdom: UK
kernel: cfg80211: Kicking the queue
kernel: cfg80211: Calling CRDA to update world regulatory domain
kernel: cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain
kernel: cfg80211: World regulatory domain updated:
kernel: cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
kernel: cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
kernel: cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
kernel: cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
kernel: cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
kernel: cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

The line Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain looks important, but I'm not sure I understand it yet.
Back to top
View user's profile Send private message
hippy-ted
n00b
n00b


Joined: 13 Sep 2007
Posts: 24

PostPosted: Mon Sep 30, 2013 2:18 pm    Post subject: Reply with quote

Oh dear! I think its all a matter of country codes. It seems that when I change /etc/modprobe.d/cfg80211.conf from
Code:
options cfg80211 ieee80211_regdom=UK
to
Code:
options cfg80211 ieee80211_regdom=GB
all my troubles are over! The Irish might have something to say about that!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum