Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Installing SELinux
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
stunirvana21
n00b
n00b


Joined: 24 May 2011
Posts: 41

PostPosted: Sun Sep 29, 2013 8:39 pm    Post subject: [Solved] Installing SELinux Reply with quote

I am trying to install SELinux on a fresh install following this guide: www.gentoo.org/proj/en/hardened/selinux/selinux-handbook.xml?part=2&chap=1

However, when I get up to 1.b. Configure SELinux, I am having trouble. When I try to emerge checkpolicy and policycoreutils, I get a circular dependency that I don't know how to resolve.
Code:

[nomerge       ] sys-apps/policycoreutils-2.1.14-r2  USE="pam -audit -dbus -sesandbox"
[ebuild  N     ]  dev-python/sepolgen-1.1.9-r2  359 kB
[ebuild  N     ]   sec-policy/selinux-base-2.20130424-r2  USE="open_perms peer_perms ubac -doc -unconfined" 880 kB
[ebuild  N     ]    sys-apps/policycoreutils-2.1.14-r2  USE="pam -audit -dbus -sesandbox" 1,663 kB

Total: 3 packages (3 new), Size of downloads: 2,902 kB

 * Error: circular dependencies:

(dev-python/sepolgen-1.1.9-r2::gentoo, ebuild scheduled for merge) depends on
 (sec-policy/selinux-base-2.20130424-r2::gentoo, ebuild scheduled for merge) (buildtime)
  (sys-apps/policycoreutils-2.1.14-r2::gentoo, ebuild scheduled for merge) (buildtime)
   (dev-python/sepolgen-1.1.9-r2::gentoo, ebuild scheduled for merge) (runtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.



Here is the output of emerge --info
Code:

Portage 2.2.1 (hardened/linux/x86/selinux, gcc-4.6.3, glibc-2.15-r3, 3.10.1-hardened-r1 i686)
=================================================================
System uname: Linux-3.10.1-hardened-r1-i686-AMD_Phenom-tm-_II_X4_955_Processor-with-gentoo-2.2
KiB Mem:     2072540 total,   1949932 free
KiB Swap:     937980 total,    937980 free
Timestamp of tree: Sat, 28 Sep 2013 19:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.5-r2, 3.2.5-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.12.6, 1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe -march=amdfam10"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe -march=amdfam10"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-march=i686 -O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox selinux sesandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=i686 -O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
USE="berkdb bindist bzip2 cli cracklib crypt cxx dri gdbm hardened iconv modules mudflap ncurses nls nptl open_perms openmp pam pax_kernel pcre pic readline selinux session ssl tcpd unicode urandom x86 zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 intel mach64 mga nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa via vmware nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON


/etc/portage/package.use
Code:

sys-libs/libselinux static-libs
dev-libs/libpcre static-libs
sec-policy/selinux-base -unconfined


Could someone point me in the right direction? Thanks.


Last edited by stunirvana21 on Tue Oct 01, 2013 12:03 am; edited 1 time in total
Back to top
View user's profile Send private message
landdie
n00b
n00b


Joined: 10 Sep 2013
Posts: 26
Location: Southern Sweden

PostPosted: Mon Sep 30, 2013 1:15 pm    Post subject: Reply with quote

Maybe you've fixed it by now but if not read
Quote:
Code Listing 5.9: Portage warning about circular dependencies. at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2&chap=1
Back to top
View user's profile Send private message
N8Fear
Tux's lil' helper
Tux's lil' helper


Joined: 15 Apr 2013
Posts: 140
Location: Berlin (Germany)

PostPosted: Mon Sep 30, 2013 3:40 pm    Post subject: Reply with quote

1st: If there's no open bug on that issue: open it
2nd: In the meantime it should be possible to emerge policycoreutils with the --nodeps ("emerge --nodeps policycoreutils") - you should reemerge it the four packages that form the circle - just to be sure...

Addition: if emerge --nodeps policycoreutils fails, try to emerge each of the other packages with --nodeps. One should work and break the circle (in this case at least).
Back to top
View user's profile Send private message
stunirvana21
n00b
n00b


Joined: 24 May 2011
Posts: 41

PostPosted: Tue Oct 01, 2013 12:02 am    Post subject: Reply with quote

Something must have been out of order in the portage tree. I resynchronized today and it worked. Sorry for the bother...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum