Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Black Screen with nvidia drivers
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Faraclas
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2014
Posts: 76

PostPosted: Mon Dec 08, 2014 11:45 pm    Post subject: Black Screen with nvidia drivers Reply with quote

Hey guys. I'm pretty new to Gentoo these days [I ran a few Gentoo systems about a decade ago in school, now I am trying to get back in] and I am having a beast of a time with the nvidia drivers. Here is a bit of background... I tried a Gentoo install from scratch [nvidia, systemd, gnome 3.8] and nothing worked. It was too ambitious. So to verify the hardware compatibility with linux drivers, I installed Linux Mint 17 on the system including the nvidia drivers (wireless, sound, etc.) Since everything was working, I wrote down what modules were being used for the hardware and decided to try Gentoo again.

So I had a nice working system (OpenRC, Xfce, network manager, sound, etc) using the nouveau driver. I figured since everything else was working, that is would be easy to do the switch to the nvidia drivers.

I followed the wiki http://wiki.gentoo.org/wiki/NVidia/nvidia-drivers and rebooted and now have a blank screen. I cant get into another console (ALT+F<anything>) to see what is going on. I have checked the following:
    Made sure kernel configuration is as specified: no framebuffers, no nouveau, no DRI
    I am using the right version of the nvidia drivers (the latest 340 drivers which I verified in Linux Mint)
    Use flags and others as specified in the Wiki
    /etc/init.d/modules has "nvidia" called out (along with sky2 [ehternet], ath9k [wireless], and agpgart [per wiki])
    dbus is set to run on the default level

I have searched the forums and found similar issues but nothing I thought could help me so far. [/list]

Can someone please help me troubleshoot this? I was getting so excited to have a Gentoo system again, and my wife is almost onboard to try and use it!!! Thanks in advance.
Back to top
View user's profile Send private message
Faraclas
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2014
Posts: 76

PostPosted: Tue Dec 09, 2014 12:07 am    Post subject: Reply with quote

Ok I am making progress...

Code:
/etc/X11/xorg.conf.d/20-nvidia.conf
Section "Device"
        Identifier "Nvidia Card"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
EndSection


Now I do get into slim and can log into Xfce after seeing the nvidia logo. The problem now is that my screen is being detected as 3480x1080, when it is really only 1920x1080.

I looked in /etc/X11 and there is no xorg.conf that exists. Inside /etc/X11/xorg.conf.d there is just the file I already created above. Using NVIDIA X Server Settings (the gtk GUI) I do not see any means of specifying the size.

Thanks!
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 5088
Location: Saint Amant, Acadiana

PostPosted: Tue Dec 09, 2014 12:40 am    Post subject: Reply with quote

You can create more conf files, they all will be read by Xorg. For instance 30-screen.conf.
See what options nvidia driver accepts in /usr/share/doc/nvidia-drivers-<version>
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Faraclas
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2014
Posts: 76

PostPosted: Tue Dec 09, 2014 4:10 am    Post subject: Reply with quote

Thanks! I ran the gtk GUI for configuring the card and was able to select the right configuration for a single monitor with the right resolution. Then I went to save the configuration, and it showed me a preview of the file. I instead took your advice and created several more files in /etc/X11/xorg.conf.d. Rebooted and the display is very nice!

However, not I have another problem... I can't see anything except for X. When the system boots, I choose the option from Grub and see initializing the RAM fs and then it goes black for about 15s until the nvidia logo flashes, then it goes black until the slim login. Then, when shutting down, it goes black for the whole process.

So how do I get visualization back? The wiki instructed me to disable all frame buffers, so I did.

Thanks for the help guys!
Back to top
View user's profile Send private message
Faraclas
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2014
Posts: 76

PostPosted: Tue Dec 09, 2014 5:33 pm    Post subject: Reply with quote

I made a little progress using the uvesafb (http://wiki.gentoo.org/wiki/Uvesafb)

Now when it boots I can see the text up until the Wiat for uevents to process line. After this, the screen goes black for about 15s until the nvidia splash screen flashes and then I am into slim. Then, when shutting down the system, the screen goes crazy after x shuts down until the computer is off. So something is still not right with this setup and the nvidia drivers.

I am using the following in /etc/default/grub
Code:
GRUB_CMDLINE_LINUX="rootfstype=ext4 video=uvesafb:1600x1200-32,mtrr:3,ywrap"
Back to top
View user's profile Send private message
Faraclas
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2014
Posts: 76

PostPosted: Thu Dec 11, 2014 7:07 am    Post subject: Reply with quote

Hey Guys, any additional help on this one? I'm kind of stuck...
Back to top
View user's profile Send private message
aweal
n00b
n00b


Joined: 24 Jul 2014
Posts: 1

PostPosted: Fri Dec 12, 2014 3:11 pm    Post subject: Reply with quote

Faraclas wrote:
Hey Guys, any additional help on this one? I'm kind of stuck...


maybe its nvidia and 3.18 kernel, as for me

Quote:
* Gentoo supports kernels which are supported by NVIDIA
* which are limited to the following kernels:
* <sys-kernel/gentoo-sources-3.18
* <sys-kernel/vanilla-sources-3.18

cat /var/log/Xorg.0.log | grep EE
Quote:
[ 991.288] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[ 991.288] (EE) NVIDIA: system's kernel log for additional error messages and
[ 991.288] (EE) NVIDIA: consult the NVIDIA README for details.
[ 991.288] (EE) No devices detected.
Back to top
View user's profile Send private message
Faraclas
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2014
Posts: 76

PostPosted: Fri Dec 12, 2014 3:36 pm    Post subject: Reply with quote

So just to reiterate, my nvidia drivers are working GREAT now!!! The problem is that once the nvidia moduule loads, I cannot see anything on the terminals. So I cant see the boot action or the shutdown. Worse, if I make a mistake on something and goof stuff up, I cant ALT+CTRL+F# to stop X or do anything...
Back to top
View user's profile Send private message
Faraclas
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2014
Posts: 76

PostPosted: Sun Dec 14, 2014 5:32 pm    Post subject: Reply with quote

Hey guys, these nvidia drivers are really kicking my butt here.

I upgraded to version 340.65 and they don't work properly anymore.

It says it is using 1920x1080, but EVERYTHING is too big. So it must be actually running in some other resolution.
* NVIDIA Xserver Settings reports 1920x1080
Code:
elias@EpicLinux ~ $ xdpyinfo | grep dimensions
  dimensions:    1920x1080 pixels (361x200 millimeters)


BUT my terminals now take up half the screen, conky is not fitting on the screen anymore, etc, etc. If is definately NOT 1920x1080

I would like to roll back to version 340.58, but I can't seem to get portage to find the ebuild. It seems portage can only find the 340.65 version

Can anyone please please help fix this?
a) How do I rollback to nvidia-drivers-340.58
b) Is there another way to make my screen actually display 1920x1080

I was supposed to take my computer to show a friend how awesome my gentoo system was tonight. (I know, dont ever do any updates before you need to do something important). Now I'm bumming cause I cant show him this...
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2952
Location: UK

PostPosted: Sun Dec 14, 2014 7:34 pm    Post subject: Reply with quote

Faraclas wrote:
So just to reiterate, my nvidia drivers are working GREAT now!!! The problem is that once the nvidia moduule loads, I cannot see anything on the terminals. So I cant see the boot action or the shutdown. Worse, if I make a mistake on something and goof stuff up, I cant ALT+CTRL+F# to stop X or do anything...

This has always been the case, for over 10 years. There is no workaround. It's the sacrifice you make for using nvidia drivers/cards.
_________________
runit-init howto | Overlay - gtk2 stuff
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 33408
Location: 56N 3W

PostPosted: Sun Dec 14, 2014 7:48 pm    Post subject: Reply with quote

Ant P.,

vesafb used to work with the binary blob and may still do so. The latest drivers do not support my 5 year old GeForce 9800 GT, so I can't test.
You will get dire warnings when the nvidia kernel module loads about you configuration is unsupported.
If vesafb fails, the plain old vga text console will still work but then you won't get any tux logos on starup and can't play videos on the console.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
jburns
l33t
l33t


Joined: 18 Jan 2007
Posts: 872
Location: Massachusetts USA

PostPosted: Sun Dec 14, 2014 7:53 pm    Post subject: Reply with quote

I use the UVESA frame buffer driver with a builtin initramfs of INITRAMFS_SOURCE="/usr/share/v86d/initramfs" in the past I have used the VESA frame buffer driver. They seem to compatible with the nvidia-drivers.
Back to top
View user's profile Send private message
Faraclas
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2014
Posts: 76

PostPosted: Sun Dec 14, 2014 9:18 pm    Post subject: Reply with quote

Thanks for the replies. I went back in to check my config and I did not have
Code:
INITRAMFS_SOURCE="/usr/share/v86d/initramfs"

set. I added in into the config via
Code:
genkernel --menuconfig all
emerge @module-rebuild

but still no framebuffer output appearing.

Also, any ideas what is going on with the nvidia-driver-340-65? The nvidia-driver-340-5x was working great!

Thanks again
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 33408
Location: 56N 3W

PostPosted: Sun Dec 14, 2014 9:24 pm    Post subject: Reply with quote

Faraclas,

Code:
INITRAMFS_SOURCE="/usr/share/v86d/initramfs"
provides support for the uvesa framebuffer.
You need to select it in the kernel too.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
comprookie2000
Developer
Developer


Joined: 25 Jul 2004
Posts: 913
Location: Pompano Beach, Florida

PostPosted: Sun Dec 14, 2014 9:36 pm    Post subject: Reply with quote

In your first post you quoted the wiki;
"Made sure kernel configuration is as specified: no framebuffers, no nouveau, no DRI "
I have found this as true, I don't use any framebuffer myself.
/etc/default/grub for grub 2
Code:

# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/files/grub.default-2,v 1.4 2013/09/21 18:10:55 floppym Exp $
#
# To populate all changes in this file you need to regenerate your
# grub configuration file afterwards:
#     'grub2-mkconfig -o /boot/grub/grub.cfg'
#
# See the grub info page for documentation on possible variables and
# their associated values.

GRUB_DISTRIBUTOR="Gentoo"

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=10

# Append parameters to the linux kernel command line
GRUB_CMDLINE_LINUX="init=/usr/lib/systemd/systemd"

# Append parameters to the linux kernel command line for non-recovery entries
#GRUB_CMDLINE_LINUX_DEFAULT=""

# Uncomment to disable graphical terminal (grub-pc only)
GRUB_TERMINAL=console

# The resolution used on graphical terminal.
# Note that you can use only modes which your graphic card supports via VBE.
# You can see them in real GRUB with the command `vbeinfo'.
#GRUB_GFXMODE=640x480

# Path to theme spec txt file.
# The starfield is by default provided with use truetype.
# NOTE: when enabling custom theme, ensure you have required font/etc.
#GRUB_THEME="/boot/grub/themes/starfield/theme.txt"

# Background image used on graphical terminal.
# Can be in various bitmap formats.
#GRUB_BACKGROUND="/boot/grub/mybackground.png"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to kernel
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY=true


I use dual monitors but here is my /etc/X11/xorg.conf Like it was said you can use a folder also if you want, I just put it all in one file.
Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 331.20  (buildmeister@swio-display-x86-rhel47-05)  Wed Oct 30 18:20:53 PDT 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "ServerFlags"
   Option         "Xinerama" "0"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
   Option         "Composite" "true"
EndSection

_________________
http://dev.gentoo.org/~dabbott/
Back to top
View user's profile Send private message
Faraclas
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2014
Posts: 76

PostPosted: Sun Dec 14, 2014 11:13 pm    Post subject: Reply with quote

For the INITRAMFS_SOURCE I only put that in the kereel config. Do I need to put it into grub as well? How?
Back to top
View user's profile Send private message
jburns
l33t
l33t


Joined: 18 Jan 2007
Posts: 872
Location: Massachusetts USA

PostPosted: Mon Dec 15, 2014 3:51 am    Post subject: Reply with quote

If your going to use UVESA see http://wiki.gentoo.org/wiki/Uvesafb
Back to top
View user's profile Send private message
Faraclas
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2014
Posts: 76

PostPosted: Mon Dec 15, 2014 8:52 pm    Post subject: Reply with quote

jburns wrote:
If your going to use UVESA see http://wiki.gentoo.org/wiki/Uvesafb


Yeah, I followed this guide (a few times now) and have not been able to get it working. I'm open to other options. Really anything that can allow me to a) watch it boot and b) [more importantly] kill X to get to a console would be awesome.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 33408
Location: 56N 3W

PostPosted: Mon Dec 15, 2014 9:22 pm    Post subject: Reply with quote

Faraclas,

Put your kernel .config on a pastebin site.
wgetpaste is your friend.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Faraclas
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2014
Posts: 76

PostPosted: Mon Dec 15, 2014 10:12 pm    Post subject: Reply with quote

Edit - deleted this cause it was me not reading properly...
Back to top
View user's profile Send private message
Faraclas
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2014
Posts: 76

PostPosted: Mon Dec 15, 2014 11:48 pm    Post subject: Reply with quote

Well guys, I redid the uvesafb wiki and....


it works!!!!!! Thanks for all of your help!
Back to top
View user's profile Send private message
Maffblaster
Developer
Developer


Joined: 01 May 2007
Posts: 42
Location: Spokane, Washington, USA

PostPosted: Fri Dec 19, 2014 12:44 am    Post subject: Reply with quote

Good hear hear that someone was able to get Nvidia Drivers working in Gentoo. I tried a few months ago on a newer notebook, but wasn't able to successfully get anything working.

Maybe I'll try again...it would be nice to connect more than just the default monitor to the notebook.
_________________
I'm an active contributor on the Wiki.
My blog: http://maffblaster.github.io
My website: http://www.digitalsurvival.us
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 33408
Location: 56N 3W

PostPosted: Fri Dec 19, 2014 10:26 pm    Post subject: Reply with quote

Maffblaster,

nVidia ... notebook ...

Do you have an Optimus graphics system?
That works but its a different problem to the one discussud in this thread.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Maffblaster
Developer
Developer


Joined: 01 May 2007
Posts: 42
Location: Spokane, Washington, USA

PostPosted: Fri Dec 19, 2014 10:48 pm    Post subject: Reply with quote

Hi Neddy,

It is Optimus. Do you have a solution to get it properly setup and working? Do you have it Optimus as well?

Thanks!
_________________
I'm an active contributor on the Wiki.
My blog: http://maffblaster.github.io
My website: http://www.digitalsurvival.us
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 33408
Location: 56N 3W

PostPosted: Fri Dec 19, 2014 11:51 pm    Post subject: Reply with quote

Maffblaster,

I don't have any hardware that new. There are several threads nere ending in success.
Its also documented in the nvidia README file which gets installed with nvidia-drivers.
From memory, its around chapter 33.

Be sure to use up to date information. There is a lot of development going on aruond hybrid graphics systems.
As a result, there is more that one solution. Be sure not to try to mix different solutions.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum