Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plasma segfaults on ~amd64 [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
vespaman
Apprentice
Apprentice


Joined: 28 Aug 2002
Posts: 251
Location: Stockholm, Sweden

PostPosted: Mon Sep 23, 2013 10:29 am    Post subject: Plasma segfaults on ~amd64 [solved] Reply with quote

During the week-end I shut off my computer for the first time in about a week, with the result today, that plasma desktop segfaults.

I guess I must have done some update since last restart, that I have forgotten about. I have done preserved-rebuild and revdep-rebuild, and updated today.
Still problem.

I had a similar issue on my x86 laptop, but there I could start plasma manually, but this does not work on this ~amd64 box.

From command line I get:
Code:
 $ plasma-desktop
QDBusObjectPath: invalid path ""
plasma-desktop(24973)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability
plasma-desktop(24973)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability
KCrash: Attempting to start /usr/bin/plasma-desktop from kdeinit
sock_file=/home/micke/.kde4/socket-jones/kdeinit4__0
KCrash: Application 'plasma-desktop' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
sock_file=/home/micke/.kde4/socket-jones/kdeinit4__0
plasma-desktop(24972): Communication problem with  "plasma-desktop" , it probably crashed.
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "


And the KDE Crash handler gives:

Code:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#5  0x00007fd408299dd5 in QMetaObject::cast(QObject*) const () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007fd3fd4cac7a in ?? () from /usr/lib64/libplasma.so.3
#7  0x00007fd3fd4cb51e in Plasma::loadScriptEngine(QString const&, Plasma::Applet*) () from /usr/lib64/libplasma.so.3
#8  0x00007fd3fd4167f5 in ?? () from /usr/lib64/libplasma.so.3
#9  0x00007fd3fd41dc9c in Plasma::Applet::Applet(QObject*, QList<QVariant> const&) () from /usr/lib64/libplasma.so.3
#10 0x00007fd3fd45ef80 in Plasma::PluginLoader::loadApplet(QString const&, unsigned int, QList<QVariant> const&) () from /usr/lib64/libplasma.so.3
#11 0x00007fd3fd42cd9e in ?? () from /usr/lib64/libplasma.so.3
#12 0x00007fd3fd433380 in Plasma::Containment::restoreContents(KConfigGroup&) () from /usr/lib64/libplasma.so.3
#13 0x00007fd3fd4345e0 in Plasma::Containment::restore(KConfigGroup&) () from /usr/lib64/libplasma.so.3
#14 0x00007fd3fd43e7fb in ?? () from /usr/lib64/libplasma.so.3
#15 0x00007fd3fd43f0f2 in Plasma::Corona::loadLayout(QString const&) () from /usr/lib64/libplasma.so.3
#16 0x00007fd3fd43f1bc in Plasma::Corona::initializeLayout(QString const&) () from /usr/lib64/libplasma.so.3
#17 0x00007fd3f635d723 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#18 0x00007fd3f635e35d in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#19 0x00007fd3f6361cd5 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#20 0x00007fd4082ad20e in QObject::event(QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#21 0x00007fd40744d3a4 in QApplication::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#22 0x00007fd4074458ec in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#23 0x00007fd407448272 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#24 0x00007fd4090567d6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#25 0x00007fd4082939de in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#26 0x00007fd408296fa9 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/qt4/libQtCore.so.4
#27 0x00007fd4082c1ba3 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#28 0x00007fd403db6055 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#29 0x00007fd403db6398 in ?? () from /usr/lib64/libglib-2.0.so.0
#30 0x00007fd403db6454 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#31 0x00007fd4082c1d36 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#32 0x00007fd4074e641e in ?? () from /usr/lib64/qt4/libQtGui.so.4
#33 0x00007fd40829268f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#34 0x00007fd408292918 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#35 0x00007fd408297b78 in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#36 0x00007fd3f63479d1 in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#37 0x00000000004088ea in _start ()


:?


Last edited by vespaman on Tue Sep 24, 2013 7:08 am; edited 1 time in total
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2060
Location: Near Toronto

PostPosted: Mon Sep 23, 2013 12:44 pm    Post subject: Reply with quote

the same to me last week; don't know what caused it

I moved ~/.kde4/share/config/*plasma* and it worked
again (had to reset my prefs :evil: )
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
lvii
n00b
n00b


Joined: 28 May 2012
Posts: 16

PostPosted: Tue Sep 24, 2013 7:00 am    Post subject: Reply with quote

I have the same problem. I use the stable branch.

last night I install the networkmanager and kde-misc/networkmanagement

Code:

gentoo ~ # emerge -avj networkmanager kde-misc/networkmanagement


when I add the networkmanager widget to the panel . the plasma was crashed.

when I relogin KDE. it was always crashed.

I can not use the Networkmanager to mange my wireless connections. so sad :-(
Back to top
View user's profile Send private message
vespaman
Apprentice
Apprentice


Joined: 28 Aug 2002
Posts: 251
Location: Stockholm, Sweden

PostPosted: Tue Sep 24, 2013 7:08 am    Post subject: Reply with quote

albright wrote:
the same to me last week; don't know what caused it

I moved ~/.kde4/share/config/*plasma* and it worked
again (had to reset my prefs :evil: )



Thanks, that worked - lost my settings, but at least plasma is up again! :( :) :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum