Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Complie error with pango, can not find x11[resolved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
clouds222
Apprentice
Apprentice


Joined: 13 Jul 2009
Posts: 187
Location: Shanghai

PostPosted: Mon Sep 23, 2013 2:38 am    Post subject: Complie error with pango, can not find x11[resolved] Reply with quote

I encounter the issue while updating Gnome.

It is reported can't find x11 to configuring pango 1.3.4, while emerging gtk+.
I've installed libX11 1.6.2, but there is no x11.pc in pkgconfig folder.

I have upgraded gcc to 4.8.1 from 4.6.3 following the guide to rebuild libtool.

PS:

Resolved by
Code:

ln -sf /proc/self/hd /dev/fd


Last edited by clouds222 on Wed Oct 09, 2013 2:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
fturco
Apprentice
Apprentice


Joined: 08 Dec 2010
Posts: 240
Location: Italy

PostPosted: Mon Sep 23, 2013 6:06 am    Post subject: Reply with quote

Please post the output of the emerge error so we can understand better. emerge --info would be great, too.
Back to top
View user's profile Send private message
clouds222
Apprentice
Apprentice


Joined: 13 Jul 2009
Posts: 187
Location: Shanghai

PostPosted: Sun Oct 06, 2013 3:14 am    Post subject: Reply with quote

homeserver ~ # emerge libX11 --info
Portage 2.2.7 (default/linux/amd64/13.0/desktop/gnome, gcc-4.7.3, glibc-2.17, 3.11.1-gentoo x86_64)
=================================================================
System Settings
=================================================================
System uname: Linux-3.11.1-gentoo-x86_64-Intel-R-_Core-TM-_i7-4700EQ_CPU_@_2.40GHz-with-gentoo-2.2
KiB Mem: 16318648 total, 15920104 free
KiB Swap: 530140 total, 530140 free
Timestamp of tree: Unknown
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash: 4.2_p45
dev-lang/python: 2.7.5-r2, 3.2.5-r2, 3.3.2-r2
dev-util/cmake: 2.8.11.2
dev-util/pkgconfig: 0.28
sys-apps/baselayout: 2.2
sys-apps/openrc: 0.12
sys-apps/sandbox: 2.6-r1
sys-devel/autoconf: 2.69
sys-devel/automake: 1.11.6, 1.13.4, 1.14
sys-devel/binutils: 2.23.2
sys-devel/gcc: 4.7.3-r1
sys-devel/gcc-config: 1.8
sys-devel/libtool: 2.4.2
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.11 (virtual/os-headers)
sys-libs/glibc: 2.17
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo fonts.conf"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS=" http://mirrors.163.com/gentoo/ http://mirrors.sohu.com/gentoo/ ftp://mirrors.stuhome.net/gentoo/ rsync://mirrors.stuhome.net/gentoo/ http://mirrors.stuhome.net/gentoo/ rsync://mirrors.xmu.edu.cn/gentoo/ http://mirrors.xmu.edu.cn/gentoo http://gentoo.aditsu.net:8000/ rsync://gentoo.lagis.at/gentoo-distfiles/ http://gentoo.lagis.at/ http://gentoo.arcticnetwork.ca/ rsync://mirror.the-best-hosting.net/gentoo-distfiles ftp://ftp.kaist.ac.kr/gentoo/ http://ftp.kaist.ac.kr/pub/gentoo/ rsync://rsync.gtlib.gatech.edu/gentoo http://lug.mtu.edu/gentoo/ ftp://lug.mtu.edu/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.cn.gentoo.org/gentoo-portage"
USE="############################### #USE Gnome############ X a52 aac acl acpi alsa amd64 apache2 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam ffmpeg firefox flac flag for fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv introspection jpeg lcms ldap libnotify libsecret mad mmx mng modules mp3 mp4 mpeg mudflap multilib mysql nautilus ncurses networking nls nptl ogg opengl openmp pam pango pcre pdf php png policykit ppds pulseaudio qt3support qt4 readline sdl session socialweb spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upcall upower usb vorbis wxwidgets x264 xcb xinerama xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda_intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="vesa i915 fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
Package Settings
=================================================================

x11-libs/libX11-1.6.2 was built with the following:
USE="-doc -ipv6 -static-libs -test" ABI_X86="64 -32 -x32"


Last edited by clouds222 on Sun Oct 06, 2013 3:24 am; edited 1 time in total
Back to top
View user's profile Send private message
clouds222
Apprentice
Apprentice


Joined: 13 Jul 2009
Posts: 187
Location: Shanghai

PostPosted: Sun Oct 06, 2013 3:20 am    Post subject: Reply with quote

I think it didn't call the pkgconfig during the pkg building. I have do emerege --depclean after emerge -avuDN world after emerger gnome.

A set of packags are unmerged. And then issue occurs when I emerge libX11.

Again, I met the issue with a fresh DISK gentoo13 install.


Last edited by clouds222 on Sun Oct 06, 2013 3:27 am; edited 1 time in total
Back to top
View user's profile Send private message
clouds222
Apprentice
Apprentice


Joined: 13 Jul 2009
Posts: 187
Location: Shanghai

PostPosted: Sun Oct 06, 2013 3:21 am    Post subject: Reply with quote

Code:


homeserver ~ # emerge libX11
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) x11-libs/libX11-1.6.2
 * libX11-1.6.2.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                          [ ok ]
>>> Unpacking source...
>>> Unpacking libX11-1.6.2.tar.bz2 to /var/tmp/portage/x11-libs/libX11-1.6.2/work
>>> Source unpacked in /var/tmp/portage/x11-libs/libX11-1.6.2/work
>>> Preparing source in /var/tmp/portage/x11-libs/libX11-1.6.2/work/libX11-1.6.2 ...
 * Applying libX11-1.1.4-aix-pthread.patch ...                                                                                                        [ ok ]
 * Applying libX11-1.1.5-winnt-private.patch ...                                                                                                      [ ok ]
 * Applying libX11-1.1.5-solaris.patch ...                                                                                                            [ ok ]
 * Running eautoreconf in '/var/tmp/portage/x11-libs/libX11-1.6.2/work/libX11-1.6.2' ...
 * Running libtoolize --install --copy --force --automake ...                                                                                         [ ok ]
 * Running aclocal -I m4 ...                                                                                                                          [ ok ]
 * Running autoconf ...                                                                                                                               [ ok ]
 * Running autoheader ...                                                                                                                             [ ok ]
 * Running automake --add-missing --copy ...                                                                                                          [ ok ]
 * Running elibtoolize in: libX11-1.6.2/
 *   Applying portage/1.2.0 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.4.2 patch ...
 *   Applying target-nm/2.4.2 patch ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-libs/libX11-1.6.2/work/libX11-1.6.2 ...
/var/tmp/portage/x11-libs/libX11-1.6.2/temp/environment: line 3131: /dev/fd/62: No such file or directory
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-libs/libX11-1.6.2/work/libX11-1.6.2 ...
/var/tmp/portage/x11-libs/libX11-1.6.2/temp/environment: line 3149: /dev/fd/62: No such file or directory
>>> Source compiled.
>>> Test phase [not enabled]: x11-libs/libX11-1.6.2

>>> Install libX11-1.6.2 into /var/tmp/portage/x11-libs/libX11-1.6.2/image/ category x11-libs
/var/tmp/portage/x11-libs/libX11-1.6.2/temp/environment: line 3149: /dev/fd/62: No such file or directory
/var/tmp/portage/x11-libs/libX11-1.6.2/temp/environment: line 3668: /dev/fd/62: No such file or directory
>>> Completed installing libX11-1.6.2 into /var/tmp/portage/x11-libs/libX11-1.6.2/image/

/usr/lib64/portage/bin/ebuild-helpers/prepstrip: line 292: /dev/fd/62: No such file or directory
/usr/lib64/portage/bin/ebuild-helpers/ecompressdir: line 72: /dev/fd/62: No such file or directory
/usr/lib64/portage/bin/ebuild-helpers/ecompressdir: line 72: /dev/fd/62: No such file or directory
/usr/lib64/portage/bin/ebuild-helpers/ecompressdir: line 72: /dev/fd/62: No such file or directory
/usr/lib64/portage/bin/ebuild-helpers/ecompressdir: line 72: /dev/fd/62: No such file or directory
/usr/lib64/portage/bin/ebuild-helpers/ecompressdir: line 72: /dev/fd/62: No such file or directory
ecompressdir: bzip2 -9 /usr/share/doc
/usr/lib64/portage/bin/ebuild-helpers/ecompressdir: line 72: /dev/fd/62: No such file or directory

>>> Installing (1 of 1) x11-libs/libX11-1.6.2
>>> needed    sym /usr/lib64/libX11-xcb.so.1
>>> needed    obj /usr/lib64/libX11-xcb.so.1.0.0
>>> needed    sym /usr/lib64/libX11.so.6
>>> needed    obj /usr/lib64/libX11.so.6.3.0
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: x11-libs/libX11-1.6.2
 *  - /usr/lib64/libX11.so.6
 *  - /usr/lib64/libX11.so.6.3.0
 *      used by /usr/bin/Xephyr (x11-base/xorg-server-1.14.3)
 *      used by /usr/bin/cairo-sphinx (x11-libs/cairo-1.12.16)
 *      used by /usr/bin/dbus-launch (sys-apps/dbus-1.6.14)
 *      used by 245 other files
 *  - /usr/lib64/libX11-xcb.so.1
 *  - /usr/lib64/libX11-xcb.so.1.0.0
 *      used by /usr/bin/xdpyinfo (x11-apps/xdpyinfo-1.3.1)
 *      used by /usr/lib64/libpulse-mainloop-glib.so.0.0.4 (media-sound/pulseaudio-4.0)
 *      used by /usr/lib64/libpulse-simple.so.0.0.4 (media-sound/pulseaudio-4.0)
 *      used by 85 other files
>>> package: x11-libs/libXext-1.3.2
 *  - /usr/lib64/libXext.so.6
 *  - /usr/lib64/libXext.so.6.4.0
 *      used by /usr/bin/Xephyr (x11-base/xorg-server-1.14.3)
 *      used by /usr/bin/gnome-screenshot (media-gfx/gnome-screenshot-3.8.3)
 *      used by /usr/bin/metacity (x11-wm/metacity-2.34.13)
 *      used by 47 other files
>>> package: x11-libs/libXi-1.7.2
 *  - /usr/lib64/libXi.so.6
 *  - /usr/lib64/libXi.so.6.1.0
 *      used by /usr/bin/gnome-control-center (gnome-base/gnome-control-center-3.8.5)
 *      used by /usr/bin/xdpyinfo (x11-apps/xdpyinfo-1.3.1)
 *      used by /usr/lib64/gnome-settings-daemon-3.0/libcursor.so (gnome-base/gnome-settings-daemon-3.8.5)
 *      used by 40 other files
>>> package: x11-libs/libXinerama-1.1.3
 *  - /usr/lib64/libXinerama.so.1
 *  - /usr/lib64/libXinerama.so.1.0.0
 *      used by /usr/bin/metacity (x11-wm/metacity-2.34.13)
 *      used by /usr/bin/xdpyinfo (x11-apps/xdpyinfo-1.3.1)
 *      used by /usr/lib64/gtk-3.0/3.0.0/immodules/im-am-et.so (x11-libs/gtk+-3.8.4)
 *      used by 19 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries
homeserver ~ #


Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4560
Location: Saint Amant, Acadiana

PostPosted: Sun Oct 06, 2013 3:28 am    Post subject: Reply with quote

Quote:
I have upgraded gcc to 4.8.1 from 4.6.3 following the guide to rebuild libtool.


Code:
sys-devel/gcc:            4.7.3-r1


You should fix this first.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
clouds222
Apprentice
Apprentice


Joined: 13 Jul 2009
Posts: 187
Location: Shanghai

PostPosted: Sun Oct 06, 2013 3:46 am    Post subject: Reply with quote

Jaglover wrote:
Quote:
I have upgraded gcc to 4.8.1 from 4.6.3 following the guide to rebuild libtool.


Code:
sys-devel/gcc:            4.7.3-r1


You should fix this first.


Sorry, I had a fresh install, with gcc-4.7.3-r1, and met the same issue. the information above is from my current setup.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5270

PostPosted: Sun Oct 06, 2013 7:21 am    Post subject: Reply with quote

All those "/dev/fd/62: No such file or directory" lines suggest that either portage got broken or there's a more generic problem on your system (likely something boot/udev related, but there are other possible reasons).
Back to top
View user's profile Send private message
N8Fear
Tux's lil' helper
Tux's lil' helper


Joined: 15 Apr 2013
Posts: 79
Location: Berlin (Germany)

PostPosted: Sun Oct 06, 2013 7:32 am    Post subject: Reply with quote

udev really seems like the culprit here (or systemd/eudev/mdev, depending on what the op is using).

I quick workaround would be:

ln -s /proc/self/fd /dev/fd

You should really make sure that the udev stuff is working properly or you'll most likely encounter other problems later...
Back to top
View user's profile Send private message
clouds222
Apprentice
Apprentice


Joined: 13 Jul 2009
Posts: 187
Location: Shanghai

PostPosted: Sun Oct 06, 2013 11:21 am    Post subject: Reply with quote

I triedto emerge udev, but it's blocked by systemd。
Back to top
View user's profile Send private message
clouds222
Apprentice
Apprentice


Joined: 13 Jul 2009
Posts: 187
Location: Shanghai

PostPosted: Sun Oct 06, 2013 11:34 am    Post subject: Reply with quote

N8Fear wrote:
udev really seems like the culprit here (or systemd/eudev/mdev, depending on what the op is using).

I quick workaround would be:

ln -s /proc/self/fd /dev/fd

You should really make sure that the udev stuff is working properly or you'll most likely encounter other problems later...


You got it! that did solve the issue, but why the issue occurs?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum