Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Qemu + spice = screen not updating in client
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Sun Sep 08, 2013 7:21 am    Post subject: Qemu + spice = screen not updating in client Reply with quote

I recently reïnstalled my Gentoo system. Causing the following versions to be used:

net-misc/spice-gtk-0.20-r1
app-emulation/qemu-1.4.2
app-emulation/spice-0.12.3-r1
app-emulation/spice-protocol-0.12.3

I'm using Windows XP SP3 with spice-gtk. Guest tools is version 0.59. I dug a little deeper and found that the QXL bundled with spice-guest-tools-0.59.exe is not the same as the seperate QXL driver offered on that same download page!

Code:
wget http://spice-space.org/download/windows/spice-guest-tools/spice-guest-tools-0.59.exe
7z x -otmp/ spice-guest-tools-0.59.exe
cat tmp/'$_OUTDIR/winxp/x86/qxl.inf' | grep -i driverver


Yields:

Code:
DriverVer = 10/15/2012,5.1.0.10016


So, checking the .18 driver (seeing if they forgot to update the version)

Code:
wget http://spice-space.org/download/windows/qxl/qxl-0.1-18/qxl_xp_x86.zip
unzip -dtmp2/ qxl_xp_x86.zip
cat tmp2/xp/x86/qxl.inf | grep -i driverver


Yields:

Code:
DriverVer = 07/17/2013,5.1.0.10018


So, it's not the driver. It has to be either qemu or another piece of the spice stack. Anyone got a clue?[/code]

EDIT: Some more info on the symptoms. The client starts fine and all. But whenever I click and the screen requires repainting, the client window goes black. The actual screen through sdl actually happily continue's. Albeit, it sometimes goes partly black as well but it does restore.
_________________
fs/super.c: "Self-destruct in 5 seconds. Have a nice day...\n"
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Sun Sep 08, 2013 7:38 am    Post subject: Reply with quote

Try more recent versions:

http://packages.gentoo.org/package/app-emulation/spice-protocol
http://packages.gentoo.org/package/app-emulation/spice
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Sun Sep 08, 2013 10:01 am    Post subject: Reply with quote

Yes, good suggestion. But, as I expected, no dice. Did this:

Code:
[ebuild     U ~] app-emulation/spice-protocol-0.12.6 [0.12.3] 69 kB
[ebuild     U ~] app-emulation/spice-0.12.4 [0.12.3-r1] USE="-client -sasl -smartcard -static-libs (-gui%)" 1,679 kB
[ebuild   R    ] app-emulation/qemu-1.4.2  USE="aio alsa caps filecaps jpeg sdl seccomp spice threads vnc -accessibility -bluetooth -curl -debug -fdt -iscsi -mixemu -ncurses -opengl -png -pulseaudio -python -rbd -sasl (-selinux) -smartcard -static -static-softmmu -static-user -systemtap -tci {-test} -tls -usbredir -uuid -vde -vhost-net -virtfs -xattr -xen -xfs" PYTHON_TARGETS="python2_7 (-python2_5) -python2_6" QEMU_SOFTMMU_TARGETS="i386 x86_64 -alpha -arm -cris -lm32 -m68k -microblaze -microblazeel -mips -mips64 -mips64el -mipsel -or32 -ppc -ppc64 -ppcemb -s390x -sh4 -sh4eb -sparc -sparc64 -unicore32 -xtensa -xtensaeb" QEMU_USER_TARGETS="-alpha -arm -armeb -cris -i386 -m68k -microblaze -microblazeel -mips -mipsel -or32 -ppc -ppc64 -ppc64abi32 -s390x -sh4 -sh4eb -sparc -sparc32plus -sparc64 -unicore32 -x86_64" 10,176 kB


However, it seems that the symptoms did change. The result is less bad. No more sudden black screens. However, the spice window still keeps the current system view when I start spice. When I click the start menu in the spice window, it only appears in the SDL window.

Now, spice also says:

Quote:
mouse: server, agent: no


Which was not the case in earlier versions. But, just as I wanted to click 'Ok' to submit this post. Windows detected the hardware associated with the agent service. After a reboot, it said:

Quote:
mouse: client, agent: yes


But I'm still having the 'stale' screen issue in the spicy client window. Another thing seems to work as well: Resizing. Resizing the spicy window makes the SDL window resize as well.

I'm trying the 0.18 VGA driver.
_________________
fs/super.c: "Self-destruct in 5 seconds. Have a nice day...\n"
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Sun Sep 08, 2013 11:10 am    Post subject: Reply with quote

Upgraded QXL driver. No results.

Downgraded spice-protocol (->0.12.3) and spice (->0.12.2) to known working versions. No results.

Downgraded spice-gtk (->0.14-r2) to known working version. No results.

Trying qemu-1.4.0 will keeping all else at stable versions. I'll try once I get back out of the shower.
_________________
fs/super.c: "Self-destruct in 5 seconds. Have a nice day...\n"
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Sun Sep 08, 2013 12:14 pm    Post subject: Reply with quote

Tried downgrading several packages to known working versions:

    spice-gtk-0.14-r2
    spice-0.12.2
    qemu-1.4.0-r1
    spice-protocol-0.12.3


No dice. FWIW, my qemu command is as follows:

Code:
/usr/bin/qemu-system-i386 \
-nodefaults -no-kvm -no-fd-bootchk \
-rtc base=utc,clock=host -no-reboot \
-snapshot -balloon virtio -m 256 \
-drive id=hd,if=virtio,file=/home/secure/ronald/Documenten/qemu/windows_xp.img \
-mon chardev=mon0 -chardev stdio,id=mon0 \
-vga qxl -spice port=5000,addr=127.0.0.1,ipv4,disable-ticketing,image-compression=auto_lz \
   -device virtio-serial -device virtserialport,chardev=sc0,name=com.redhat.spice.0 \
   -chardev spicevmc,id=sc0,name=vdagent \
-d unimp,guest_errors -D /home/secure/ronald/Documenten/qemu/windows_xp.log \
-device virtio-net,netdev=tap -netdev tap,id=tap,ifname=tap0,script=,downscript=,vnet_hdr=off


Yelp?

EDIT: Going to try qemu-1.6.0.

EDIT2: Qemu-1.6.0 yielded no results. I give up. Maybe it's a bug in glib/gtk or something like that.
_________________
fs/super.c: "Self-destruct in 5 seconds. Have a nice day...\n"
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Sun Sep 15, 2013 12:55 pm    Post subject: Reply with quote

* polite bump *
_________________
fs/super.c: "Self-destruct in 5 seconds. Have a nice day...\n"
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Wed Sep 25, 2013 5:42 am    Post subject: Reply with quote

* polite bump * (Anyone else suffering from this?)
_________________
fs/super.c: "Self-destruct in 5 seconds. Have a nice day...\n"
Back to top
View user's profile Send private message
PraetorZero
Apprentice
Apprentice


Joined: 11 Dec 2004
Posts: 239
Location: /home

PostPosted: Fri Oct 04, 2013 10:14 pm    Post subject: Reply with quote

I had a similiar problem in July. My host is on another machine in my network and I rebuilt just about everything related to libvirtd and spice that I could find until I found an Android spice client that worked just fine. I migrated my troubleshooting to my desktop and never found a real resolution. After a few weeks, I migrated to an SSD and copied my install over. On a random whim, I tried it again and it started working again.

I did have a few permissions issues that I had to correct after the move, but nothing that I believe should have had anything to do with the spice client.
_________________
What's the worst that can happen?
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Sat Oct 05, 2013 6:28 am    Post subject: Reply with quote

That's... odd. Thanks though. However, I don't have an Android phone so... :) .
_________________
fs/super.c: "Self-destruct in 5 seconds. Have a nice day...\n"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum