Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cpupower failed to start
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
disperato
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2004
Posts: 116

PostPosted: Sat Apr 26, 2014 8:39 pm    Post subject: cpupower failed to start Reply with quote

just that message and no cpupower daemon running

AS USUAL, a cryptic message that says nothing (we wold not be on linux, otherwise) and no results over the internet

I'm the only one on the planet who is having this error. How to deal with it and crypto-style like that?

Already seen dmesg, system messages, checked for use flags to activate (debug, there aren't any), whatever.



EDITED: because I was enraged, rude and unfair when wrote this.
_________________
The free men's path is always obstructed by mediocrity.


Last edited by disperato on Sun Apr 27, 2014 12:53 am; edited 1 time in total
Back to top
View user's profile Send private message
disperato
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2004
Posts: 116

PostPosted: Sun Apr 27, 2014 12:39 am    Post subject: Reply with quote

After a bit more digging, here is the arcane solution, for anyone who is banging their head against the wall:

I added these lines to my /etc/conf.d/cpupower and acted on the kernel config accordingly:

Code:
START_OPTS="--governor conservative" #can ONLY be used with ACPI_CPUFREQ driver
#START_OPTS="--governor powersave" #can be used with INTEL_PSTATE driver
###INTEL_PSTATE (performance and powersave only;       frequency range: 800-3200 MHz)
###ACPI_CPUFREQ (performance, ondemand, conservative, powersave; frequency range: 800-2200 MHz)
### NB1: INTEL_PSTATE kicks off ACPI_CPUFREQ As for speed range, I wasn't able to move below 2.2GHz or beyond 2.9GHz
### NB2: ACPI_CPUFREQ can gets up to 2200MHz only, but it really covers all the range dynamiccally between cpus, alternating them as well


Obviously those comments refer to my particular machine. Answers/discussion on if the results are the same for other laptops may be useful to understand whether those limitations are for my laptop or the driver INTEL_PSTATE is faulty/buggy/limited.
All that I can tell you, is that the situation is unchanged in newer kernel 3.14.1 (I'm stable on 3.12.12)

Clevo P150SM
intel core i7 4702MQ
_________________
The free men's path is always obstructed by mediocrity.
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2949

PostPosted: Sun Apr 27, 2014 3:06 am    Post subject: Re: cpupower failed to start Reply with quote

disperato wrote:
[...] and no cpupower daemon running

disperato ... that would be because there is no "cpupower daemon" :) ... it only sets the cpufreq and vars under /sys, and can query the current state (via '--info').

As for the problem at hand, what do you have set as the "default governor" in .config? I'd suggest, as this is a laptop, you set "ondemand" as then the scaling will occur ... oddly enough ... ondemand. You should probably avoid "conservative" (I believe it was Con Kolivas who said that where switching is concerned there is little between ondemand and conservative ... accept that ondemand will provide better responsiveness, and in some cases less context switching). That said, I'm really unfamiliar with intel_pstate so take that advice with a grain of salt.

I assume that when you're calling '--governor powersave' this governor is enabled in the kernel (and not as a module) and if a module its loaded (along with the intel_pstate module) prior to cpupower running? ... sorry, obvious questions I know, but it helps to rule out the obvious.

Also, does your cpu support 'turbo mode', if so then this should probably be disabled for 'powersave' (at least if I were to point at some reason intel_pstate would cause setting the governor to fail it would be that some conflict might exist between one ... powersave ... and the other ... turbo).

Code:
# echo 1 > /sys/devices/system/cpu/intel_pstate/no_turbo

Anyhow, I can't say what the issue is, but the above is probably where I'd start trying to debug the issue.

HTH & best ... khay
Back to top
View user's profile Send private message
disperato
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2004
Posts: 116

PostPosted: Sun Apr 27, 2014 9:40 am    Post subject: Reply with quote

hi khayyam, thank you for reply,

my post was a bit incomplete, actually when intel_pstate is built into the kernel (no option to make it a module), it overrides the acpi_freq (either built-in or modularised), and ships its own governor.

cpupower frequency-info shows clearly that in such a case only powersave and performance can be chosen (ondemand and conservative, also built-in, are ignored) and frequencies are claimed to be in the range 800-3200MHz whereas they stick to 2200-2900MHz. It doesn't seem to be the right behaviour.

Conversely, when acpi_freq only is built-in, every governor can be chosen, plus a wide range of frequencies, although the turbo mode range (2.2-3.2 GHz) is totally ignored.
This is the part where I'll try to shed a light, following your tips too, ignoring intel_pstate driver (that driver acted very disappointing).
_________________
The free men's path is always obstructed by mediocrity.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum