Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Brother MFC 9970CDW printer drivers do not work [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
geeksheik
n00b
n00b


Joined: 07 Sep 2003
Posts: 62

PostPosted: Fri Sep 20, 2013 7:03 am    Post subject: Brother MFC 9970CDW printer drivers do not work [solved] Reply with quote

I'm posting a solved topic on an issue that cost me significant time.

In the office, we have a Brother MFC 9970CDW multifunction printer.

This model is not included within the available database of printer drivers, net-print/foomatic-db-ppds, to be used with cups, so I downloaded and installed the drivers for the 9970 from Brother.

http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html#MFC-9970CDW

There are 2 packages to be downloaded, an LPR driver and a cupswrapper driver. .rpm and .deb packages are the options for both; I chose the rpm.

Code:
# rpm2targz mfc9970cdwlpr-1.1.1-5.i386.rpm
# rpm2targz mfc9970cdwcupswrapper-1.1.1-5.i386.rpm


Then I unpacked them to a .tgz file via the rpm2targz utility (available via the app-arch/rpm2targz-9.0.0.5g package). This creates a tarball with the contained files all relative to the root folder. ...so I changed to the root folder and unpacked both tarballs, thereby installing all necessary files.

Then I went through the cups installation process and selected the PPD driver that was contained in the cupswrapper driver.

At this point, I could print a test page, but I could never use this driver to print from any application on my system. I tried and tried with various connect strings and settings, but nothing worked. A colleague of mine in the office had exactly the same results with a different distribution (Ubuntu, I think). What does Brother have to publish crappy, non-working drivers ?!? :evil:

The solution ended up being to select the "Brother MFC9840CDW Foomatic/Postscript" driver from the foomatic-db package. This works fine. I can print in color and double-sided as well.

The connect string is "lpd://<IP_ADDRESS>/BINARY_P1" Of course, substitute the IP address of your printer in there. This string is reported by the printer during the CUPS network printer discovery, but garbage characters are reported in place of the IP address.

Hopefully this post saves someone from the headaches I had. Why does printer installation under Linux have to be so time-consuming?! I've always found this to be one of the worst parts of Linux system setup.

Note: it's not clear for me at the moment whether some part of the 2 downloaded packages is actually necessary for this to work. ...perhaps I will try uninstalling the cruft and see if I still have a working printer solution...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum