Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Refresh rate issue
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
C-TZ
n00b
n00b


Joined: 10 Feb 2012
Posts: 33

PostPosted: Wed Sep 18, 2013 1:11 pm    Post subject: Refresh rate issue Reply with quote

EDIT

After reading this:
Quote:
When using __GL_SYNC_TO_VBLANK with TwinView, OpenGL can only sync to one of the display devices; this may cause tearing corruption on the display device to which OpenGL is not syncing. You can use the environment variable __GL_SYNC_DISPLAY_DEVICE to specify to which display device OpenGL should sync. You should set this environment variable to the name of a display device; for example "CRT-1". Look for the line "Connected display device(s):" in your X log file for a list of the display devices present and their names.


So apparently it's not even possible using two monitors with twinview that run on slightly different frequencies. I never noticed this using Windows 7. There's this trick I tried with two X servers running one on each screen, but then I couldn't move windows from one monitor to the other and when I started an application from monitor 2 it always ended up on monitor one.


I've been able to move my problem from my main monitor to my secondary monitor using this:

Quote:
I have set this permanently in /etc/environment - just add something like this on a new line:

__GL_SYNC_DISPLAY_DEVICE="DFP-0"




Hi there,

I'm using dual monitor setup with kde 4.10.5 and I'm at the point where I want to drive my car head on into my main monitor and then run face-forward into a tree as hard as I can, so I thought "lets seek some professional help" :D :P

Main monitor: Medion MD 20110
Second: Philips 170S

xorg.conf created by nvidia-settings utility:
Quote:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 319.49 (buildmeister@swio-display-x64-rhel04-03) Tue Aug 13 20:42:00 PDT 2013

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from data in "/etc/conf.d/gpm"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Philips 170S"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8600 GTS"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "Stereo" "0"
Option "nvidiaXineramaInfoOrder" "DFP-0"
Option "metamodes" "CRT: nvidia-auto-select +1920+0, DFP: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection



When I move windows around there's this horizontal line moving from the bottom slowely to the top. Only when I move windows, watch movie clips, etc.
I have searched forever where to change things to fix this. It seems like somehow X and/or KDE just don't know how to handle my monitor properly.

Somehow the refresh rate always seems to relate to my SECOND monitor... I can't figure out how to change this. Isn't this supposed to be configured properly "out of the box"? :?

Need more info? I'd appriciate the help.


What I've noticed is that even when there's an xorg.conf file... After I fiddle around with "System settings->Display and Monitor" settings, my xorg.conf doesn't really seem to do anything :?

EDIT: My video card is an nvida 8600 GTS
_________________
Life isn't fair, but keep on going: make it fair.


Last edited by C-TZ on Thu Sep 19, 2013 9:37 pm; edited 2 times in total
Back to top
View user's profile Send private message
C-TZ
n00b
n00b


Joined: 10 Feb 2012
Posts: 33

PostPosted: Thu Sep 19, 2013 6:32 pm    Post subject: Reply with quote

*BUMP*
_________________
Life isn't fair, but keep on going: make it fair.
Back to top
View user's profile Send private message
C-TZ
n00b
n00b


Joined: 10 Feb 2012
Posts: 33

PostPosted: Thu Sep 19, 2013 8:03 pm    Post subject: Reply with quote

I found out it's called tearing in English (not my native language) and that allot of people are experiencing this problem.


Can anyone help me with setting environment variables? :) Because I don't understand the context... bashrc, .profile, xorg.conf(.d)?


According to https://devtalk.nvidia.com/default/topic/540730/again-tearing-problems-with-drivers-gt-300-dual-head-setup/

it should help to disable composite and/or set __GL_SYNC_DISPLAY_DEVICE=DFP-1.

Any help or tips appreciated.
_________________
Life isn't fair, but keep on going: make it fair.
Back to top
View user's profile Send private message
C-TZ
n00b
n00b


Joined: 10 Feb 2012
Posts: 33

PostPosted: Thu Sep 19, 2013 8:51 pm    Post subject: Reply with quote

Hmmm... "Sync to this display device" in nvidia-settings application isn't working. When I do "export __{theformentionedvariable}=DFP-1" it doesn't seem to do anything. Am I doing this right?

Haha, I'm actualy laughing out loud right now, litteraly :D . . . This is such a stupid problem and I don't even know WHAT exactly the problem IS at this point...

Is this a driver problem? I've read that some people using older drivers have no tearing and others do.
Or is this a KDE problem? Because it's application layer can't handle two monitors with slightly different refresh rates?

I've emerged kscreen in the hopes that it would allow me to configure slightly more than the standard KDE application but no luck. It tells me it runs on 60Hz but there's still tearing so something is not right.


From the awkward forum silence I understand that nobody wants to burn his/her hands on this one?

I should just sell my second monitor or buy Win7?

Come on... this shouldn't be that hard right? I'm not techy enough to do it myself but I bet there's some wizard out there who's knowledge borders on the godlike and can help me with this. You guys want to help me bring this problem to his/her attention?


EDIT: increasing my powermizer level doens't work since I only have one level.

EDIT: Enabling triple buffer option under device doesn't seem to help anything.

EDIT: Option "SwapbuffersWait" "false" in device section doesn't help but for the first time setting an "option" in xorg.conf atleast does something.

EDIT: Trying:
Quote:
I too was suffering from video tearing in my Intel sandy bridge processor. This worked for me. I put the following lines in "/etc/environment" -

CLUTTER_PAINT=disable-clipped-redraws:disable-culling
CLUTTER_VBLANK=True


Failed


EDIT: Tried:
Quote:
I have set this permanently in /etc/environment - just add something like this on a new line:

__GL_SYNC_DISPLAY_DEVICE="DFP-0"


SUCCES!! :D :D :D The problem has now been half-solved by moving it to my second monitor. SO NOW MY MAIN MONITOR IS WORKING PERFECTLY :D :D

I'm so happy. I hope nvidia will resolve this issue in later binary drivers, this is a really stupid problem.
_________________
Life isn't fair, but keep on going: make it fair.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum