Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] java script in midori
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jyoung
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2007
Posts: 119

PostPosted: Sat Sep 14, 2013 8:36 pm    Post subject: [SOLVED] java script in midori Reply with quote

Hi Folks,

I'm having some issues with my java script plugin in the midori web browser. I've tried installing both the icedtea and sun-jre-bin plugins following the instructions at the gentoo java wiki:

http://www.gentoo.org/doc/en/java.xml

When I select one of them, midori detects it in its preferences->extensions list. For example, when I eselect icedtea, that option appears in midori's list of plugins. But, its icon is a broken icon, and indeed even when I select that option from the list I can't load pages with java script in them. Any ideas?


Last edited by jyoung on Sun Sep 29, 2013 5:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
jyoung
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2007
Posts: 119

PostPosted: Sun Sep 29, 2013 5:00 pm    Post subject: [SOLVED] java script in midori Reply with quote

Okay, I'm going to mark this one SOLVED. It turns out that my 'does it work' test was confounded by many websites discriminating against less commonly used browsers, and that when I changed a setting in midori that allows it to pretend to be a different browser (firefox, in my case), most of the issues disappeared. Unfortunately, the one website that I really need to access still isn't working, but, although that is a javascript site, I'm starting to suspect that the problem may be unrelated.

For future readers, I followed the instructions on the gentoo java guide (http://www.gentoo.org/doc/en/java.xml) to install the sun java plugin. I am certain that there were at least some issues with the icetea plugin because the javascript test site (http://www.java.com/en/download/testjava.jsp) suddenly started working when I switched to the sun plugin.

Also, I had previously tried the sun plugin unsuccessfully; since then I've recompiled with all of the use flags enabled (X alsa jce nsplugin pax_kernel). They are not all enabled by default, and I am not sure which, if any, made a difference.

I'm using a 64bit multilib system, so I also have the 32bit emulator installed (emul-linux-x86-java-1.6); I am not sure that that matter.
Back to top
View user's profile Send private message
netixen
n00b
n00b


Joined: 26 Sep 2013
Posts: 15

PostPosted: Sun Sep 29, 2013 5:15 pm    Post subject: Reply with quote

Hi,
Java is not javascript.
I still got what you are saying and I would use oracle-jre-bin instead of sun-jre-bin
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum