Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cant emerge sympy from sage overlay
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
elkhunter
Tux's lil' helper
Tux's lil' helper


Joined: 19 Sep 2004
Posts: 99

PostPosted: Thu Sep 12, 2013 1:47 pm    Post subject: cant emerge sympy from sage overlay Reply with quote

I'm running into the following error when trying to emerge sympy from the sage overlay. Any ideas? Note that I also have the science overlay installed in case that matters.

Thanks in advance.

* Package: dev-python/sympy-0.7.2-r3
* Repository: sage-on-gentoo
* Maintainer: grozin@gentoo.org sci-mathematics@gentoo.org
* USE: amd64 elibc_glibc gtk kernel_linux opengl pdf png python_targets_python2_7 userland_GNU
* FEATURES: preserve-libs userpriv usersandbox
>>> Unpacking source...
>>> Unpacking sympy-0.7.2.tar.gz to /var/tmp/portage/dev-python/sympy-0.7.2-r3/work/python2
>>> Source unpacked in /var/tmp/portage/dev-python/sympy-0.7.2-r3/work
>>> Preparing source in /var/tmp/portage/dev-python/sympy-0.7.2-r3/work ...
* Applying sympy-0.7.2-mpmath.patch ...
[ ok ]
* Applying sympy-0.7.2-mpmath-import.patch ...
[ ok ]
* Applying sympy-0.7.2-mpmath-test.patch ...
[ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/sympy-0.7.2-r3/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-python/sympy-0.7.2-r3/work ...
* It seems that you need to set USE_PYTHON to make sure that legacy
* packages will be built with respect to PYTHON_TARGETS correctly:
*
* USE_PYTHON='2.7'
*
* Please note that after changing the USE_PYTHON variable, you may need
* to run 'python-updater' to rebuild affected packages.
*
* For more information on python.eclass compatibility, please see
* the appropriate python-r1 User's Guide chapter [1].
*
* [1] http://www.gentoo.org/proj/en/Python/python-r1/user-guide.xml#doc_chap2
* python2_7: running distutils-r1_run_phase python_compile
/usr/bin/python2.7 setup.py build --build-base /var/tmp/portage/dev-python/sympy-0.7.2-r3/work/build-python2_7 --build-platlib /var/tmp/portage/dev-python/sympy-0.7.2-r3/work/build-python2_7/lib --build-purelib /var/tmp/portage/dev-python/sympy-0.7.2-r3/work/build-python2_7/lib --build-scripts /var/tmp/portage/dev-python/sympy-0.7.2-r3/work/build-python2_7/scripts
Traceback (most recent call last):
File "setup.py", line 36, in <module>
import sympy
File "/var/tmp/portage/dev-python/sympy-0.7.2-r3/work/python2/sympy-0.7.2/sympy/__init__.py", line 49, in <module>
from sympy.core import *
File "/var/tmp/portage/dev-python/sympy-0.7.2-r3/work/python2/sympy-0.7.2/sympy/core/__init__.py", line 8, in <module>
from expr import Expr, AtomicExpr
File "/var/tmp/portage/dev-python/sympy-0.7.2-r3/work/python2/sympy-0.7.2/sympy/core/expr.py", line 5, in <module>
from evalf import EvalfMixin, pure_complex
File "/var/tmp/portage/dev-python/sympy-0.7.2-r3/work/python2/sympy-0.7.2/sympy/core/evalf.py", line 5, in <module>
import mpmath.libmp as libmp
File "/usr/lib64/python2.7/site-packages/mpmath/__init__.py", line 10, in <module>
mp = MPContext()
File "/usr/lib64/python2.7/site-packages/mpmath/ctx_mp.py", line 72, in __init__
ctx.init_builtins()
File "/usr/lib64/python2.7/site-packages/mpmath/ctx_mp.py", line 101, in init_builtins
ctx.one = ctx.make_mpf(fone)
File "ext_main.pyx", line 493, in sage.libs.mpmath.ext_main.Context.make_mpf (sage/libs/mpmath/ext_main.c:6669)
File "ext_main.pyx", line 503, in sage.libs.mpmath.ext_main.Context.make_mpf (sage/libs/mpmath/ext_main.c:6601)
File "ext_impl.pyx", line 268, in sage.libs.mpmath.ext_impl.MPF_set_tuple (sage/libs/mpmath/ext_impl.c:4102)
File "integer.pyx", line 754, in sage.rings.integer.Integer.__init__ (sage/rings/integer.c:7864)
TypeError: unable to coerce <type 'mpz'> to an integer
* ERROR: dev-python/sympy-0.7.2-r3::sage-on-gentoo failed (compile phase):
* (no error message)
*
* Call stack:
* ebuild.sh, line 93: Called src_compile
* environment, line 3561: Called distutils-r1_src_compile
* environment, line 996: Called _distutils-r1_run_foreach_impl 'python_compile'
* environment, line 314: Called python_parallel_foreach_impl 'distutils-r1_run_phase' 'python_compile'
* environment, line 3426: Called multibuild_parallel_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
* environment, line 2622: Called multibuild_foreach_variant '_multibuild_parallel' '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
* environment, line 2570: Called _multibuild_run '_multibuild_parallel' '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
* environment, line 2568: Called _multibuild_parallel '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
* environment, line 2613: Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'python_compile'
* environment, line 662: Called distutils-r1_run_phase 'python_compile'
* environment, line 987: Called python_compile
* environment, line 2999: Called distutils-r1_python_compile
* environment, line 889: Called esetup.py
* environment, line 1770: Called die
* The specific snippet of code:
* "${@}" || die
*
* If you need support, post the output of `emerge --info '=dev-python/sympy-0.7.2-r3::sage-on-gentoo'`,
* the complete build log and the output of `emerge -pqv '=dev-python/sympy-0.7.2-r3::sage-on-gentoo'`.
* The complete build log is located at '/var/tmp/portage/dev-python/sympy-0.7.2-r3/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-python/sympy-0.7.2-r3/temp/environment'.
* Working directory: '/var/tmp/portage/dev-python/sympy-0.7.2-r3/work/python2/sympy-0.7.2'
* S: '/var/tmp/portage/dev-python/sympy-0.7.2-r3/work'
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum