Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Installing Blender
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
mrfabiolo
n00b
n00b


Joined: 02 Jan 2011
Posts: 50

PostPosted: Wed Sep 18, 2013 11:52 am    Post subject: [SOLVED]Installing Blender Reply with quote

i write this:
Code:
emerge blender

and this is the output:
Code:
 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies |

!!! Problem resolving dependencies for media-gfx/blender
... done!

!!! The ebuild selected to satisfy "blender" has unmet requirements.
- media-gfx/blender-2.68a::gentoo USE="boost bullet dds elbeem game-engine nls openexr openmp sdl sse sse2 tiff -collada -colorio -cycles -debug -doc -ffmpeg -fftw -jack -jpeg2k -ndof -openal -player -redcode -sndfile" PYTHON_SINGLE_TARGET="-python3_3" PYTHON_TARGETS="python3_3"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python_single_target_python3_3

  The above constraints are a subset of the following complete expression:
    python_single_target_python3_3? ( python_targets_python3_3 ) exactly-one-of ( python_single_target_python3_3 ) player? ( game-engine ) redcode? ( jpeg2k ) cycles? ( boost openexr tiff ) nls? ( boost ) game-engine? ( boost )

How can I solve this problem?


Last edited by mrfabiolo on Thu Sep 19, 2013 12:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9752
Location: Córdoba (Spain)

PostPosted: Wed Sep 18, 2013 11:58 am    Post subject: Reply with quote

Addint this to make.conf should do the trick:

Code:
PYTHON_SINGLE_TARGET="python3_3"

_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
mrfabiolo
n00b
n00b


Joined: 02 Jan 2011
Posts: 50

PostPosted: Wed Sep 18, 2013 12:15 pm    Post subject: Reply with quote

mmm.
I tried to do:
Code:
emerge --update --deep --newuse world

and then i added "PYTHON_SINGLE_TARGET="python3_3" in make.conf . . .
and then:
Code:
emerge blender

but it seems that it doesn't work. as before.

Maybe is because of i have a conflict when I do the first command:
Code:
emerge --update --deep --newuse world

In fact the output is :
Code:
 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
Calculating dependencies... done!
[ebuild   R    ] x11-libs/libdrm-2.4.45  USE="-libkms*"
[ebuild   R    ] media-libs/alsa-lib-1.0.27.1  PYTHON_SINGLE_TARGET="-python2_7*"
[ebuild   R    ] x11-proto/xcb-proto-1.8-r1  PYTHON_SINGLE_TARGET="-python2_7*"
[ebuild   R    ] x11-libs/xpyb-1.3.1-r1  PYTHON_SINGLE_TARGET="-python2_7*"
[ebuild   R    ] media-libs/mesa-9.1.2-r1  USE="-xa*" PYTHON_SINGLE_TARGET="-python2_7*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/mesa:0

  (media-libs/mesa-9.1.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/mesa-9.1.2-r1::gentoo, installed) pulled in by
    media-libs/mesa[xa] required by (x11-drivers/xf86-video-vmware-12.0.2-r1::gentoo, installed)

x11-libs/libdrm:0

  (x11-libs/libdrm-2.4.45::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libdrm-2.4.45::gentoo, installed) pulled in by
    x11-libs/libdrm[libkms,video_cards_vmware] required by (x11-drivers/xf86-video-vmware-12.0.2-r1::gentoo, installed)


It might be possible to solve these slot collisions
by applying all of the following changes:
   - media-libs/mesa-9.1.2-r1 (Change USE: +xa)
   - x11-libs/libdrm-2.4.45 (Change USE: +libkms)
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5270

PostPosted: Wed Sep 18, 2013 12:27 pm    Post subject: Reply with quote

Try setting it as a useflag for blender, instead of global.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9752
Location: Córdoba (Spain)

PostPosted: Wed Sep 18, 2013 12:35 pm    Post subject: Reply with quote

mrfabiolo wrote:
mmm.
I tried to do:
Code:
emerge --update --deep --newuse world

and then i added "PYTHON_SINGLE_TARGET="python3_3" in make.conf . . .
and then:
Code:
emerge blender

but it seems that it doesn't work. as before.


Not as before. It might seem so to you, but this error is different from the one you posted above.

Quote:

Maybe is because of i have a conflict when I do the first command:
Code:
emerge --update --deep --newuse world

In fact the output is :
Code:
 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
Calculating dependencies... done!
[/quote]

To avoid turning this into a bigger mess, you should really run etc-update, and fix those config files. Be sure to get used to that, and do it each time portage tells you so. Neglection in this can even turn your system un-bootable (in rare occasions, admittedly).

[quote][ebuild   R    ] x11-libs/libdrm-2.4.45  USE="-libkms*"
[ebuild   R    ] media-libs/alsa-lib-1.0.27.1  PYTHON_SINGLE_TARGET="-python2_7*"
[ebuild   R    ] x11-proto/xcb-proto-1.8-r1  PYTHON_SINGLE_TARGET="-python2_7*"
[ebuild   R    ] x11-libs/xpyb-1.3.1-r1  PYTHON_SINGLE_TARGET="-python2_7*"
[ebuild   R    ] media-libs/mesa-9.1.2-r1  USE="-xa*" PYTHON_SINGLE_TARGET="-python2_7*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/mesa:0

  (media-libs/mesa-9.1.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/mesa-9.1.2-r1::gentoo, installed) pulled in by
    media-libs/mesa[xa] required by (x11-drivers/xf86-video-vmware-12.0.2-r1::gentoo, installed)

x11-libs/libdrm:0

  (x11-libs/libdrm-2.4.45::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libdrm-2.4.45::gentoo, installed) pulled in by
    x11-libs/libdrm[libkms,video_cards_vmware] required by (x11-drivers/xf86-video-vmware-12.0.2-r1::gentoo, installed)


It might be possible to solve these slot collisions
by applying all of the following changes:
   - media-libs/mesa-9.1.2-r1 (Change USE: +xa)
   - x11-libs/libdrm-2.4.45 (Change USE: +libkms)


So, you should really do that portage is telling you: add the "xa" use flag to mesa, and the "libkms" use flag to libdrm. You can do it globally in make.conf, or you can do it per-package in package.use.

I don't want to spoil the fun of it. If you need further details, please, just ask here. :)
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
mrfabiolo
n00b
n00b


Joined: 02 Jan 2011
Posts: 50

PostPosted: Wed Sep 18, 2013 7:27 pm    Post subject: Reply with quote

ok i have solved the problem of xa and libkms.
But now i don't know how to install blender with emerge.

I tried to set PYTHON_SINGLE_TARGET="python3_3" into the make.conf but i got the same problem:
Code:
tux ~ # emerge --pretend blender

 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies -

!!! Problem resolving dependencies for media-gfx/blender
... done!

!!! The ebuild selected to satisfy "blender" has unmet requirements.
- media-gfx/blender-2.68a::gentoo USE="boost bullet dds elbeem game-engine nls openexr openmp sdl sse sse2 tiff -collada -colorio -cycles -debug -doc -ffmpeg -fftw -jack -jpeg2k -ndof -openal -player -redcode -sndfile" PYTHON_SINGLE_TARGET="-python3_3" PYTHON_TARGETS="-python3_3"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python_single_target_python3_3

  The above constraints are a subset of the following complete expression:
    python_single_target_python3_3? ( python_targets_python3_3 ) exactly-one-of ( python_single_target_python3_3 ) player? ( game-engine ) redcode? ( jpeg2k ) cycles? ( boost openexr tiff ) nls? ( boost ) game-engine? ( boost )



Quote:
Try setting it as a useflag for blender, instead of global.

how can I set it only for blender? where do I put "PYTHON_SINGLE_TARGET="python3_3""?
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9752
Location: Córdoba (Spain)

PostPosted: Wed Sep 18, 2013 7:43 pm    Post subject: Reply with quote

See this.

http://www.gossamer-threads.com/lists/gentoo/user/269428

Maybe the use flag is masked. I am not familiar with blender and i dont have my laptop here at the moment to check myself.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
mrfabiolo
n00b
n00b


Joined: 02 Jan 2011
Posts: 50

PostPosted: Thu Sep 19, 2013 12:34 pm    Post subject: Reply with quote

I set "python_targets_python3_3" in the USE of make.conf and now I solved.
thanks you all!
Back to top
View user's profile Send private message
poinck
n00b
n00b


Joined: 30 Oct 2013
Posts: 6

PostPosted: Wed Oct 30, 2013 3:40 pm    Post subject: Reply with quote

I set the same use-flags in "make.conf" but I have still the same error:

Code:
rechner poinck # emerge -a blender

These are the packages that would be merged, in order:

Calculating dependencies /

!!! Problem resolving dependencies for media-gfx/blender
... done!

!!! The ebuild selected to satisfy "blender" has unmet requirements.
- media-gfx/blender-2.68a::gentoo USE="boost bullet dds elbeem ffmpeg game-engine jack nls openexr openmp sdl sse sse2 tiff -collada -colorio -cycles -debug -doc -fftw -jpeg2k -ndof -openal -player -redcode -sndfile" PYTHON_SINGLE_TARGET="-python3_3" PYTHON_TARGETS="python3_3"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python_single_target_python3_3

  The above constraints are a subset of the following complete expression:
    python_single_target_python3_3? ( python_targets_python3_3 ) exactly-one-of ( python_single_target_python3_3 ) player? ( game-engine ) redcode? ( jpeg2k ) cycles? ( boost openexr tiff ) nls? ( boost ) game-engine? ( boost )


If I than add "python_single_target_python3_3" as well in "make.conf" I have a conflct for the package "numpy":

Code:
rechner poinck # emerge -a blender

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "dev-python/numpy[python_targets_python3_3(-)?,python_single_target_python3_3(+)?]".
!!! One of the following packages is required to complete your request:
- media-gfx/blender-2.68a::gentoo (Change USE: -python_targets_python3_3, this change violates use flag constraints defined by media-gfx/blender-2.68a: 'python_single_target_python3_3? ( python_targets_python3_3 ) exactly-one-of ( python_single_target_python3_3 ) player? ( game-engine ) redcode? ( jpeg2k ) cycles? ( boost openexr tiff ) nls? ( boost ) game-engine? ( boost )')
(dependency required by "media-gfx/blender-2.68a" [ebuild])
(dependency required by "blender" [argument])


Currently I am frustrated with this. *hmpf*
Back to top
View user's profile Send private message
hasufell
Developer
Developer


Joined: 29 Oct 2011
Posts: 159

PostPosted: Mon Nov 25, 2013 7:30 pm    Post subject: Reply with quote

Code:
# grep PYTHON_TARGETS /etc/portage/make.conf
PYTHON_TARGETS="python2_7 python3_2 python3_3"

# grep python3_3 /etc/portage/profile/use.mask
-python_targets_python3_3
-python_single_target_python3_3

# grep media-gfx/blender /etc/portage/package.use
media-gfx/blender python_single_target_python3_3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum