Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Splashutils no compila [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 395

PostPosted: Thu Jul 24, 2014 2:42 pm    Post subject: Splashutils no compila [SOLVED] Reply with quote

Hola genturiones!!!

Otra vez recurro a ustedes por un nuevo problema. Después de un update me apareció un “preserved libs” para el splashutils:

Code:
!!! existing preserved libs:
>>> package: media-libs/libmng-2.0.2-r1
 *  - /usr/lib64/libmng.so.1
 *  - /usr/lib64/libmng.so.1.0.0
 *      used by /usr/lib64/libfbsplashrender.so.1.0.0 (media-gfx/splashutils-1.5.4.4-r1)
 *      used by /usr/sbin/fbsplashd (media-gfx/splashutils-1.5.4.4-r1)


Pero cuando corro el “emerge @preserved-rebuild” la compilación falla:

Code:
#  emerge @preserved-rebuild           
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 2) media-gfx/splashutils-1.5.4.4-r1
 * splashutils-lite-1.5.4.4.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                               [ ok ]
 * splashutils-gentoo-1.0.17.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                              [ ok ]
 * miscsplashutils-0.1.8.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                  [ ok ]
 * libpng-1.4.3.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                           [ ok ]
 * jpegsrc.v8a.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                             [ ok ]
 * freetype-2.3.12.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                        [ ok ]
 * zlib-1.2.3.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                             [ ok ]
>>> Unpacking source...
>>> Unpacking splashutils-lite-1.5.4.4.tar.bz2 to /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Unpacking splashutils-gentoo-1.0.17.tar.bz2 to /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Unpacking miscsplashutils-0.1.8.tar.bz2 to /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Unpacking libpng-1.4.3.tar.bz2 to /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Unpacking jpegsrc.v8a.tar.gz to /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Unpacking freetype-2.3.12.tar.bz2 to /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Unpacking zlib-1.2.3.tar.bz2 to /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Source unpacked in /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Preparing source in /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/splashutils-1.5.4.4 ...
 * Applying splashutils-1.5.4.4-gentoo-typo-fix.patch ...                                                              [ ok ]
 * Applying splashutils-1.5.4.4-freetype-bz2.patch ...                                                                 [ ok ]
 * Applying splashutils-1.5.4.4-bzip2.patch ...                                                                        [ ok ]
 * Running eautoreconf in '/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/splashutils-1.5.4.4' ...
 * Running libtoolize --install --copy --force --automake ...                                                          [ ok ]
 * Running aclocal -I m4 ...                                                                                           [ ok ]
 * Running autoconf ...                                                                                                [ ok ]
 * Running autoheader ...                                                                                              [ ok ]
 * Running automake --add-missing --copy --force-missing ...                                                           [ ok ]
 * Running elibtoolize in: splashutils-1.5.4.4/
 *   Applying portage/1.2.0 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.4.2 patch ...
 *   Applying target-nm/2.4.2 patch ...
 * Running elibtoolize in: splashutils-1.5.4.4/libs/freetype-2.3.12/
 * Running elibtoolize in: splashutils-1.5.4.4/libs/freetype-2.3.12/builds/unix/
 *   Applying portage/2.2 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.2.6 patch ...
 *   Applying target-nm/2.4.2 patch ...
 * Running elibtoolize in: splashutils-1.5.4.4/libs/jpeg-8a/
 *   Applying portage/2.2 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.2.6 patch ...
 *   Applying target-nm/2.4.2 patch ...
 * Running elibtoolize in: splashutils-1.5.4.4/libs/libpng-1.4.3/
 *   Applying portage/2.2 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.2.6 patch ...
 *   Applying target-nm/2.4.2 patch ...
 * Running elibtoolize in: splashutils-1.5.4.4/libs/zlib-1.2.3/
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/splashutils-1.5.4.4 ...
make -j5 CC=x86_64-pc-linux-gnu-gcc LIB=lib64 STRIP=true
x86_64-pc-linux-gnu-gcc -O2 -march=native -pipe -Wl,-O1 -Wl,--as-needed fbres.c -o fbres
x86_64-pc-linux-gnu-gcc -O2 -march=native -pipe -Wl,-O1 -Wl,--as-needed usleep.c -o usleep
true fbres
true usleep
make[1]: Entering directory `/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/miscsplashutils-0.1.8/fbtruetype'
x86_64-pc-linux-gnu-gcc -O2 -march=native -pipe -I/usr/include/freetype2   -c -o fbtruetype.o fbtruetype.c
x86_64-pc-linux-gnu-gcc -O2 -march=native -pipe -I/usr/include/freetype2   -c -o messages.o messages.c
x86_64-pc-linux-gnu-gcc -O2 -march=native -pipe -I/usr/include/freetype2   -c -o console.o console.c
x86_64-pc-linux-gnu-gcc -O2 -march=native -pipe -I/usr/include/freetype2   -c -o ttf.o ttf.c
x86_64-pc-linux-gnu-gcc -O2 -march=native -pipe -I/usr/include/freetype2   -c -o luxisri.o luxisri.c
ttf.c:16:30: fatal error: freetype/ftoutln.h: No such file or directory
compilation terminated.
make[1]: *** [ttf.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/miscsplashutils-0.1.8/fbtruetype'
make: *** [all] Error 2
emake failed
 * ERROR: media-gfx/splashutils-1.5.4.4-r1::gentoo failed (configure phase):
 *   failed to build miscsplashutils
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_configure
 *   environment, line 2868:  Called die
 * The specific snippet of code:
 *       emake CC="${CC}" LIB=$(get_libdir) STRIP=true || die "failed to build miscsplashutils";
 *
 * If you need support, post the output of `emerge --info '=media-gfx/splashutils-1.5.4.4-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-gfx/splashutils-1.5.4.4-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/miscsplashutils-0.1.8'
 * S: '/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/splashutils-1.5.4.4'


Alguien sabe cómo se puede solucionar esto?

Por otro lado, por ahí leí que splashutils está cayendo en desuso y se quiere usar Plymouth. Es cierto eso? Convendría pasarme a Plymouth)

Muchas gracias!!!!!


Last edited by natrix on Sat Jul 26, 2014 12:00 am; edited 1 time in total
Back to top
View user's profile Send private message
bontakun
Apprentice
Apprentice


Joined: 25 Jan 2005
Posts: 231
Location: Temuco - Chile

PostPosted: Fri Jul 25, 2014 1:53 pm    Post subject: Reply with quote

no estoy usando splashutils para bootear, pero podrías dale una mirada a
https://forums.gentoo.org/viewtopic-t-369521-start-0.html
http://wiki.gentoo.org/wiki/Fbsplash

te comento además que en instalaciones anteriores había perdido splashutils al cambiar de openRC a systemD, por lo que decidí instalar Plymouth, ya que estoy armando una instalación desde cero y anda de perillas, seguir los manuales oficiales y listo.

Saludos
_________________
de cada 10 personas que ven television... 5 son la mitad
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 395

PostPosted: Sat Jul 26, 2014 12:00 am    Post subject: Reply with quote

Hola bontakun!!! muchas gracias por responder.

Te cuento que ya pude solucionar el problema, había dos trabas diferentes que frenaban la compilación, una era un problema con la truetype y la otra el mng. Al final lo pude arreglar así:

Code:
USE="-truetype -mng" emerge media-gfx/splashutils


Voy a tener presente lo que me decir de plymouth. La próxima que pase algo con splashutils me cambio!!!!

Nuevamente gracias :) :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum