Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[KERNEL]ipw3945 no funciona la compilar kernel libre
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
lukki
n00b
n00b


Joined: 23 Jul 2014
Posts: 2

PostPosted: Wed Jul 23, 2014 7:25 am    Post subject: [KERNEL]ipw3945 no funciona la compilar kernel libre Reply with quote

Buenas,
La cosa es así: desde hace semanas me preguntaba por que uname -a me tiraba el kernel que tenía desde la instalación: ERA PORQUE NUNCA COMPILABA E INSTALABA los nuevos :roll: :oops: :lol:
Me di a la tarea de hacerlo. Pero previo a esto -en verdad desde hace semanas- agregue la USE=deblob así que los nuevos gentoo-sources eran limpiados de porqueria privativa.
Que pasó? Sin esa porqueria murio la wifi.
Info:
Code:

lukkix ~ # uname -a
Linux lukkix 3.15.6-gentoo-gnu #5 SMP Mon Jul 21 20:21:11 2014 x86_64 Intel(R) Core(TM)2 Duo CPU T5450 @ 1.66GHz GenuineIntel GNU/Linux

Code:

lukkix ~ # ifconfig -a
enp8s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.34  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fd11:2233:4455:1:21b:24ff:fee8:5e14  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::21b:24ff:fee8:5e14  prefixlen 64  scopeid 0x20<link>
        ether 00:1b:24:e8:5e:14  txqueuelen 1000  (Ethernet)
        RX packets 7914  bytes 8688852 (8.2 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 6838  bytes 756478 (738.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17 

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

sit0: flags=128<NOARP>  mtu 1480
        sit  txqueuelen 0  (IPv6-in-IPv4)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp6s0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 00:1c:bf:00:1b:ca  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lukkix ~ #

Code:

lukkix ~ # lspci -k
06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
   Subsystem: Intel Corporation PRO/Wireless 3945ABG Network Connection
   Kernel driver in use: iwl3945
   Kernel modules: iwl3945

Code:

lukki@lukkix ~ $ dmesg | grep firmware
[  135.069604] 0000:06:00.0: Missing Free firmware
[  135.069623] iwl3945 0000:06:00.0: Direct firmware load failed with error -2
[  135.070426] iwl3945 0000:06:00.0: /*(DEBLOBBED)*/ firmware file req failed: -22
##MUCHAS VECES MAS LO MISMO##

Code:

lukkix ~ # nano /var/log/dmesg
[    9.673030] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree$
[    9.673034] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[    9.673097] iwl3945 0000:06:00.0: can't disable ASPM; OS doesn't have ASPM control
[    9.673116] iwl3945 0000:06:00.0: enabling device (0000 -> 0002)
[    9.728920] iwl3945 0000:06:00.0: Tunable channels: 11 802.11bg, 13 802.11a channels
[    9.728925] iwl3945 0000:06:00.0: Detected Intel Wireless WiFi Link 3945ABG
[    9.729014] iwl3945 0000:06:00.0: irq 45 for MSI/MSI-X
[    9.729315] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'


Y mi menuconfig: http://paste.desdelinux.net/5012

Los chicos de #argentoo me pasaron la data de un overlay de funtoo http://gpo.zugaina.org/net-wireless/ipw3945/ChangeLog , cree un overlay local pero al instalarlo me da error de configuración del kernel aunque los parametros que pide reparar estan como exige.
Bueno no se que mas contar así que mi pregunta es: Es posible hacer funcionar la wifi sin quitar la USE=deblob?

Fucking Intel!!! Fucking drivers!!! I want to be @FREE!!!

Saludos.
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 347

PostPosted: Sat Jul 26, 2014 10:43 pm    Post subject: Reply with quote

Hola lukki:
Como vas con tu deblob? Pudiste avanzar?

Hace un in tiempo, influenciado por las palabras de Linus (http://www.muylinux.com/2012/06/18/linus-a-nvidia-que-te-jodan) había probado el USE deblob y la belleza de un núcleo GNU. Pero la verdad es que tuve muchos problemas del tipo drivers.

Uno de los problemas que tuve fue mi webcam que no andaba, por alguna razón no respondía uvcvideo y lo solucioné con lo siguiente:
Code:
git clone git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git uvcvideo
cd uvcvideo
git remote add uvcvideo git://linuxtv.org/pinchartl/uvcvideo.git
git remote update
git checkout -b uvcvideo-master uvcvideo/uvcvideo-next

Fuente: http://www.ideasonboard.org/uvc/

Pero al final llegué a la conclusión personal de que para una PC de escritorio y con mis escasos conocimientos es complicado mantener un sistema completamente libre y volví al núcleo tradicional. Espero no desalentarte….
Back to top
View user's profile Send private message
lukki
n00b
n00b


Joined: 23 Jul 2014
Posts: 2

PostPosted: Mon Jul 28, 2014 5:36 pm    Post subject: Reply with quote

Hola @natrix;
Lamentablemente estoy estancado y no creo que por ahora tenga solución. Por lo que me dicen el driver es privativo y no hay forma de hacerlo andar "libremente".
Por suerte mi situación económica me da la oportunidad de pensar en comprar una wireless usb (en realidad tengo una por ahí tirada que compre en alguna época y nunca la pude hacer andar) así que estoy en ese plan. La verdad es que con las otras cosas no tuve problemas; la webcam me anda bien (tampoco la uso mucho -ni poco-).
Tendremos que esperar para poder liberar nuestras maquinas. Pero seguro que mas temprano que tarde lo haremos :wink:
Gracias por pasarte.
PD: alguna sugerencia para la wireless usb?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum