Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nginx and php-fpm not showing php errors
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
dylan_stark
Tux's lil' helper
Tux's lil' helper


Joined: 30 Aug 2005
Posts: 132
Location: Belgrade, Serbia

PostPosted: Wed Oct 09, 2013 12:35 pm    Post subject: nginx and php-fpm not showing php errors Reply with quote

I can't make nginx and php-fpm to display or even log PHP errors!
I've been running in circles all morning and don't know where to look anymore.

in php.ini
display_errors = On
log_errors = On

in php-fpm.conf
php_flag[display_errors] = on
;php_admin_value[error_log] = /var/log/fpm-php.www.log
php_admin_flag[log_errors] = on
;php_admin_value[memory_limit] = 32M

catch_workers_output = yes
error_log = /var/log/php-fpm.log


But logs are not showing anywhere!!
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6336
Location: Blighty

PostPosted: Wed Oct 09, 2013 1:36 pm    Post subject: Reply with quote

Silly question, but how have you configured nginx to use php?

Here's my code block from nginx.conf
Code:

        location ~ \.php$ {
            include        fastcgi_params;
            keepalive_timeout 0;
            fastcgi_param  SCRIPT_FILENAME $document_root$fastcgi_script_name;
            fastcgi_pass   127.0.0.1:3052;
        }


And I run php in fastcgi mode on 127.0.0.1:3052
On Gentoo you may have to make a custom init.d script to do this.
_________________
When baselayout tells you to update config files or things break WE REALLY DO MEAN IT

Please add SOLVED to the thread title if your issue has been
Strip comments from configs please
Back to top
View user's profile Send private message
dylan_stark
Tux's lil' helper
Tux's lil' helper


Joined: 30 Aug 2005
Posts: 132
Location: Belgrade, Serbia

PostPosted: Wed Oct 09, 2013 1:41 pm    Post subject: Reply with quote

PHP is working fine.
Just can't see errors :(
Back to top
View user's profile Send private message
dylan_stark
Tux's lil' helper
Tux's lil' helper


Joined: 30 Aug 2005
Posts: 132
Location: Belgrade, Serbia

PostPosted: Wed Oct 09, 2013 1:49 pm    Post subject: Reply with quote

Solved!
It was opcache "problem" in PHP!!

One general lesson learned.
Start with basic configuration, make sure everything works and that add features one by one.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum