Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]No sound at all
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message

Joined: 30 Aug 2013
Posts: 7

PostPosted: Fri Aug 30, 2013 8:02 am    Post subject: [Solved]No sound at all Reply with quote

I install gentoo on my thinkpad x201 laptop, but the computer do not make any sound, any help will be appericiated, thanks.
Below lists the info about my gentoo.

dmesg shows:
[ 1.168729] ALSA device list:
[ 1.170476] No soundcards found.

lspci result(lspci | grep -i audio):
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)

lsmod result(lsmod | grep snd):
snd_hda_codec_hdmi 28465 1
snd_hda_codec_conexant 34286 1
snd_hda_intel 29590 1
snd_hda_codec 127867 3 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel
snd_hwdep 5949 1 snd_hda_codec

the info tells me the driver works right? Please let me know if i am wrong.

aplay -l result:
**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 0: CX20585 Analog [CX20585 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

alsamixer is working and i unmute all.

So where am i going, there is no sound at all. help me, thanks.

i try run "alsa-info" and provides info about my laptop at
Wish it helps.

finally, i make the "speaker-test -c 2 -t wav" work by follow steps at
i ran the command
amixer set -c 1 Master 70 unmute
amixer set -c 1 PCM 70 unmute

i guess i do not unmute sound card at all.(what i do to unmute sound card is run "alsamixer" to unmute, it seems i was wrong).
Though, i do not have sound at my Xfce4 enviroment and i need to work on it.

add the following text to [b]~/.asoundrc

defaults.pcm.card 1
defaults.pcm.device 0
defaults.ctl.card 1

That is all to get my sound card work
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum