Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox, Chrome, and VLC won't produce sound
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Tesla23
n00b
n00b


Joined: 10 Aug 2015
Posts: 1

PostPosted: Mon Aug 10, 2015 8:04 pm    Post subject: Firefox, Chrome, and VLC won't produce sound Reply with quote

I have tried recently to use my usb wireless headphones on my gentoo computer. However, I have found that it doesn't work with Chrome, Firefox, or VLC player. It does work in Konquerer and system sounds. Here is my sound.conf in /etc:
Code:
defaults.pcm.card 2
defaults.pcm.device 2
defaults.ctl.card 2
Back to top
View user's profile Send private message
weeeeeeeeeee
n00b
n00b


Joined: 29 Jul 2015
Posts: 18

PostPosted: Tue Aug 11, 2015 8:07 am    Post subject: Reply with quote

I had that same problem recently, and can't remember precisely what I did, but I can look up the machine that I fixed it on...
I think from memory the problem was that firefox and various programs ignored the sound.conf file.

I tried two things which conflicted but one fixed them; I tried a local config file, and also a kernel boot parameter to change the order of the sound cards so the default PCM was card 0 and not the HDMI where firefox was sending sound to by default.

I got most of my leads from precisely here
https://wiki.gentoo.org/wiki/ALSA#HTML5_does_not_play_in_the_Firefox_browser
and
https://wiki.gentoo.org/wiki/ALSA#Laptops_with_HDMI_audio_output

If you get stuck I can go find the machine that I fixed it on and give more detail...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum