Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Clementine build fails because of gstreamer-app-1.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1864

PostPosted: Mon Aug 24, 2015 6:58 pm    Post subject: Clementine build fails because of gstreamer-app-1.0 Reply with quote

Hi!
I am currently trying to compile Clementine-9999 or Clementine-1.2.3 on my ~amd64 system with KDE5.
Compile fails with htis error:
Code:

-- The C compiler identification is GNU 4.9.3
-- The CXX compiler identification is GNU 4.9.3
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found PkgConfig: /usr/bin/x86_64-pc-linux-gnu-pkg-config (found version "0.28")
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found
-- Found Qt4: /usr/bin/qmake (found suitable version "4.8.7", minimum required is "4.5.0")
-- Found Qt4: /usr/bin/qmake (found version "4.8.7")
-- Found OpenGL: /usr/lib64/libGL.so 
-- Boost version: 1.57.0
-- Found Gettext: /usr/bin/msgmerge (found version "0.19.5.1")
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE 
-- Found PROTOBUF: /usr/lib64/libprotobuf.so 
FFTW3 lib not found. Set FFTW3_DIR to find it.
-- checking for module 'libcdio'
--   found libcdio, version 0.93
-- checking for module 'libchromaprint'
--   found libchromaprint, version 1.2.0
-- checking for one of the modules 'cryptopp;libcrypto++'
-- checking for module 'gio-2.0'
--   found gio-2.0, version 2.44.1
-- checking for module 'glib-2.0'
--   found glib-2.0, version 2.44.1
-- checking for module 'gobject-2.0'
--   found gobject-2.0, version 2.44.1
-- checking for module 'gstreamer-1.0'
--   found gstreamer-1.0, version 1.4.5
-- checking for module 'gstreamer-app-1.0'
--   package 'gstreamer-app-1.0' not found
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:340 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPkgConfig.cmake:502 (_pkg_check_modules_internal)
  CMakeLists.txt:66 (pkg_check_modules)


-- Configuring incomplete, errors occurred!
See also "/var/tmp/portage/media-sound/clementine-9999/work/clementine-9999_build/CMakeFiles/CMakeOutput.log".
See also "/var/tmp/portage/media-sound/clementine-9999/work/clementine-9999_build/CMakeFiles/CMakeError.log".
 * ERROR: media-sound/clementine-9999::gentoo failed (configure phase):
 *   cmake failed
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 3455:  Called cmake-utils_src_configure
 *   environment, line  854:  Called _execute_optionally 'src_configure'
 *   environment, line  417:  Called enable_cmake-utils_src_configure
 *   environment, line 1174:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 *
 * If you need support, post the output of `emerge --info '=media-sound/clementine-9999::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-sound/clementine-9999::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-sound/clementine-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/clementine-9999/temp/environment'.
 * Working directory: '/var/tmp/portage/media-sound/clementine-9999/work/clementine-9999_build'
 * S: '/var/tmp/portage/media-sound/clementine-9999/work/clementine-9999'


It seems to be a problem with gstreamer, but i habe version media-libs/gstreamer-1.4.5 installed. Any ideas?
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6189

PostPosted: Mon Aug 24, 2015 8:03 pm    Post subject: Reply with quote

Well, that one should come from media-libs/gst-plugins-base:1.0, but you should already have those...

... :roll: Also, do you really need the live version of clementine ?
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1864

PostPosted: Tue Aug 25, 2015 4:56 pm    Post subject: Reply with quote

Hm, when I try
Code:

emerge -a media-libs/gst-plugins-base:1.0

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] media-libs/gst-plugins-base-1.4.5:1.0::gentoo [0.10.36-r2:0.10::gentoo] USE="X alsa introspection nls ogg orc pango theora vorbis -ivorbis" ABI_X86="32 (64) (-x32)" 0 KiB

it seems already to be provided there.
Just tried the live version because clementine-1.2.3 won't compile :roll: I am a little bit out of options here.
MAybe somebody knows a decent alternative? Amarok isn't maintained anymore, right?
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6189

PostPosted: Wed Aug 26, 2015 5:39 pm    Post subject: Reply with quote

Martux wrote:
Hm, when I try
Code:

emerge -a media-libs/gst-plugins-base:1.0

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] media-libs/gst-plugins-base-1.4.5:1.0::gentoo [0.10.36-r2:0.10::gentoo] USE="X alsa introspection nls ogg orc pango theora vorbis -ivorbis" ABI_X86="32 (64) (-x32)" 0 KiB

it seems already to be provided there.


:roll: No, the above says the exact opposite :sigh:
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1864

PostPosted: Wed Aug 26, 2015 7:04 pm    Post subject: Reply with quote

LOL, you're right of course. Oversaw that.
Well, with that installed, clementine-1.2.3 works again, not the live ebuild.
Thanks for the hint!
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 267
Location: Estonia

PostPosted: Fri Aug 28, 2015 5:10 am    Post subject: Reply with quote

Interesting that the main tree ones seem to be depending on gstreamer 0.10 slot stuff instead? Including gst-plugins-base:0.10
_________________
GNOME team lead; GStreamer
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6189

PostPosted: Fri Aug 28, 2015 10:04 pm    Post subject: Reply with quote

Leio wrote:
Interesting that the main tree ones seem to be depending on gstreamer 0.10 slot stuff instead? Including gst-plugins-base:0.10

Well, you know how it is: some maintainers are a bit sloppy with the updates and fail to notice new/dropped dependencies (especially if they already have those new dependencies installed), some deliberately ignore certain bugs, even if they're repeatedly brought to their attention.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum