Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Clementine Spotify plugin? [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
greyspoke
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2010
Posts: 137

PostPosted: Thu Feb 25, 2016 8:45 pm    Post subject: Clementine Spotify plugin? [SOLVED] Reply with quote

Clementine used to play spotify stuff for me but it has stopped at a recent update. It says a plugin needs to be installed due to licensing issues on the settings page where I give it my Spotify password. But I can't see a way of doing that, though there is a directory
Code:
blah ~/.config/Clementine/spotifyblob/version14-64bit $ ls
blob           libspotify.so.12    libspotify.so.12.1.45
libspotify.so  libspotify.so.12.1
blah ~/.config/Clementine/spotifyblob/version14-64bit $

which looks promising. According to some old posts on Ubuntu, Debian forums a button to install the plugin should appear somewhere, but it isn't for me.
ETA I have successfully installed Spotify 1.0.23.93, the Clementine version is 1.3_rc1


Last edited by greyspoke on Sat May 07, 2016 6:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
Tatsh
Apprentice
Apprentice


Joined: 22 Jul 2007
Posts: 169

PostPosted: Mon Mar 07, 2016 8:50 am    Post subject: Reply with quote

The current version is like version16.

Close Clementine. Try going to ~.config/Clementine/spotifyblob and deleting everything inside. Open Clementine and open preferences. Go to Spotify, log out. Then log in again. A prompt should ask to install the blob and then it will install the local copy.

I would strongly suggest not relying upon the version from Portage.

The actual blob files are stored here: https://spotify.clementine-player.org/version16-64bit/
Back to top
View user's profile Send private message
greyspoke
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2010
Posts: 137

PostPosted: Thu Mar 10, 2016 7:05 pm    Post subject: Reply with quote

Thanks Tatsh, that's pretty much the sort of thing I tried before, but it doesn't work. Whether with an empty spotifyblob directory or with the latest blob bits in an appropriately named subdirectory, nothing happens when I click to log in to my spotify account. It says that I am not logged in to Spotify and that the plugin is not installed. Running Clementine from a terminal with --verbose, nothing shows up. It is as if the login button doesn't do anything.
Back to top
View user's profile Send private message
greyspoke
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2010
Posts: 137

PostPosted: Sat May 07, 2016 6:46 pm    Post subject: Reply with quote

Well clementine-1.3.1 behaves itself :) so I have marked the thread as solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum