Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]media-libs/tiff is giving very weird self-conflict
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Johnny_Bit
Apprentice
Apprentice


Joined: 30 Aug 2005
Posts: 242
Location: Poland

PostPosted: Sat Aug 31, 2013 6:59 am    Post subject: [SOLVED]media-libs/tiff is giving very weird self-conflict Reply with quote

Hello,

I am faced with following problem when trying to update @world:
Code:
# emerge -avuDN @world

These are the packages that would be merged, in order:

Calculating dependencies /
... done!

Total: 0 packages, Size of downloads: 0 kB

WARNING: One or more updates have been skipped due to a dependency conflict:

media-libs/tiff:0

  (media-libs/tiff-4.0.3-r4::gentoo, ebuild scheduled for merge) conflicts with
    media-libs/tiff:0=[abi_x86_32(-),abi_x86_32(-)] required by (media-libs/lcms-2.5-r1::gentoo, installed)
  (media-libs/tiff-4.0.3-r4::gentoo, ebuild scheduled for merge) conflicts with
    media-libs/tiff:0/0=[abi_x86_32(-),abi_x86_32(-)] required by (media-libs/lcms-2.5-r1::gentoo, installed)


Nothing to merge; quitting.


As You can see - same version conflicts with itself!

it gets weirder when trying to emerge just media-libs/tiff:

Code:
# emerge -av1 media-libs/tiff
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] media-libs/tiff-3.9.7:3 [4.0.2-r1:0] USE="cxx jpeg zlib -jbig" 1,434 kB

Total: 1 package (1 in new slot), Size of downloads: 1,434 kB

WARNING: One or more updates have been skipped due to a dependency conflict:

media-libs/tiff:0

  (media-libs/tiff-4.0.3-r4::gentoo, ebuild scheduled for merge) conflicts with
    media-libs/tiff:0=[abi_x86_32(-),abi_x86_32(-)] required by (media-libs/lcms-2.5-r1::gentoo, installed)
  (media-libs/tiff-4.0.3-r4::gentoo, ebuild scheduled for merge) conflicts with
    media-libs/tiff:0/0=[abi_x86_32(-),abi_x86_32(-)] required by (media-libs/lcms-2.5-r1::gentoo, installed)


Would you like to merge these packages? [Yes/No]


So - I cannot even emerge it alone at version 4.0.x!

What info should I provide so You could help me with this?


Last edited by Johnny_Bit on Sat Aug 31, 2013 8:43 am; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3839
Location: Irgendwo im Nirgendwo

PostPosted: Sat Aug 31, 2013 7:26 am    Post subject: Reply with quote

multilib issue - put media-libs/tiff into your package.accept_keywords.
https://bugs.gentoo.org/show_bug.cgi?id=482756
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Johnny_Bit
Apprentice
Apprentice


Joined: 30 Aug 2005
Posts: 242
Location: Poland

PostPosted: Sat Aug 31, 2013 8:33 am    Post subject: Reply with quote

This is interesting, as my whole system is strictly 32bit... I will try Your solution.
Back to top
View user's profile Send private message
Johnny_Bit
Apprentice
Apprentice


Joined: 30 Aug 2005
Posts: 242
Location: Poland

PostPosted: Sat Aug 31, 2013 8:41 am    Post subject: Reply with quote

That... Worked. Thank You!

Code:
# emerge -avuDN @world

These are the packages that would be merged, in order:

Calculating dependencies /
... done!
[ebuild     U ~] media-libs/tiff-4.0.3-r5 [4.0.2-r1] USE="cxx jpeg lzma zlib -jbig -static-libs" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum