Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
portage 2.2.X won't emerge anything; fails in unpack source
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
mhill
Tux's lil' helper
Tux's lil' helper


Joined: 09 Mar 2003
Posts: 85
Location: Thornton, CO

PostPosted: Wed Aug 21, 2013 4:06 pm    Post subject: portage 2.2.X won't emerge anything; fails in unpack source Reply with quote

I keep portage up to date, so a couple months ago I routinely upgraded it; I think it was to 2.2.0_rcX . Emerge immediately stopped working; it said the source file didn't exist, even though it did (and this included rebuilding existing packages with existing source files). Fortunately, I was able to reinstall the previous package file.

Well, last night I updated it again (at least I was aware I might have problems again). Sure enough, every emerge attempt fails:

Code:
#  emerge portage

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-apps/portage-2.2.0
 * portage-2.2.0.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...            [ ok ]
>>> Unpacking source...
>>> Unpacking portage-2.2.0.tar.bz2 to /var/tmp/portage/sys-apps/portage-2.2.0/work
 * ERROR: sys-apps/portage-2.2.0::gentoo failed (unpack phase):
 *   portage-2.2.0.tar.bz2 does not exist
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_unpack
 *        environment, line 2573:  Called __eapi0_src_unpack
 *   phase-helpers.sh, line  585:  Called unpack 'portage-2.2.0.tar.bz2'
 *   phase-helpers.sh, line  310:  Called die
 * The specific snippet of code:
 *              [[ ! -s ${srcdir}${x} ]] && die "${x} does not exist"
 *
 * If you need support, post the output of `emerge --info '=sys-apps/portage-2.2.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/portage-2.2.0::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/portage-2.2.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/portage-2.2.0/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-apps/portage-2.2.0/work'
 * S: '/var/tmp/portage/sys-apps/portage-2.2.0/work/portage-2.2.0'

>>> Failed to emerge sys-apps/portage-2.2.0, Log file:

>>>  '/var/tmp/portage/sys-apps/portage-2.2.0/temp/build.log'


Clearly, the problem is not that the source file doesn't exist:

Code:
#  ls -l /usr/portage/distfiles/portage-2.2.0.tar.bz2
-rw-rw-r-- 1 root portage 898674 Aug 12 17:15 /usr/portage/distfiles/portage-2.2.0.tar.bz2
#  emerge -pvt portage

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R    ] sys-apps/portage-2.2.0  USE="doc (ipc) -build -epydoc (-pypy2_0) -python2 -python3 (-selinux) -xattr" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_2 (-pypy1_9) -pypy2_0 -python2_6 (-python3_1) -python3_3 (-python3_4)" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


So for me, right now, portage is horribly broken. The one thing I can use it for is to go back to the previous, working, version. :( But at some point I know I'll have to move forward, so I would like to get this figured out soon.

Thanks for any help you can provide!
_________________
Michael Hill

Desktop: Intel i7-3930K, 16GB DDR3, 1x 240GB SSD, 2x 2TB SATA, GeForce GTX660Ti, TSSTcorp SH-S203N
Laptop: Dell Inspiron 1720, Intel T7500, 2GB DDRAM, 1x 250GB SATA, GeForce 8600M GT
Back to top
View user's profile Send private message
broken_chaos
Guru
Guru


Joined: 18 Jan 2006
Posts: 370
Location: Ontario, Canada

PostPosted: Wed Aug 21, 2013 9:18 pm    Post subject: Reply with quote

Could you post your emerge --info? Perhaps there's something strange going on with your DISTDIR setting (or something else that's in emerge --info).
Back to top
View user's profile Send private message
zmedico
Developer
Developer


Joined: 02 Jan 2004
Posts: 294
Location: California USA

PostPosted: Thu Aug 22, 2013 12:43 am    Post subject: Reply with quote

Looks like bad permissions on DISTDIR, triggered since FEATURES=userpriv is enabled by default now.
_________________
Zac
Back to top
View user's profile Send private message
mhill
Tux's lil' helper
Tux's lil' helper


Joined: 09 Mar 2003
Posts: 85
Location: Thornton, CO

PostPosted: Thu Aug 22, 2013 6:33 am    Post subject: Reply with quote

I'm pretty sure I've been using userpriv for a long time; I know it uses the user "portage" to download the files. There isn't any problem that I know of with the fetch phase; it's when it goes to read the file (even if it just wrote it) that it claims there's no such file. For that matter, it's not claiming that the file isn't readable, but that it doesn't exist at all.

Code:
# emerge --info
Portage 2.1.12.2 (default/linux/amd64/13.0, gcc-4.7.3, glibc-2.17, 3.9.11-gentoo-r1 x86_64)
=================================================================
System uname: Linux-3.9.11-gentoo-r1-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.2
KiB Mem:    16363924 total,   4484516 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Wed, 21 Aug 2013 12:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.9-r1
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.5.4, 4.7.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=core2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg ccache collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.usu.edu/mirrors/gentoo/ http://distfiles.gentoo.org/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j12"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl additions aiglx alsa amd64 ao apache2 audacious audiofile bash-completion bcmath berkdb branding bzip2 bzlib calendar cdinstall cli cracklib crypt curl cxx dbase dbx dedicated device-mapper dga divx doc dot dovecot-sasl dri dv efiemu expat faac fame fbcon ffmpeg fftw flac flatfile fluidsynth font-server fontconfig fontforge gd gecko-sdk gif gimpprint ginac glitz glut gnuplot gnutls gpgme gs gstreamer gtk guidexml hardenedphp hddtemp hou iconv id3tag imagemagick imlib inifile inotify jack jpeg jpeg2k keyscrub lame lastfmradio latin1 lcms libmms libsamplerate lm_sensors logrotate logwatch lzma mbox memlimit mikmod mime mmap mmx modplug modules mount mp3 mp4 mpm-prefork mudflap multilib mysql ncurses no-suexec nocardbus nocd nodrm nomotif nowin nptl nsplugin ofx ogg opengl pam pcntl pcre pda php pie plotutils png posix ppds quotes readline realmedia rtsp sasl server session shared sharedmem simplexml skins smpeg smtp sndfile sockets sou sse sse2 ssl ssse3 startup-notification subtitles system-sqlite sysvipc tagwriting tcl tcpd theora threads tidy tiff timidity tk truetype ups usb usbhost userlocales vhosts videos vim-syntax vorbis wma wmp wv wxgtk1 wxwidgets wxwindows xcb xine xml xpm xprint xscreensaver xvid zlib" ABI_X86="64" ALSA_CARDS="ice1712" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_core authn_dbd authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="i386" QEMU_USER_TARGETS="i386" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="vga nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

Permissions shouldn't be a problem:

Code:
$ ls -ld /usr{,/portage{,/distfiles}}/
drwxr-xr-x  15 root    root     4096 Apr 27 14:50 /usr//
drwxr-xr-x 167 root    root     4096 Aug 20 05:31 /usr/portage//
drwxrwsr-x   6 portage portage 49152 Aug 21 12:18 /usr/portage/distfiles//

Thanks.
_________________
Michael Hill

Desktop: Intel i7-3930K, 16GB DDR3, 1x 240GB SSD, 2x 2TB SATA, GeForce GTX660Ti, TSSTcorp SH-S203N
Laptop: Dell Inspiron 1720, Intel T7500, 2GB DDRAM, 1x 250GB SATA, GeForce 8600M GT
Back to top
View user's profile Send private message
zmedico
Developer
Developer


Joined: 02 Jan 2004
Posts: 294
Location: California USA

PostPosted: Thu Aug 22, 2013 6:38 am    Post subject: Reply with quote

What filesystem type is /usr/portage/distfiles? I once had a similar error because ${DISTDIR} was mounted via sshfs-fuse without the allow_other option enabled.
_________________
Zac
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9014
Location: beyond the rim

PostPosted: Thu Aug 22, 2013 6:38 am    Post subject: Reply with quote

Maybe broken symlinks to SRC_URI files in the builddir?
Back to top
View user's profile Send private message
mhill
Tux's lil' helper
Tux's lil' helper


Joined: 09 Mar 2003
Posts: 85
Location: Thornton, CO

PostPosted: Fri Aug 23, 2013 3:26 pm    Post subject: Reply with quote

distfiles is JFS. /usr/portage/distfiles is a symlink to /export/distfiles (because I NFS-export it). I reiterate that it works just fine up thru portage-2.1.12.13 at least; it fails under 2.2.0, it failed when I tried to roll back to 2.1.13.3, and portage downgraded itself to 2.1.12.2 when I masked 2.2.0. Nothing has changed in the setup, except portage versions. I didn't quite follow the bit about broken SRC_URI links, but the same thing should apply.

Thanks.
_________________
Michael Hill

Desktop: Intel i7-3930K, 16GB DDR3, 1x 240GB SSD, 2x 2TB SATA, GeForce GTX660Ti, TSSTcorp SH-S203N
Laptop: Dell Inspiron 1720, Intel T7500, 2GB DDRAM, 1x 250GB SATA, GeForce 8600M GT
Back to top
View user's profile Send private message
zmedico
Developer
Developer


Joined: 02 Jan 2004
Posts: 294
Location: California USA

PostPosted: Fri Aug 23, 2013 6:10 pm    Post subject: Reply with quote

mhill wrote:
distfiles is JFS. /usr/portage/distfiles is a symlink to /export/distfiles (because I NFS-export it).


In that case, you need to check the permissions on /export/distfiles:
Code:
ls -ld /export{,/distfiles}


mhill wrote:
Permissions shouldn't be a problem:

Code:
$ ls -ld /usr{,/portage{,/distfiles}}/
drwxr-xr-x  15 root    root     4096 Apr 27 14:50 /usr//
drwxr-xr-x 167 root    root     4096 Aug 20 05:31 /usr/portage//
drwxrwsr-x   6 portage portage 49152 Aug 21 12:18 /usr/portage/distfiles//


Funny that ls -ld doesn't show the symlink when there's a trailing slash.
_________________
Zac
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9014
Location: beyond the rim

PostPosted: Mon Aug 26, 2013 8:31 am    Post subject: Reply with quote

mhill wrote:
I didn't quite follow the bit about broken SRC_URI links, but the same thing should apply.

Yeah, that was aimed at Zac ;)
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5897
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Aug 26, 2013 10:40 am    Post subject: Reply with quote

while we're at it:

everyone was successful in installing sys-kernel/spl with portage 2.2.0 ?

it keeps on showing the error, that UTS_RELEASE can't be found:

Quote:
checking kernel source version... Not found
configure: error: *** Cannot find UTS_RELEASE definition.


luckily I still had a backup of an older version:

2.2.0_alpha179 <-- that one works


I tried setting up several "tricks" but that did no change:

- make prepare
- make -C /usr/src/linux modules_prepare
- chown -R root:portage
- chmod -R a+rX
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.5.2

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Mon Aug 26, 2013 12:41 pm    Post subject: Reply with quote

kernelOfTruth wrote:
everyone was successful in installing sys-kernel/spl with portage 2.2.0 ?


Please file bugs at https://bugs.gentoo.org instead of posting them to random threads that don't get tracked.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5897
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Aug 26, 2013 2:51 pm    Post subject: Reply with quote

TomWij wrote:
kernelOfTruth wrote:
everyone was successful in installing sys-kernel/spl with portage 2.2.0 ?


Please file bugs at https://bugs.gentoo.org instead of posting them to random threads that don't get tracked.


Sure,

just wanted to be sure that it's not a system issue or PEBKAC

will do so, then

Thanks :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.5.2

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum