Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Dual boot gentoo/win7
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Tman11
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2013
Posts: 77

PostPosted: Thu Aug 22, 2013 4:29 am    Post subject: [SOLVED] Dual boot gentoo/win7 Reply with quote

hello, so im now trying to do a dual boot gentoo install with a windows 7 as the other boot. I did a genkernel all to form my kernel and init. When it comes time to do the grub.conf I input everything correctly thats located in the /boot folder. My problem is when i reboot the pc and come upon the boot loader i select the gentoo linux OS and it tells me error 15.

I have my win7 OS on sda1 and the rest is listed

Code:
/dev/sda2 boot
/dev/sda3 swap
/dev/sda4 root

default 0
timeout 15
#splashimage

title Gentoo Linux
root (hd0,3)
kernel /boot/kernel-genkernel-x86_64-3.10.7-gentoo root=/dev/sda4
initrd /boot/initramfs-genkernel-x86_64-3.10.7-gentoo

# vim: ft-conf:
title Win7
rootnoverify (hd0,0)
makeactive
chainloader +1


Code:
ls /mnt/gentoo/boot
system.map-genkernel-x86_64-3.10.7-gentoo
boot
kernel-genkernel-x86_64-3.10.7-gentoo
initramfs-genkernel-x86_64-3.10.7-gentoo
grub
lost+found


any help on what i may have missed please let me know. thank you


Last edited by Tman11 on Thu Aug 22, 2013 6:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6256
Location: Goose Creek SC

PostPosted: Thu Aug 22, 2013 5:38 am    Post subject: Reply with quote

root (hd0,3) is incorrect; needs to point to the partition location of the grub files which may not, as in your case, be the root partition

default 0
timeout 15
#splashimage

title Gentoo Linux
root (hd0,1)
kernel /boot/kernel-genkernel-x86_64-3.10.7-gentoo root=/dev/sda4
initrd /boot/initramfs-genkernel-x86_64-3.10.7-gentoo

# vim: ft-conf:
title Win7
rootnoverify (hd0,0)
makeactive
chainloader +1
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Tman11
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2013
Posts: 77

PostPosted: Thu Aug 22, 2013 2:31 pm    Post subject: Reply with quote

makes total sense lol, just fixed it and starts right up. I don't wanna start another post but I'm needing help in my genkernel --menuconfig all on getting my eth0 up and going. can you help me out with this please heres my lscpi

http://bpaste.net/show/124908/

I also configured in the genkernel for Realtek etho to be recognized, yet still no wired Internet.

did as the guide told me and added the command config_eth0="dhcp" in the /etc/conf.d/net file. also the following cd /etc/init.d ln -s net.lo net.eth0 and had it start as a default.
Back to top
View user's profile Send private message
mvaterlaus
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2010
Posts: 145
Location: Switzerland

PostPosted: Thu Aug 22, 2013 2:55 pm    Post subject: Reply with quote

what does ifconfig -a tell you? I think, you have >=udev-197, which uses other network names than eth0, wlan0 etc. check out this link:

http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames/
Back to top
View user's profile Send private message
Tman11
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2013
Posts: 77

PostPosted: Thu Aug 22, 2013 3:25 pm    Post subject: Reply with quote

ifconfig -a tells me i have the following

enp2s0: (everything else follows)

lo: (everything else follows)

though i read your url post and went with the following

touch /etc/udev/rules.d/80-net-name-slot.rules

EDIT:

also when i type the following commands i get this

Code:
/etc/init.d/net.eth0 start
Brining up interface eth0
ERROR: interface eth0 does not exist
Ensure that you have loaded the correct kernel module for your hardware
ERROR: net.eth0 failed to start
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6256
Location: Goose Creek SC

PostPosted: Thu Aug 22, 2013 3:33 pm    Post subject: Reply with quote

The bad news:
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 02) -- I have a motherboard with one of these that last worked with a version 3.6 kernel.
have tried r8169 and r8168 drivers each time a major kernel revision occurred with no luck.
if you had wired with the install media, boot the install media and lspci -k and lsmod to determine what modules the media used, uname -a to determine kernel version.
did you reboot after touch /etc/udev/rules.d/80-net-name-slot.rules ?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Tman11
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2013
Posts: 77

PostPosted: Thu Aug 22, 2013 3:39 pm    Post subject: Reply with quote

DONAHUE wrote:
The bad news:
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 02) -- I have a motherboard with one of these that last worked with a version 3.6 kernel.
have tried r8169 and r8168 drivers each time a major kernel revision occurred with no luck.
if you had wired with the install media, boot the install media and lspci -k and lsmod to determine what modules the media used, uname -a to determine kernel version.
did you reboot after touch /etc/udev/rules.d/80-net-name-slot.rules ?



the touch /etc/blah/blah/blah worked like a charm :) i have my eth0 up and going heres a wgetpaste of my kernel to see whats up.

http://bpaste.net/show/125173/

Edit:: Had to set M to the listings under ethernet support---> realtek (forgot the exact string)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum