Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Grub Problem] "Booting the kernel" to infinity?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Wantoast
n00b
n00b


Joined: 14 Aug 2013
Posts: 16

PostPosted: Wed Aug 21, 2013 11:46 pm    Post subject: [Grub Problem] "Booting the kernel" to infinity? Reply with quote

Hi,
I've just finished installing Gentoo and setting up the bootloader, but after the reboot I'm stuck with this problem:
Grub do find the kernel, the point is that it stops while booting it/continues trying to do it infinitely:

Code:

Booting 'Gentoo Linux'
root (hd0,2)
Filesystem type is ext2fs, partition type 0x83
kernel /gentoo-kernel root=/dev/sda1
[Linux-bzImage, setup=0x300, size=0x43f880]

early console in decompress-kernel
Decompressing Linux . . . Parsing ELF . . .done
Booting the kernel


And then there's just a blinking cursor.

My partition table is this:
Code:

/dev/sda1 on /mnt/gentoo (ext4)
/dev/sda2 is swap
/dev/sda3 on /mnt/gentoo/boot (ext4)
/dev/sda4 on /mnt/gentoo/home (ext4)


Here's my grub.conf file:
Code:

default 0
timeout 30
#splashimage=(hd0,0)/boot/grub/splash.xpm.gz

#title Gentoo Linux 2.6.24-r5
#root (hd0,0)
#kernel /boot/kernel-genkernel-x86-2.6.24-gentoo-r5 root=/dev/ram0 real_root=/dev/sda3
#initrd /boot/initramfs-genkernel-x86-2.6.24-gentoo-r5

# vim:ft=conf:

title Gentoo Linux
root (hd0,2)
kernel /gentoo-kernel root=/dev/sda1

title Gentoo Linux (Rescue)
root (hd0,2)
kernel /gentoo-kernel root=/dev/sda1 init=/bin/bb


Just two things:
In order to start some LiveCDs I had to disalbe "acpi", but I tried to add "acpi=off" after the "root" variable and the issue persisted.
The handbook says that if I have an initramfs I should change the config file, but I don't actually know if I have it or not. So this could be the problem.

If it is, how can I solve?
If it isn't, are there any other solutions?

Thanks in advance!
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5190

PostPosted: Thu Aug 22, 2013 7:57 pm    Post subject: Reply with quote

Code:

title Gentoo Linux
root (hd0,2)
kernel /gentoo-kernel root=/dev/sda1

title Gentoo Linux (Rescue)
root (hd0,2)
kernel /gentoo-kernel root=/dev/sda1 init=/bin/bb


You problem is you need

Code:

title Gentoo Linux
root (hd0,2)
kernel /boot/gentoo-kernel root=/dev/sda1

title Gentoo Linux (Rescue)
root (hd0,2)
kernel /boot/gentoo-kernel root=/dev/sda1 init=/bin/bb


You were missing /boot for the kernel.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
Wantoast
n00b
n00b


Joined: 14 Aug 2013
Posts: 16

PostPosted: Fri Aug 23, 2013 10:11 am    Post subject: Reply with quote

No, that wasn't my problem. It could find the kernel but for some reasons during the boot it was just stopping.

Anyway I asked on some Irc chats and found that it was a kernel problem (which, first time, I tried to config manually). Using genkernel all went fine.
Probably it was just an "acpi" option that I checked but didn't have to.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum