Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
imagemagick..... it just won't build? [SOLVED]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 20 Aug 2013
Posts: 2

PostPosted: Tue Aug 20, 2013 5:49 pm    Post subject: imagemagick..... it just won't build? [SOLVED] Reply with quote

Tried turning USE flags on/off. No success. turning the cxx-flags off would make build freeze at stream.o though.

Also: redundant dependency with autotrace enabled. that's a bug, right? =)

So it said I should post following output:

ortage (default/linux/amd64/13.0, gcc-4.6.3, glibc-2.15-r3, 3.8.13-gentoo x86_64)
System Settings
System uname: Linux-3.8.13-gentoo-x86_64-Intel-R-_Core-TM-_i5-2410M_CPU_@_2.30GHz-with-gentoo-2.2
KiB Mem: 8158948 total, 7409256 free
KiB Swap: 0 total, 0 free
Timestamp of tree: Mon, 19 Aug 2013 17:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [disabled]
app-shells/bash: 4.2_p45
dev-lang/python: 2.7.5, 3.2.5-r1
dev-util/ccache: 3.1.9
dev-util/pkgconfig: 0.28
sys-apps/baselayout: 2.2
sys-apps/openrc: 0.11.8
sys-apps/sandbox: 2.6-r1
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.12.6
sys-devel/binutils: 2.23.1
sys-devel/gcc: 4.6.3
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc: 2.15-r3
Repositories: gentoo
CFLAGS="-O2 -pipe -march=corei7-avx -fomit-frame-pointer -fpredictive-commoning -ftree-vectorize -funroll-loops -funswitch-loops"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=corei7-avx -fomit-frame-pointer -fpredictive-commoning -ftree-vectorize -funroll-loops -funswitch-loops"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS=" rsync://"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="10bit 3dnow 3dnowext X aac aacplus acl acpi alsa amd64 apng avc avx bash-completion berkdb bzip2 c++0x cli consolekit cpudetection cpuopts cracklib crypt custom-cflags custom-optimization cxx dri egl evdev faac ffmpeg fluidsynth fortran gdbm gif gles2 glib gtk hwdb iconv icu int64 jit jpeg kernel-builtin keymap libnotify libzfs midi minimal minizip mmx mmxext modules mp3 mudflap multicore multilib ncurses nls nptl ogg opencl opengl openmp openrc openvg opus pam pcre png policykit postscript pulseaudio python readline regex rootfs run-as-root sdl sdl-image secure-delete session smpeg sqlite sqlite3 sse sse2 sse3 sse4 sse4_1 ssl ssse3 static svg system-sqlite systemd tcpd theora threads tiff twolame unicode vorbis vp8 vp9 vpx wayland webp x264 zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="synaptics keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Last edited by izarf on Tue Aug 20, 2013 7:38 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 29 May 2005
Posts: 6078
Location: Saint Amant, Acadiana

PostPosted: Tue Aug 20, 2013 7:12 pm    Post subject: Reply with quote

Will it build with
CFLAGS="-O2 -pipe -march=corei7-avx"

If not, please put the whole build log into pastebin.
Please learn how to denote units correctly!

Political Correctness is all about replacing imaginary injustice with real injustice.
Back to top
View user's profile Send private message

Joined: 20 Aug 2013
Posts: 2

PostPosted: Tue Aug 20, 2013 7:37 pm    Post subject: Reply with quote

Well what do you say? =) Case Solved!
Looping dependencies still remain though. But that's another story.
:D Thank you :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum