Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Deadlock emerging virt-manager-0.10.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
tomtomp
Tux's lil' helper
Tux's lil' helper


Joined: 10 Oct 2011
Posts: 89

PostPosted: Tue Aug 20, 2013 8:37 am    Post subject: Deadlock emerging virt-manager-0.10.0 Reply with quote

Hi, I wanted to try virtualization, so I emerged qemu and all the other things. I found tutorial on ubuntu forums with usage of virt-manager and wanted to try it but first I had problems with libvirt-glib because of my march (core-avx2) and now emerge doesn't eve get to compilin. The message looks like this:
Quote:

emerge: there are no ebuilds built with USE flags to satisfy ">=net-libs/gtk-vnc-0.3.8[gtk3,introspection,python,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_single_target_python2_6(+)?,python_single_target_python2_7(+)?]".
!!! One of the following packages is required to complete your request:
- app-emulation/virt-manager-0.10.0::gentoo (Change USE: -python_targets_python2_7, this change violates use flag constraints defined by app-emulation/virt-manager-0.10.0: 'python_single_target_python2_6? ( python_targets_python2_6 ) python_single_target_python2_7? ( python_targets_python2_7 ) exactly-one-of ( python_single_target_python2_6 python_single_target_python2_7 )')
(dependency required by "app-emulation/virt-manager-0.10.0" [ebuild])
(dependency required by "virt-manager" [argument])

I don't know what to do anymore, any help is appreciated.
If more info is neede I will provide it.
Thank you for help!
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3600
Location: USA

PostPosted: Tue Aug 20, 2013 11:50 am    Post subject: Reply with quote

It appears it wants specific use flags or PYTHON_TARGETS on vnc, but you have it forcibly turned off via make.conf or package.use.

What do you have as your PYTHON_TARGETS? My guess is that you are asking it to target both 2.6 and 2.7, but virt-manager wants one or the other but not both.

emerge --info output may be interesting...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum