Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Quik Fix] no background re-paint in eg Nexuiz & Warzone
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
CleanTestr
n00b
n00b


Joined: 15 Jan 2013
Posts: 47
Location: somewhere in Rural Nebraska, USA

PostPosted: Tue Aug 20, 2013 1:18 am    Post subject: [Quik Fix] no background re-paint in eg Nexuiz & Warzone Reply with quote

What doesn't work is that the 'background image' (in both GLX and SDL nexuiz)
doesn't render: it remains 'black' (#000000). Menus, overlaid graphics, neon
effects, the Warzone 'radar' all work (in fact, if you don't mind playing nexuiz
in a dark-ed out basement, you might enjoy it; and if you don't care what you're
shooting at, Warzone is 'playable').

'Decals' : 'lights' objects in Nexuiz render as this funky red/white/green stripes
pattern, which gets more 'mashed-up', the longer the machine has been on for --
don't know if this is a related problem or not.


This occurs on multilib-desktop running with
glibc ~amd64
xorg-server ~amd64
xorg-drivers ~amd64
xf86-video-intel ~amd64

and on hardened no-multilib running with
glibc ~amd64
xorg-server ~amd64
xorg-drivers ~amd64
xf86-video-intel-2.20.13

Some games 'work', and others 'don't work'.

Games that work:
sauerbraten-2013.01.04
simutrans
supertuxkart
rott -demo
heroes
xgalaga
dosBox + NETHACK.EXE 3.22
'non-Game' mplayer2:dvd

Games that don't work:
nexuiz-252
warzone2100-3.1.0

Help troubleshooting this would be appreciated :)
_________________
Stan: A signal? Why didn't you wake me?
790: It was a distress signal. They only lead to trouble, so I always ignore them. --Lexx


Last edited by CleanTestr on Wed Aug 21, 2013 6:35 am; edited 4 times in total
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4564
Location: Saint Amant, Acadiana

PostPosted: Tue Aug 20, 2013 1:33 am    Post subject: Re: Xorg @!*&#@~~ - no video Reply with quote

CleanTestr wrote:
No, it's not That Bad. And Yes, I'll change the Topic...

This occurs on multilib-desktop running with
glibc ~amd64
xorg-server ~amd64
xorg-drivers ~amd64
xf86-video ~amd64

( it seemed to me that this was working, back in June, or so... )

Some games 'work', and others 'don't work'.

Games that work:
sauerbraten-2013.01.04
simutrans
supertuxkart
rott -demo
heroes
xgalaga
dosBox + NETHACK.EXE 3.22
'non-Game' mplayer2:dvd

Games that don't work:
nexuiz-252
warzone2100-3.1.0

What doesn't work is that the 'background image' (in both GLX and SDL nexuiz)
doesn't render: it remains 'black' (#000000). Menus, overlaid graphics, neon
effects, the Warzone 'radar' all work (in fact, if you don't mind playing nexuiz
in a dark-ed out basement, you might enjoy it; and if you don't care what you're
shooting at, Warzone is 'playable').

Help troubleshooting this would be appreciated :)

..

My crystal ball broke down when I tried to help some dude who claimed "Gentoo is not working, help!". My neighbor is not home so I cannot borrow his. You can wait until someone who still has a working crystal ball chimes in (unlikely, those balls break so easily when asked dumb questions, happens all the time here), or you can help us to help you (this is a strong suggestion) by providing useful information about your system, error messages, logs, etc.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
CleanTestr
n00b
n00b


Joined: 15 Jan 2013
Posts: 47
Location: somewhere in Rural Nebraska, USA

PostPosted: Tue Aug 20, 2013 1:41 am    Post subject: Reply with quote

There are no build-time errors.

multi-lib:

emerge --info
Xorg.0.log
nexuiz-output

: note that this contains the line:
Trying to load library... "libpng12.so.0" "libpng.so" - loaded.
Missing function "png_set_gray_1_2_4_to_8" - broken library!

I tried 'reverting' to libpng12, but no change in either failing program.

no-multilib:

emerge --info
Xorg.0.log
_________________
Stan: A signal? Why didn't you wake me?
790: It was a distress signal. They only lead to trouble, so I always ignore them. --Lexx
Back to top
View user's profile Send private message
CleanTestr
n00b
n00b


Joined: 15 Jan 2013
Posts: 47
Location: somewhere in Rural Nebraska, USA

PostPosted: Wed Aug 21, 2013 5:22 am    Post subject: Reply with quote

Ok, after some digging I came up with the following Quik Fix
(not a Solution):

for warzone2100 use commandline switch --notexturecompression

and

for nexuiz, in Settings:Video, set Compress Textures to None

with those in place, everything seems fully functional.
_________________
Stan: A signal? Why didn't you wake me?
790: It was a distress signal. They only lead to trouble, so I always ignore them. --Lexx
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum