Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libreoffice 4 not starting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
DZoom
n00b
n00b


Joined: 13 Jun 2010
Posts: 45

PostPosted: Mon Aug 19, 2013 9:11 am    Post subject: libreoffice 4 not starting Reply with quote

Hello there,

everytime i try to start libreoffice i just get the following warning message, entitled "LibreOffice 4.0 Fatal Error":
Quote:

The application cannot be started.
exception occurred raising singleton "/singletons/com.sun.star.deployment.ExtensionManager": loading component library failed: file:///usr/lib64/libreoffice/program/../program/libdeployment.so

Only thing you can do is clicking OK, but libreoffice won't start.
At the moment i got this problem on two of my amd64 gentoo installations.
The mentioned file exists:
Code:
$ locate libdeployment.so
/usr/lib64/libreoffice/program/libdeployment.so
$ ls -l /usr/lib64/libreoffice/program/libdeployment.so
-rwxr-xr-x 1 root root 1022032 Jul 14 02:58 /usr/lib64/libreoffice/program/libdeployment.so

i got these errors after doing a clean installation and using libreoffice-bin on one system; on the other system that error occured after doing a world update (which worked fine).
i didn't find anything useful on this issues via google -- but i can't be the only one having this issue, can i?
i also tried deleting the .config/libreoffice folder, but no effect.

Code:
$ eix -I libreoffice
[I] app-office/libreoffice-bin
     Available versions:  4.0.4.2^st {{aqua debug elibc_FreeBSD gnome java kde python_single_target_python2_7 python_single_target_python3_3 python_targets_python2_7 python_targets_python3_3}}
     Installed versions:  4.0.4.2^st(11:27:51 AM 07/29/2013)(java python_single_target_python2_7 python_targets_python2_7 -aqua -debug -elibc_FreeBSD -gnome -kde -python_single_target_python3_3 -python_targets_python3_3)
     Homepage:            http://www.libreoffice.org
     Description:         LibreOffice, a full office productivity suite. Binary package.


the JRE installed on my systems came along with the installed JDK.
Code:
$ eix -I jdk
[I] dev-java/oracle-jdk-bin
     Available versions:  (1.7) 1.7.0.25^fs
        {{+X alsa derby doc examples +fontconfig jce nsplugin pax_kernel source}}
     Installed versions:  1.7.0.25(1.7)^fs(10:25:29 AM 08/19/2013)(X alsa doc fontconfig source -derby -examples -jce -nsplugin -pax_kernel)
     Homepage:            http://www.oracle.com/technetwork/java/javase/
     Description:         Oracle's Java SE Development Kit

[I] virtual/jdk
     Available versions: 
        (1.5)   1.5.0-r1
        (1.6)   1.6.0-r2
        (1.7)   (~)1.7.0
     Installed versions:  1.7.0(1.7)(12:43:22 PM 06/28/2013)
     Description:         Virtual for Java Development Kit (JDK)


Which further configs are useful?
Any help is appreciated
Back to top
View user's profile Send private message
Vorlon
Apprentice
Apprentice


Joined: 16 May 2003
Posts: 196
Location: West Grove, PA

PostPosted: Mon Sep 02, 2013 10:28 pm    Post subject: Reply with quote

Naturally, you should sync and do a "emerge --deep --newuse -u world" to make sure all the sub-systems are up to date. Even with a clean install, something may have been out of sync.

You could also try a revdep-rebuild to rebuild any non-conforming libraries.

I haven't seen your exact error, but every time I have an error like this it is because one of the libraries is out of sync with the application. Rebuilding both the libraries and the application will often fix it. If you are really desperate, you can try an emerge -e world to rebuild the entire system.


Good luck!
_________________
Casey Bralla
Chief Nerd in Residence
The NerdWorld Organisation
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum