Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] equery problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1512

PostPosted: Mon Mar 24, 2014 6:38 am    Post subject: [SOLVED] equery problem Reply with quote

I upgraded dev-lang/ruby to ruby version 2.0.0.p353. I have installed also ruby 1.8.7_p3701.8.7_p370

I then ran
Code:
 equery d ruby
Traceback (most recent call last):
  File "/usr/lib/python-exec/python3.2/equery", line 35, in <module>
    from gentoolkit import equery, errors
  File "/usr/lib64/python3.2/site-packages/gentoolkit/equery/__init__.py", line 30, in <module>
    import portage
ImportError: No module named portage


to check if I need also ruby 1.8.7 and got the above error. Any one have idea how to solve the above error?

Also, I am not sure to which profile I have to switch ruby? Currently I switched to ruby20.

PS. I managed to solve the problem. It was a issue with python-updater.

I did the following things:
Code:
 
eselect python set 1
emerge dev-lang/python portage (python 3.3)
eselect python set 3
equery d ruby


More details can be found here:
[url] https://forums.gentoo.org/viewtopic-p-7481998.html [/url]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum