Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
changes in portage 2.2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
jpsollie
n00b
n00b


Joined: 17 Aug 2013
Posts: 1

PostPosted: Sat Aug 17, 2013 3:52 pm    Post subject: changes in portage 2.2 Reply with quote

Hi people,

I upgraded this weekend one of my pcs to portage 2.2, and I'd like to know what changed to the search algorithm:
the AI went, let's say, from IQ 105 to 55: searches take more than twice as long, and results are often wrong (slotted installs ignore masked versions) and clearly improperly searched

example:

Quote:

vliegtuig tmp # emerge --verbose --backtrack=30 @preserved-rebuild

* IMPORTANT: 22 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] kde-base/kde-env-4.11.0:4 [4.9.0:4] USE="(-aqua)" 0 kB
[ebuild U ] media-gfx/sane-backends-1.0.23-r1 [1.0.21] USE="ipv6 threads%* -avahi -doc -gphoto2 -snmp% -usb* -v4l -xinetd%" SANE_BACKENDS="{test} -abaton -agfafocus -apple -artec -artec_eplus48u -as6e -avision -bh -canon -canon630u -canon_dr -canon_pp -cardscan -coolscan -coolscan2 -coolscan3 -dc2
Quote:
10 -dc240 -dc25 -dell1600n_net -dmc -epjitsu -epson -epson2 -fujitsu -genesys -gt68xx -hp -hp3500 -hp3900 -hp4200 -hp5400 -hp5590 -hpljm1005 -hpsj5s -hs2
p -ibm -kodak -kodakaio% -kvs1025 -kvs20xx% -kvs40xx% -leo -lexmark -ma1509 -magicolor% -matsushita -microtek -microtek2 -mustek -mustek_pp -mustek_usb -mustek_usb2% -nec -net -niash -p5 -pie -pixma -plustek -plustek_pp -pnm% -qcam -ricoh -rts8891 -s9036 -sceptre -sharp -sm3600 -sm3840 -snapscan -sp15c -st400 -stv680 -tamarack -teco1 -teco2 -teco3 -u12 -umax -umax1220u -umax_pp -xerox_mfp" 5,218 kB
[ebuild R ] media-libs/libmng-1.0.10-r1 USE="lcms -static-libs" 0 kB
[ebuild R ] sys-fs/udev-206-r3 USE="acl firmware-loader gudev* kmod openrc -doc -introspection (-selinux) -static-libs" ABI_X86="(64) -32 (-x32)" 0 kB
[ebuild R ] virtual/udev-206-r2 USE="gudev* kmod -introspection (-selinux) -static-libs" ABI_X86="(64) -32 (-x32)" 0 kB
[ebuild NS ] dev-lang/spidermonkey-17.0.0-r1:17 [1.8.5-r1:0] USE="-debug -jit -minimal -static-libs {-test}" 6,621 kB
[ebuild U ] dev-python/pygobject-2.28.6-r53:2 [2.28.6-r52:2] USE="-examples -libffi {-test} (-doc%) (-introspection%*)" PYTHON_TARGETS="python2_7%* -python2_6%" 0 kB
[ebuild U ] dev-python/dbus-python-1.2.0 [1.0.0] USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7%* python3_2%* -python2_6% -python3_3%" 0 kB
[ebuild U ] dev-python/sip-4.14.7:0/10 [4.13.3:0/0] USE="-debug -doc" PYTHON_TARGETS="python2_7%* python3_2%* (-python2_5) -python2_6% (-python3_1) -python3_3%" 738 kB
[ebuild U ] media-libs/jasper-1.900.1-r6 [1.900.1-r5] USE="jpeg opengl -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild R ] dev-qt/qtgui-4.8.5:4 USE="accessibility exceptions glib qt3support tiff xv (-aqua) -c++0x -cups -debug -egl -gtkstyle -mng -nas -nis -pch -trace -xinerama" 0 kB
[ebuild U ] kde-base/oxygen-icons-4.11.0:4 [4.9.0:4] USE="(-aqua) -bindist" 28,638 kB
[ebuild U ] dev-libs/soprano-2.9.3 [2.8.0] USE="dbus raptor redland virtuoso -debug -doc {-test} (-clucene%)" 1,913 kB
[ebuild U ] dev-libs/shared-desktop-ontologies-0.11.0 [0.9.0] 3,875 kB
[ebuild U ] dev-libs/libattica-0.4.2 [0.4.0] USE="qt4%* -debug (-qt5) {-test%}" 56 kB
[ebuild U ] dev-python/PyQt4-4.10.2 [4.9.4] USE="X dbus declarative kde opengl sql svg webkit -debug -doc -examples -help% -multimedia -phonon -script% -scripttools% -xmlpatterns (-assistant%)" PYTHON_TARGETS="python2_7%* python3_2%* (-python2_5) -python2_6% (-python3_1) -python3_3%" 11,017 kB
[ebuild U ] net-print/hplip-3.13.7 [3.12.6-r1] USE="X hpcups kde qt4 -doc -fax -hpijs -libnotify* -libusb0% -minimal -parport -policykit* -scanner -snmp -static-ppds (-acl%*)" PYTHON_SINGLE_TARGET="python2_7%* -python2_6%" PYTHON_TARGETS="python2_7%* -python2_6%" 20,331 kB
[ebuild R ] mail-client/thunderbird-17.0.8 USE="alsa crypt dbus ipc jit lightning minimal -bindist -custom-cflags -custom-optimization -debug -gconf -ldap -libnotify -mozdom (-selinux) -startup-notification -system-sqlite -wifi" LINGUAS="en_GB fr nl -ar -ast -be -bg -bn_BD -br -ca -cs -da -de -el -es_AR -es_ES -et -eu -fi -fy_NL -ga_IE -gd -gl -he -hr -hu -hy_AM -id -is -it -ja -ko -lt -nb_NO -nn_NO -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -sq -sr -sv_SE -ta_LK -tr -uk -vi -zh_CN -zh_TW" 0 kB
[ebuild U ] sys-auth/polkit-0.111-r1 [0.107] USE="introspection kde nls pam -examples -gtk (-selinux) -systemd" 0 kB
[ebuild N ] sys-power/upower-0.9.21 USE="introspection -doc -ios -systemd" 412 kB
[ebuild N ] sys-fs/udisks-2.1.0:2 USE="gptfdisk introspection -cryptsetup -debug (-selinux) -systemd" 805 kB
[ebuild U ] kde-base/kdelibs-4.11.0:4 [4.8.5:4] USE="3dnow acl alsa bzip2 fam handbook jpeg2k mmx nls opengl policykit spell sse sse2 ssl udev udisks upower (-altivec) (-aqua) -debug -doc -kerberos -lzma -openexr {-test} -zeroconf (-semantic-desktop%*) (-upnp%)" 11,526 kB
[ebuild N ] kde-base/nepomuk-core-4.11.0:4 USE="(-aqua) -debug -epub -exif -ffmpeg -pdf -taglib" 376 kB
[ebuild N ] kde-base/nepomuk-widgets-4.11.0:4 USE="(-aqua) -debug" 48 kB
[ebuild U ] kde-base/katepart-4.11.0:4 [4.8.5:4] USE="handbook (-aqua) -debug" 2,519 kB
[ebuild U ] kde-base/kdesu-4.11.0:4 [4.8.5:4] USE="handbook (-aqua) -debug" 7,687 kB
[ebuild U ] kde-base/khelpcenter-4.11.0:4 [4.8.5:4] USE="(-aqua) -debug" 0 kB
[ebuild U ] kde-base/kactivities-4.11.0:4 [4.8.5:4] USE="(-aqua) (-semantic-desktop%*)" 85 kB
[ebuild U ] kde-base/libkonq-4.11.0:4 [4.8.5:4] USE="(-aqua) -debug {-test}" 2,459 kB
[ebuild U ] kde-base/kdialog-4.11.0:4 [4.8.5:4] USE="(-aqua) -debug" 0 kB
[ebuild U ] kde-base/rocs-4.11.0:4 [4.8.5:4] USE="handbook (-aqua) -debug" 1,118 kB
[ebuild U ] kde-base/okular-4.11.0:4 [4.8.5-r2:4] USE="crypt handbook jpeg pdf postscript tiff (-aqua) -chm -debug -djvu -ebook" 1,495 kB
[ebuild U ] kde-base/ksplash-4.11.0:4 [4.8.5-r1:4] USE="3dnow mmx sse sse2 (-altivec) (-aqua) -debug -xinerama" 13,387 kB
[ebuild U ] kde-base/krfb-4.11.0:4 [4.8.5:4] USE="handbook (-aqua) -debug -telepathy%" 458 kB
[ebuild U ] kde-base/kdebase-kioslaves-4.11.0:4 [4.8.5:4] USE="bzip2 handbook samba sftp (-aqua) -debug -exif* -lzma -openexr" 0 kB
[ebuild U ] kde-base/gwenview-4.11.0:4 [4.8.5:4] USE="handbook (-aqua) -debug -kipi (-semantic-desktop%*)" 2,830 kB

Total: 36 packages (26 upgrades, 4 new, 1 in new slot, 5 reinstalls), Size of downloads: 123,601 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

virtual/udev:0

(virtual/udev-206-r2::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(virtual/udev-206-r2::gentoo, ebuild scheduled for merge) pulled in by
>=virtual/udev-200[gudev] required by (sys-power/upower-0.9.21::gentoo, ebuild scheduled for merge)
>=virtual/udev-197[gudev,hwdb(+)] required by (sys-fs/udisks-2.1.0::gentoo, ebuild scheduled for merge)

sys-fs/udev:0

(sys-fs/udev-206-r3::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(sys-fs/udev-206-r3::gentoo, ebuild scheduled for merge) pulled in by
>=sys-fs/udev-206-r2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_x86_32(-)?,abi_x86_64(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev?,introspection?,kmod?,selinux?,static-libs?] required by (virtual/udev-206-r2::gentoo, ebuild scheduled for merge)

kde-base/kdelibs:4

(kde-base/kdelibs-4.11.0::gentoo, ebuild scheduled for merge) pulled in by
>=kde-base/kdelibs-4.11.0:4[aqua=,handbook] required by (kde-base/krfb-4.11.0::gentoo, ebuild scheduled for merge)
(and 22 more with the same problem)

(kde-base/kdelibs-4.8.5::gentoo, installed) pulled in by
>=kde-base/kdelibs-4.8.5:4[-aqua,opengl,semantic-desktop] required by (kde-base/pykde4-4.8.5::gentoo, installed)
>=kde-base/kdelibs-4.8.5:4[-aqua,semantic-desktop] required by (kde-base/dolphin-4.8.5::gentoo, installed)
>=kde-base/kdelibs-4.8.5:4[-aqua,semantic-desktop] required by (kde-base/kdeplasma-addons-4.8.5::gentoo, installed)
>=kde-base/kdelibs-4.8.5:4[-aqua,semantic-desktop] required by (kde-base/kdepimlibs-4.8.5::gentoo, installed)
>=kde-base/kdelibs-4.8.5:4[-aqua,semantic-desktop] required by (kde-base/plasma-workspace-4.8.5::gentoo, installed)
>=kde-base/kdelibs-4.8.5:4[-aqua,semantic-desktop] required by (kde-base/kget-4.8.5::gentoo, installed)

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.



this search took almost 30 mins on my phenom II X4 940 CPU :(
The requested gudev is already added to package.use, for virtual and sys-fs udev, but even after 30 mins, it doesn't seem capable to uninstall the old KDE packages

what happened?? portage 2.1 used to solve this in a minute!
_________________
I am using gentoo for over 10 years now. yet seen its possibilities, I still feel like a n00b...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum