Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(SOLVED)-No PDF Thumbnails in Dolphin
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1109
Location: 127.0.0.1

PostPosted: Sat Aug 17, 2013 9:45 am    Post subject: (SOLVED)-No PDF Thumbnails in Dolphin Reply with quote

Has anyone else been having the issue of some thumbnails of PDF files showing up dolphin, while others just show a blank white box?

Also has anyone who is using okular noticing that it has been extremely slow to load thumbnails of pages, and in rendering the main page

This is on a core i7 machine so i doubt that the CPU is an issue

All PDF's show thumbs under Windows, and under XFCE, so am a bit stuck as to why KDE and Okular are being problematic

Decided to try KDE 4.11 after I heard it had a lot of improvements, and it does indeed seem more responsive in this latest version

Edit: Dont know what changed but a world update seems to have sorted it
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.


Last edited by FizzyWidget on Mon Sep 09, 2013 7:32 am; edited 3 times in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3839
Location: Irgendwo im Nirgendwo

PostPosted: Sat Aug 17, 2013 1:04 pm    Post subject: Reply with quote

Poppler is not really fast. I also had okular running on an i7 2600K, and some pdf pages used >1 second to render. Same with qpdfview (which you might want to try, jst to make sure it is not a performance issue in okular, which I don't think).
I am using mupdf, which feels about 1000x faster than any poppler-based viewer.

Concerning the "white rectangles" as thumb:
If the first page is white IMHO the thumb will be white, too. Probably windows has some heuristics to chose the first non-contentless page as preview.
I also saw some pdf where it looked like it showed a white page. There just was little text in quite small letters, which got rendered in light grey (antialiasing?).
As it is possible to embed a thumb into the pdf: How big do you scale your previews under windows and linux? the embedded thumb is quite small...
Last but not least: This also might be an error in pdf thumb generator or poppler itself (returning an empty image in some cases).
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1109
Location: 127.0.0.1

PostPosted: Sat Aug 17, 2013 1:10 pm    Post subject: Reply with quote

I think it is an issue with the thumb preview as it is fine under XFCE all show the cover as it should, I use mupdf on XFCE and agree its fast, will try the other program you mentioned.

Some open like you say almost instant, others take minutes for the previews to show
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3839
Location: Irgendwo im Nirgendwo

PostPosted: Sat Aug 17, 2013 5:34 pm    Post subject: Reply with quote

The "slow" pdfs in my experience are ones with many/big images. Catalogs, e.g.
And can you confirm that those PDFs that take ages to load also are the ones that show white squares in dolphin? Do the previews appear after a while? If not, probably the kde thumbnailer kills a process that takes too long, resulting in an empty preview.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1109
Location: 127.0.0.1

PostPosted: Sun Aug 18, 2013 6:15 am    Post subject: Reply with quote

It is looking to be a Dolphin issue as I have removed and re-embedded page thumbnails and okular is okay now, but no thumbnails show up in Dolphin, but they do in XFCE and windows
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3839
Location: Irgendwo im Nirgendwo

PostPosted: Sun Aug 18, 2013 6:31 am    Post subject: Reply with quote

okular creates previews on the fly while dolphin caches them. You could try "F5" in dolphin, probably that will regenerate them. If it doesn't you can delete/move ~/.thumbnails. Probably close dolphin before doing so...
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1109
Location: 127.0.0.1

PostPosted: Sun Aug 18, 2013 7:52 am    Post subject: Reply with quote

I have done that, many many times :cry: , what I find strange is that it will make a thumbnail for one or two PDF's but leave the rest as white - yet they have all been made and checked the same way - qpdfview, okular and mupdf all open them, and show thumbs okay (apart from mupdf obviously), also qpdfview and okular are no longer slow to open or view the PDF's.

So I am at a loss, if they are all made the same way, why should it pick one or two up and show thumbs in dolphin but not the rest :/

I am still googling to find any answer I can
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
Helmering
n00b
n00b


Joined: 13 Dec 2011
Posts: 36
Location: Italy

PostPosted: Sun Aug 18, 2013 12:36 pm    Post subject: Reply with quote

Hi,

Menu dolphin => Settings => Configure => General => Preview:

List properly tagged and max file size to 0MB?

Cheers Ralf
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1109
Location: 127.0.0.1

PostPosted: Sun Aug 18, 2013 6:04 pm    Post subject: Reply with quote

It's a KDE issue as the thumbs show under Gnome, XFCE and Windows, so I know the PDF's are okay - Just have no clue how to sort it
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum