Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge suddenly developed a libpng-1.6.3 fetish?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
virduun
n00b
n00b


Joined: 02 Jun 2011
Posts: 26

PostPosted: Mon Aug 26, 2013 9:48 pm    Post subject: Emerge suddenly developed a libpng-1.6.3 fetish? Reply with quote

The other day I tried to do a world update and emerge seems to demand that I unmask libpng 1.6.3-r1 (as well as 1.5.17) for no apparent reason. All of the packages which would be reinstalled due to the new libpng version are not updates, and I know they install just fine with 1.5.13-r1, because I did just that a couple weeks ago when I downgraded to it from 1.6.3-r1 and it automatically rebuilt all of them without incident.

Now, the reason I'm using 1.5.13-r1..

A while ago I noticed Wine was having trouble with applications that would run just fine previously. The apparent issue (and I don't know why it would be anything else, since reverting libpng fixed it) was that Wine was being compiled with libpng 1.6.3, but when running 32-bit applications it would use the version of libpng which is included in the emul-linux-x86-* package set, which is only 1.5.13. When attempting to run such an application, Wine would notice this version discrepancy and promptly shit itself.

As for why emul-linux-x86-* is still using an old libpng version, I couldn't begin to guess. The issue I was having with Wine had persisted for quite a while, so it evidently isn't a matter of 1.6.3 being super-recent, and while I could theoretically just wait for emul-linux-x86-* to get updated, I have a feeling that libpng 1.7 would be out by then, and I would just have the same problem, just with bigger numbers.

So I guess what I'm asking is, is there a way to get emerge to accept that I really don't want libpng 1.6.3?
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3601
Location: USA

PostPosted: Mon Aug 26, 2013 10:18 pm    Post subject: Reply with quote

Please post the emerge output. It should tell what's blocking.

Likely you have a single package that requires a specific version of libpng. If you could disable that package or prevent that package from upgrading, then you could get rid of this block.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
virduun
n00b
n00b


Joined: 02 Jun 2011
Posts: 26

PostPosted: Mon Aug 26, 2013 11:25 pm    Post subject: Reply with quote

Ok, it doesn't seem to want libpng 1.6.3 anymore after I masked app-text/ghostscript-gpl-9.09 and net-print/cups-filters-1.0.36-r2 (not sure why I have cups-anything, but whatever). For some reason I just wasn't mentally parsing the lines that mentioned the packages that were being picky. I haven't actually done the update yet, but the emerge -p no longer gives those errors. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum