Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]Portage: blocked packeges udev, systemd, virtualgdev
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
GenProm
Tux's lil' helper
Tux's lil' helper


Joined: 18 Aug 2011
Posts: 93
Location: Germany

PostPosted: Wed Jun 04, 2014 9:18 am    Post subject: [solved]Portage: blocked packeges udev, systemd, virtualgdev Reply with quote

Hi

I just wanted to do a normal update like i always do but i get this time:

Code:

kobold manuel # emerge -auDNv  world                     

These are the packages that would be merged, in order:

Calculating dependencies ... done!                                   
[ebuild  N     ] sys-libs/libseccomp-2.1.1  USE="static-libs" 111 kB
[ebuild  r  U  ] app-text/qpdf-5.1.1:0/13 [4.1.0:0/10] USE="static-libs -doc -examples {-test}" 7,484 kB
[ebuild  N     ] virtual/libgudev-208  USE="introspection static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] virtual/libudev-208:0/1  USE="static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild     U  ] virtual/udev-208-r2 [208-r1] USE="gudev introspection static-libs (-kmod%*) (-selinux%)" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild   R    ] dev-libs/glib-2.38.2-r1:2  USE="(mime%*) static-libs -debug (-fam) (-selinux) -systemtap {-test} -utils -xattr" ABI_X86="(64) (-32) (-x32)" PYTHON_TARGETS="python2_7 (-python2_6)" 0 kB
[ebuild  rR    ] net-print/cups-filters-1.0.53  USE="dbus foomatic jpeg png static-libs tiff zeroconf -perl" 0 kB
[ebuild  N     ] sys-apps/systemd-212-r5:0/2  USE="acl filecaps firmware-loader gudev introspection kmod lzma pam (policykit) python seccomp -audit -cryptsetup -doc -gcrypt -http (-kdbus) -qrcode (-selinux) (-ssl) {-test} -vanilla -xattr" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2" 0 kB
[ebuild  N     ] sys-apps/gentoo-systemd-integration-4  52 kB
[ebuild     U  ] sys-power/upower-0.9.23-r3 [0.9.23-r2] USE="introspection -doc -ios (-systemd%)" 0 kB
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-212-r5, sys-apps/gentoo-systemd-integration-4)
[blocks B      ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/udev-212-r1)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-212-r1)

Total: 10 packages (3 upgrades, 5 new, 2 reinstalls), Size of downloads: 7,645 kB
Conflict: 3 blocks (3 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-212-r1::gentoo, installed) pulled in by
    >=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev,introspection?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_64(-),gudev,introspection,static-libs]) required by (virtual/libgudev-208::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-208:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,static-libs?] (>=sys-fs/udev-208:0/0[abi_x86_64(-),static-libs]) required by (virtual/libudev-208::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-208 required by (virtual/udev-208-r2::gentoo, ebuild scheduled for merge)
    sys-fs/udev required by @selected

  (sys-apps/systemd-212-r5::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/systemd-200 required by (sys-power/upower-0.9.23-r3::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following packages are causing rebuilds:

  (app-text/qpdf-5.1.1::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (net-print/cups-filters-1.0.53::gentoo, ebuild scheduled for merge)



As in another Thread suggested i tried:

Code:

kobold manuel # emerge -vp systemd libudev libgudev

These are the packages that would be merged, in order:

Calculating dependencies                            ... done!   
[ebuild  N     ] sys-libs/libseccomp-2.1.1  USE="static-libs" 111 kB
[ebuild  N     ] virtual/libudev-208:0/1  USE="static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] virtual/libgudev-208  USE="introspection static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] sys-apps/systemd-212-r5:0/2  USE="acl filecaps firmware-loader gudev introspection kmod lzma pam (policykit) python seccomp -audit -cryptsetup -doc -gcrypt -http (-kdbus) -qrcode (-selinux) (-ssl) {-test} -vanilla -xattr" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2" 0 kB
[ebuild  N     ] sys-apps/gentoo-systemd-integration-4  52 kB
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-212-r5, sys-apps/gentoo-systemd-integration-4)
[blocks B      ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/udev-212-r1)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-212-r1)

Total: 5 packages (5 new), Size of downloads: 162 kB
Conflict: 3 blocks (3 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-212-r1::gentoo, installed) pulled in by
    >=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev,introspection?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_64(-),gudev,introspection,static-libs]) required by (virtual/libgudev-208::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-208:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,static-libs?] (>=sys-fs/udev-208:0/0[abi_x86_64(-),static-libs]) required by (virtual/libudev-208::gentoo, ebuild scheduled for merge)

  (sys-apps/systemd-212-r5::gentoo, ebuild scheduled for merge) pulled in by
    systemd
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked



Also I tried:

Code:

kobold manuel # emerge -vp gentoo-systemd-integration

These are the packages that would be merged, in order:

Calculating dependencies                 ... done!
[ebuild  N     ] sys-libs/libseccomp-2.1.1  USE="static-libs" 111 kB
[ebuild  N     ] sys-apps/systemd-212-r5:0/2  USE="acl filecaps firmware-loader gudev introspection kmod lzma pam (policykit) python seccomp -audit -cryptsetup -doc -gcrypt -http (-kdbus) -qrcode (-selinux) (-ssl) {-test} -vanilla -xattr" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2" 0 kB
[ebuild  N     ] sys-apps/gentoo-systemd-integration-4  52 kB
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-212-r5, sys-apps/gentoo-systemd-integration-4)
[blocks B      ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/udev-212-r1)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-212-r1)

Total: 3 packages (3 new), Size of downloads: 162 kB
Conflict: 3 blocks (3 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-212-r1::gentoo, installed) pulled in by
    sys-fs/udev required by @selected

  (sys-apps/gentoo-systemd-integration-4::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/gentoo-systemd-integration required by (sys-apps/systemd-212-r5::gentoo, ebuild scheduled for merge)
    gentoo-systemd-integration


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked



As far as i understand it, it is an internal conflict that systemd blocks the new udev and the udev blocks the udev-integration.

So how to solve this ?

Here are some infos:

Emerge --info

Code:

kobold manuel # emerge --info
Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.17, 3.12.20-gentoo x86_64)
=================================================================
System uname: Linux-3.12.20-gentoo-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.2
KiB Mem:     8172844 total,   5698344 free
KiB Swap:    7167996 total,   7167996 free
Timestamp of tree: Wed, 04 Jun 2014 08:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6, 3.3.3
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.3, 4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories:

gentoo
    location: /var/portage_sync
    sync-type: rsync
    sync-uri: rsync://rsync.europe.gentoo.org/gentoo-portage
    priority: -1000

bangert
    location: /var/lib/layman/bangert
    masters: gentoo
    priority: 0

gamerlay
    location: /var/lib/layman/gamerlay
    masters: gentoo
    priority: 1

java
    location: /var/lib/layman/java
    masters: gentoo
    priority: 2

anders-larsson
    location: /var/lib/layman/anders-larsson
    masters: gentoo
    priority: 3

my_local_overlay
    location: /usr/local/portage
    masters: gentoo
    priority: 4

ABI="amd64"
ABI_X86="64"
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
ACCEPT_PROPERTIES="*"
ACCEPT_RESTRICT="*"
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
ANT_HOME="/usr/share/ant"
APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias"
ARCH="amd64"
AUTOCLEAN="yes"
BOOTSTRAP_USE="cxx unicode internal-glib python_targets_python3_3 python_targets_python2_7 multilib"
BZIP="-9"
CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author"
CAMERAS="ptp2"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CFLAGS_amd64="-m64"
CFLAGS_x32="-mx32"
CFLAGS_x86="-m32"
CG_COMPILER_EXE="/opt/bin/cgc"
CG_INC_PATH="/opt/nvidia-cg-toolkit/include"
CG_LIB_PATH="/opt/nvidia-cg-toolkit/lib64:/opt/nvidia-cg-toolkit/lib32"
CHOST="x86_64-pc-linux-gnu"
CHOST_amd64="x86_64-pc-linux-gnu"
CHOST_x32="x86_64-pc-linux-gnux32"
CHOST_x86="i686-pc-linux-gnu"
CLEAN_DELAY="5"
COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog"
COLLISION_IGNORE="/lib/modules/* *.py[co] *$py.class */dropin.cache"
COLORFGBG="15;0"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DBUS_SESSION_BUS_ADDRESS="unix:abstract=/tmp/dbus-7ULNQY8NkW,guid=e42abe0889c140461f909c0f538edda0"
DEFAULT_ABI="amd64"
DESKTOP_SESSION="default"
DISPLAY=":0"
DISTDIR="/var/portage_sync/distfiles"
DM_CONTROL="/var/run/xdmctl"
EDITOR="/bin/nano"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--autounmask=n --ask --verbose"
EMERGE_WARNING_DELAY="10"
EPREFIX=""
EROOT="/"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FETCHCOMMAND="wget -t 3 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}""
FETCHCOMMAND_RSYNC="rsync -avP "${URI}" "${DISTDIR}/${FILE}""
FETCHCOMMAND_SFTP="bash -c "x=\${2#sftp://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; eval \"declare -a ssh_opts=(\${3})\" ; exec sftp -P \${port} \"\${ssh_opts[@]}\" \"\${host}:/\${x#*/}\" \"\$1\"" sftp "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""
FETCHCOMMAND_SSH="bash -c "x=\${2#ssh://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; exec rsync --rsh=\"ssh -p\${port} \${3}\" -avP \"\${host}:/\${x#*/}\" \"\$1\"" rsync "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""
FFLAGS="-O2 -pipe"
FLTK_DOCDIR="/usr/share/doc/fltk-1.3.2/html"
GCC_SPECS=""
GENTOO_MIRRORS="ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ ftp://gd.tuwien.ac.at/opsys/linux/gentoo ftp://de-mirror.org/gentoo"
GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx"
GRUB_PLATFORMS=""
GSETTINGS_BACKEND="gconf"
GS_LIB="/home/manuel//.fonts"
GTK2_RC_FILES="/etc/gtk-2.0/gtkrc:/home/manuel/.gtkrc-2.0:/home/manuel/.kde4/share/config/gtkrc-2.0"
GTK_RC_FILES="/etc/gtk/gtkrc:/home/manuel/.gtkrc:/home/manuel/.kde4/share/config/gtkrc"
GZIP="-9"
HOME="/root"
INFOPATH="/usr/share/info:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.7.3/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.23.2/info"
INPUT_DEVICES="evdev keyboard mouse wacom"
IUSE_IMPLICIT="prefix"
JAVAC="/etc/java-config-2/current-system-vm/bin/javac"
JAVACC_HOME="/usr/share/javacc/"
JAVA_HOME="/etc/java-config-2/current-system-vm"
JDK_HOME="/etc/java-config-2/current-system-vm"
KDE_FULL_SESSION="true"
KDE_MULTIHEAD="false"
KDE_SESSION_UID="1000"
KDE_SESSION_VERSION="4"
KERNEL="linux"
KONSOLE_DBUS_SERVICE=":1.72"
KONSOLE_DBUS_SESSION="/Sessions/1"
KONSOLE_DBUS_WINDOW="/Windows/1"
KONSOLE_PROFILE_NAME="Shell"
LANG="de_DE.UTF-8"
LANGUAGE=""
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LC_ADDRESS="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_CTYPE="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_MESSAGES="C"
LC_MONETARY="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu"
LDFLAGS_amd64="-m elf_x86_64"
LDFLAGS_x32="-m elf32_x86_64"
LDFLAGS_x86="-m elf_i386"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe %s"
LIBDIR_amd64="lib64"
LIBDIR_amd64_fbsd="lib64"
LIBDIR_arm="lib"
LIBDIR_arm64="lib64"
LIBDIR_n32="lib32"
LIBDIR_n64="lib64"
LIBDIR_o32="lib"
LIBDIR_ppc="lib32"
LIBDIR_ppc64="lib64"
LIBDIR_s390="lib32"
LIBDIR_s390x="lib64"
LIBDIR_sparc32="lib32"
LIBDIR_sparc64="lib64"
LIBDIR_x32="libx32"
LIBDIR_x86="lib32"
LIBDIR_x86_fbsd="lib32"
LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer"
LINGUAS="de"
LOGNAME="root"
LS_COLORS="rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:"
MAIL="/var/mail/manuel"
MAKEOPTS="-j5"
MANPATH="/etc/java-config-2/current-system-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.7.3/man:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.23.2/man:/etc/java-config-2/current-system-vm/man/:/usr/share/postgresql/man/:/usr/share/postgresql-9.3/man/"
MULTILIB_ABIS="amd64 x86"
MULTILIB_STRICT_DENY="64-bit.*shared object"
MULTILIB_STRICT_DIRS="/lib32 /lib /usr/lib32 /usr/lib /usr/kde/*/lib32 /usr/kde/*/lib /usr/qt/*/lib32 /usr/qt/*/lib /usr/X11R6/lib32 /usr/X11R6/lib"
MULTILIB_STRICT_EXEMPT="(perl5|gcc|gcc-lib|binutils|eclipse-3|debug|portage|udev|systemd|clang|python-exec)"
MULTIOSDIRS="../lib64:../lib32"
NETBEANS="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml"
OFFICE_IMPLEMENTATION="libreoffice"
OPENCL_PROFILE="nvidia"
OPENGL_PROFILE="nvidia"
PAGER="/usr/bin/less"
PATH="/sbin:/bin:/usr/sbin:/usr/bin"
PHP_TARGETS="php5-5"
PKGDIR="/usr/portage/packages"
PORTAGE_ARCHLIST="ppc sparc64-freebsd ppc-openbsd x86-openbsd ppc64 x86-winnt x86-fbsd ppc-aix alpha arm x86-freebsd s390 amd64 arm-linux x86-macos x64-openbsd ia64-hpux hppa x86-netbsd ppc64-linux x86-cygwin amd64-linux ia64-linux x86 sparc-solaris x64-freebsd sparc64-solaris x86-linux x64-macos sparc m68k-mint ia64 mips ppc-macos x86-interix hppa-hpux amd64-fbsd x64-solaris m68k sh arm64 x86-solaris sparc-fbsd"
PORTAGE_BIN_PATH="/usr/lib64/portage/bin"
PORTAGE_COMPRESS_EXCLUDE_SUFFIXES="css gif htm[l]? jp[e]?g js pdf png"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="log warn error info qa"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="echo:log,info,warn,error save:warn,error"
PORTAGE_FETCH_CHECKSUM_TRY_MIRRORS="5"
PORTAGE_FETCH_RESUME_MIN_SIZE="350K"
PORTAGE_GID="250"
PORTAGE_GPG_SIGNING_COMMAND="gpg --sign --digest-algo SHA256 --clearsign --yes --default-key "${PORTAGE_GPG_KEY}" --homedir "${PORTAGE_GPG_DIR}" "${FILE}""
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_INTERNAL_CALLER="1"
PORTAGE_OVERRIDE_EPREFIX=""
PORTAGE_PYM_PATH="/usr/lib64/portage/pym"
PORTAGE_PYTHONPATH="/usr/lib64/portage/pym"
PORTAGE_REPOSITORIES="[DEFAULT]
main-repo = gentoo

[anders-larsson]
location = /var/lib/layman/anders-larsson
masters = gentoo
priority = 3

[bangert]
location = /var/lib/layman/bangert
masters = gentoo
priority = 0

[gamerlay]
location = /var/lib/layman/gamerlay
masters = gentoo
priority = 1

[gentoo]
location = /var/portage_sync
masters =
priority = -1000
sync-type = rsync
sync-uri = rsync://rsync.europe.gentoo.org/gentoo-portage

[java]
location = /var/lib/layman/java
masters = gentoo
priority = 2

[my_local_overlay]
location = /usr/local/portage
masters = gentoo
priority = 4
"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_RSYNC_RETRIES="-1"
PORTAGE_SYNC_STALE="30"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_VERBOSE="1"
PORTAGE_WORKDIR_MODE="0700"
PORTAGE_XATTR_EXCLUDE="security.* system.nfs4_acl"
PORTDIR="/var/portage_sync"
PORTDIR_OVERLAY="/var/lib/layman/bangert /var/lib/layman/gamerlay /var/lib/layman/java /var/lib/layman/anders-larsson /usr/local/portage"
PORT_LOGDIR_CLEAN="find "${PORT_LOGDIR}" -type f ! -name "summary.log*" -mtime +7 -delete"
PRELINK_PATH_MASK="/opt;/mnt/data:/usr/lib64/libfreebl3.so:/usr/lib64/libnssdbm3.so:/usr/lib64/libsoftokn3.so:/opt/bin/skype"
PROFILEHOME=""
PROFILE_ONLY_VARIABLES="ARCH ELIBC IUSE_IMPLICIT KERNEL USERLAND USE_EXPAND_IMPLICIT USE_EXPAND_UNPREFIXED USE_EXPAND_VALUES_ARCH USE_EXPAND_VALUES_ELIBC USE_EXPAND_VALUES_KERNEL USE_EXPAND_VALUES_USERLAND"
PWD="/home/manuel"
PYTHONDONTWRITEBYTECODE="1"
PYTHON_SINGLE_TARGET="python2_7"
PYTHON_TARGETS="python2_7 python3_3"
QT_GRAPHICSSYSTEM="raster"
QT_PLUGIN_PATH="/usr/lib64/kde4/plugins:/home/manuel/.kde4/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/"
RESUMECOMMAND="wget -c -t 3 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}""
RESUMECOMMAND_RSYNC="rsync -avP "${URI}" "${DISTDIR}/${FILE}""
RESUMECOMMAND_SSH="bash -c "x=\${2#ssh://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; exec rsync --rsh=\"ssh -p\${port} \${3}\" -avP \"\${host}:/\${x#*/}\" \"\$1\"" rsync "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""
ROOT="/"
ROOTPATH="/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.7.3:/opt/nvidia-cg-toolkit/bin:/opt/vmware/bin"
RPMDIR="/usr/portage/rpm"
RUBYOPT="-rauto_gem"
RUBY_TARGETS="ruby19 ruby20"
R_HOME="/usr/lib64/R"
SESSION_MANAGER="local/kobold:@/tmp/.ICE-unix/2905,unix/kobold:/tmp/.ICE-unix/2905"
SHELL="/bin/bash"
SHELL_SESSION_ID="8673b2e501d84000a21d873147c88505"
SHLVL="3"
SYMLINK_LIB="yes"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
SYSTEMD_LESS="FRSM --shift 5"
TERM="xterm"
UNINSTALL_IGNORE="/lib/modules/*"
USE="3dnow 3dnowext S3TC X a52 aac acl acpi ads alisp alsa amd64 asf autoipd avahi avi bash-completion berkdb binary-drivers bluetooth branding bzip2 cairo cdda cdr cg cli consolekit cpudetection cracklib crypt css cups cxx dbus declarative dhcpcd divx dri dts dvd dvdr dvdread emboss emulation encode evo exif extra-tools fam ffmpeg firefox flac flash fortran g3dvl gcj gdbm gfxnvidia gif gimp gpm gsm gtk gtk2 hddtemp iconv icu ieee1394 introspection ipv6 java jpeg jpeg2k kde kipi lcms ldap libmpeg2 libnotify lm_sensors lzma mad mdnsresponder-compat melt mmx mmxext mng modules mp3 mp4 mpeg mpg123 mplayer multilib ncurses networkmanager nls nptl nsplugin nss nvidia ogg openal opengl openmp oss pam pango pcre pdf phonon plasma png policykit ppds profiler pulseaudio python qt3 qt3support qt4 readline resolvconf script sdl semantic-desktop session spell sqlite sse sse2 sse3 ssl ssse3 startup-notification static-libs subversion svg symlink tcpd theora tiff truetype udev udisks unicode upower usb vdpau video vorbis wav wavpack webkit wifi win32 win32codecs wxwidgets x264 xcb xcomposite xine xinerama xml xscreensaver xv xvid xvmc zeroconf zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USER="root"
USERLAND="GNU"
USE_EXPAND="ABI_MIPS ABI_PPC ABI_S390 ABI_X86 ALSA_CARDS APACHE2_MODULES APACHE2_MPMS CALLIGRA_FEATURES CAMERAS COLLECTD_PLUGINS CROSSCOMPILE_OPTS CURL_SSL DRACUT_MODULES DVB_CARDS ELIBC ENLIGHTENMENT_MODULES FCDSL_CARDS FFTOOLS FOO2ZJS_DEVICES FRITZCAPI_CARDS GPSD_PROTOCOLS GRUB_PLATFORMS INPUT_DEVICES KERNEL LCD_DEVICES LIBREOFFICE_EXTENSIONS LINGUAS LIRC_DEVICES MONKEYD_PLUGINS NETBEANS_MODULES NGINX_MODULES_HTTP NGINX_MODULES_MAIL OFED_DRIVERS OFFICE_IMPLEMENTATION OPENMPI_FABRICS OPENMPI_OFED_FEATURES OPENMPI_RM PHP_TARGETS PYTHON_SINGLE_TARGET PYTHON_TARGETS QEMU_SOFTMMU_TARGETS QEMU_USER_TARGETS RUBY_TARGETS SANE_BACKENDS USERLAND UWSGI_PLUGINS VIDEO_CARDS VOICEMAIL_STORAGE XFCE_PLUGINS XTABLES_ADDONS"
USE_EXPAND_HIDDEN="ABI_MIPS ABI_PPC ABI_S390 CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_EXPAND_IMPLICIT="ARCH ELIBC KERNEL USERLAND"
USE_EXPAND_UNPREFIXED="ARCH"
USE_EXPAND_VALUES_ARCH="alpha amd64 amd64-fbsd amd64-linux arm arm-linux arm64 hppa hppa-hpux ia64 ia64-hpux ia64-linux m68k m68k-mint mips ppc ppc64 ppc64-linux ppc-aix ppc-macos ppc-openbsd s390 sh sparc sparc64-freebsd sparc64-solaris sparc-fbsd sparc-solaris x64-freebsd x64-macos x64-openbsd x64-solaris x86 x86-cygwin x86-fbsd x86-freebsd x86-interix x86-linux x86-macos x86-netbsd x86-openbsd x86-solaris x86-winnt"
USE_EXPAND_VALUES_ELIBC="AIX Cygwin Darwin DragonFly FreeBSD glibc HPUX Interix mintlib musl NetBSD OpenBSD SunOS uclibc Winnt"
USE_EXPAND_VALUES_KERNEL="AIX Cygwin Darwin FreeBSD freemint HPUX Interix linux NetBSD OpenBSD SunOS Winnt"
USE_EXPAND_VALUES_USERLAND="BSD GNU"
USE_ORDER="env:pkg:conf:defaults:pkginternal:repo:env.d"
VBOX_APP_HOME="/usr/lib64/virtualbox"
VIDEO_CARDS="nvidia vesa"
WINDOWID="20971547"
WINDOWPATH="7"
XAUTHORITY="/root/.xauthfxCuNW"
XCURSOR_THEME="Oxygen_White"
XDG_CONFIG_DIRS="/etc/xdg"
XDG_CURRENT_DESKTOP="KDE"
XDG_DATA_DIRS="/usr/share:/usr/local/share:/usr/share"
XDG_SESSION_COOKIE="8b94ae00da0e067d4a255f35000043fb-1401871776.365513-1145730328"
XDM_MANAGED="method=classic"
XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
XZ_OPT="-9"
_="/usr/bin/emerge"

kobold manuel #


Package.mask:

Code:


# mask newer versions of emu-32 bit baselibs becaause wine-1.2.2. for diablo will not work with them!
#>app-emulation/emul-linux-x86-baselibs-20131008-r6

=net-im/skype-2.2.0.35-r1
#sci-geosciences/googleearth*

#mask newer versions of libreoffice beacuse they crash often
# workaround libreoffice crash use lower version
#>app-office/libreoffice-4.0.4.2


# mask some packages to avoid glib update with breaks consolekit -> pulseaudio, mounting etc
# see: http://forums.gentoo.org/viewtopic-p-7514236.html#7514236 and https://bugs.gentoo.org/show_bug.cgi?id=501330
# Date: 10.03.2014
#>=dev-libs/glib-2.38.2
#>=dev-cpp/glibmm-2.38.1
#>=net-libs/glib-networking-2.38.2
#>x11-libs/gdk-pixbuf-2.28.2
#>x11-libs/gtk+-3.4.4
#>=dev-cpp/gtkmm-3.10.1
#>=dev-util/gdbus-codegen-2.38.2
#>=gnome-base/gvfs-1.18.3
#>=net-libs/webkit-gtk-2.2.4
#>=dev-util/anjuta-3.10.2   # REMOVED
#>=x11-misc/xdg-user-dirs-gtk-0.10
#>=dev-util/gdbus-codegen-2.36.4-r1
#>=net-libs/libsoup-2.44.2
#>=dev-libs/gobject-introspection-1.38.0
#>=dev-libs/gobject-introspection-common-1.38.0
#>=gnome-base/gnome-keyring-3.10.1
#>=gnome-base/libgnome-keyring-3.10.1



packake.accept_keywords

Code:

# is needed to fix consolekit bug !!! see package.mask
#media-sound/lingot

## steam
games-util/steam-launcher

# teamviewer
net-misc/teamviewer

# speech recognition
app-accessibility/sphinx3
sci-mathematics/htk
app-accessibility/cmuclmtk
dev-java/jdbc-postgresql
dev-python/urllib3
dev-python/configparser
dev-python/backports-ssl-match-hostname
dev-python/pywavelets
# used for controling windows
x11-misc/wmiface


# BRAND new nv drivers and new kernel
#x11-drivers/nvidia-drivers
#sys-kernel/gentoo-sources

# new MYPaint for tablet
media-gfx/mypaint

# NEW WACOM XORG DRIVERS (required for the tablet to work in x, also kernel patches are needed and the new 0.8 libwacom)
x11-drivers/xf86-input-wacom


# NEW LIBREOFFICE hope it does not crash so often / quickpkg packes of libreoffice4.0.2.x (no crashes but broke emerge) and 4.1.x (few crashes)

app-office/libreoffice
app-text/libodfgen
app-text/libebook
app-text/libetonyek
app-text/libabw
dev-cpp/libcmis:0.4
app-text/libmwaw
dev-util/mdds
media-libs/libfreehand
app-office/libreoffice-l10n

# video editing/recording software

media-video/simplescreenrecorder
media-video/openshot

#  new nv drivers and new kernel 07.10.2013 normaly not needed just couriuos
#=x11-drivers/nvidia-drivers-325.15
#=sys-kernel/gentoo-sources-3.12
#>=sys-kernel/linux-headers-3.12

# needed for blue tint bug workaround in flash videos!
x11-libs/libvdpau
#kde-misc/semantik

# for newest firefox needed
dev-libs/nspr
dev-libs/nss
www-client/firefox
mail-client/thunderbird

# still needed for udisk ?
#=sys-auth/pam_mount-2.13

# so we can install the downloaded java archives...
dev-java/oracle-jre-bin
dev-java/oracle-jdk-bin

# newest skype version
net-im/skype

# newest calibre version - warning can cause major problems with KDE compiling, needs KDE 4.12 !!!!!!
#app-text/calibre
#dev-python/PyQt4
#dev-python/sip
#kde-base/pykde4
#kde-base/kdelibs
#kde-base/oxygen-icons
#kde-base/kde-env
#kde-base/nepomuk-widgets

# newest wine version WARNING: new emul-baselib will break wine-1.2.2. for diablo
#app-emulation/wine
#app-emulation/emul-linux-x86*

# for vpn
#net-firewall/ufw

# for hamchi gameing
net-misc/logmein-hamachi ~amd64
net-misc/haguichi

# for vmware workstartion 10
app-emulation/vmware-modules
app-emulation/vmware-tools
app-emulation/vmware-workstation


Any help would be much apprechiated :-D
_________________
Thank you for your help.

Manuel


Last edited by GenProm on Thu Jun 05, 2014 8:58 am; edited 1 time in total
Back to top
View user's profile Send private message
slick
Bodhisattva
Bodhisattva


Joined: 20 Apr 2003
Posts: 3490

PostPosted: Wed Jun 04, 2014 9:54 am    Post subject: Reply with quote

See 992424
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum