Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Still can't get round udev/eudev/systemd blockers
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1313
Location: /uk/sheffield

PostPosted: Thu Aug 15, 2013 5:36 pm    Post subject: Still can't get round udev/eudev/systemd blockers Reply with quote

I'm having real problems resolving this on two of my systems.

I've read through and tried suggestions in these threads...

https://forums.gentoo.org/viewtopic-t-966000.html
https://forums.gentoo.org/viewtopic-t-955000-start-25.html

...and others (around issues with emul-linux packages that crop up as a consequence).

I first tried emerging udev, then installing systemd, but now eudev is pulled in by virtual/udev, and despite me trying to keyword it out I'm told I need to change that.

In /etc/portage/package.keywords
Code:

sys-apps/hwids -~amd64
sys-apps/systemd -~amd64
sys-fs/udev -~amd64
virtual/udev -~amd64


Currently I'm getting (long as I've been on holiday for three weeks)...

Code:

# emerge -uDNa @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] app-arch/xz-utils-5.0.5-r1 [5.0.5] ABI_X86="32%* (64%*) (-x32)"
[ebuild   R    ] dev-python/python-exec-0.3.1  PYTHON_TARGETS="(-pypy1_9*) (-python2_5*) (-python3_1*)"
[ebuild   R    ] sys-libs/ncurses-5.9-r2  USE="-gpm*"
[ebuild     U  ] virtual/libiconv-0-r1 [0] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-libs/libdvdcss-1.2.13-r1 [1.2.13] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-libs/vo-aacenc-0.1.3 [0.1.2] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-libs/ilmbase-2.0.1-r1 [2.0.1] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] dev-libs/gobject-introspection-common-1.36.0 [1.34.2]
[ebuild     U  ] gnome-base/gnome-common-3.7.4 [3.6.0]
[ebuild     U  ] media-libs/libcddb-1.3.2-r1 [1.3.2] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-plugins/caps-plugins-0.9.10 [0.4.5-r2] USE="-doc%"
[ebuild     U  ] sys-libs/mtdev-1.1.4 [1.1.3]
[ebuild     U  ] app-arch/p7zip-9.20.1-r4 [9.20.1-r3]
[ebuild     U  ] app-office/libreoffice-l10n-4.1.0.4 [4.1.0.2]
[ebuild   R    ] x11-base/xorg-drivers-1.14  VIDEO_CARDS="-radeonsi%"
[ebuild     U  ] dev-libs/kpathsea-6.1.1_p20130530 [6.1.0_p20120701]
[ebuild  N     ] media-sound/wavpack-4.60.1-r1  USE="mmx -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] app-arch/bzip2-1.0.6-r4 [1.0.6-r3] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] dev-libs/expat-2.1.0-r3 [2.1.0-r2] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] sys-libs/libraw1394-2.1.0-r1 [2.1.0] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] dev-libs/libffi-3.0.13-r1 [3.0.13] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] dev-libs/libusb-1.0.9-r2 [1.0.9] USE="-examples%" ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] virtual/libffi-3.0.13-r1 [3.0.11] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] virtual/libusb-1-r1 [1] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-libs/x264-0.0.20130731 [0.0.20130506] USE="sse%*" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] media-libs/libsidplay-1.36.59-r1  USE="-static-libs" ABI_X86="32 (64) (-x32)"
[ebuild  N     ] media-libs/libsidplay-2.1.1-r4  USE="-static-libs" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] x11-libs/gnome-pty-helper-0.34.7 [0.34.2]
[ebuild     U  ] sys-libs/libieee1284-0.2.11-r3 [0.2.11-r2] ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] dev-util/gtk-builder-convert-2.24.20  PYTHON_SINGLE_TARGET="(-python2_5) -python2_6 python2_7" PYTHON_TARGETS="(-python2_5) -python2_6 python2_7"
[ebuild     U  ] dev-lang/v8-3.19.18.18 [3.19.18.9]
[ebuild     U  ] dev-python/setuptools-0.9.8-r1 [0.9.7]
[ebuild   R    ] dev-python/pyxdg-0.25  PYTHON_TARGETS="-pypy2_0%"
[ebuild     U  ] net-libs/nodejs-0.10.15 [0.10.13]
[ebuild     U  ] dev-util/gdbus-codegen-2.36.3 [2.34.3]
[ebuild     U  ] app-admin/eselect-ruby-20130814 [20120106]
[ebuild     U  ] dev-vcs/mercurial-2.7 [2.6.3]
[ebuild     U  ] app-admin/logrotate-3.8.6 [3.8.5]
[ebuild   R    ] sys-auth/pambase-20120417-r2  USE="systemd*"
[ebuild     U  ] sys-apps/ed-1.9 [1.7-r1]
[ebuild   R    ] sys-apps/busybox-1.21.0  USE="systemd*"
[ebuild     U  ] sys-apps/bleachbit-0.9.6 [0.9.5] LINGUAS="-ar% -ast% -be% -bg% -bn% -bs% -ca% -cs% -da% -de% -el% -en_AU% en_GB%* -eo% -es% -et% -eu% -fa% -fi% -fo% -fr% -gl% -he% -hi% -hr% -hu% -hy% -ia% -id% -it% -ja% -ko% -ku% -ky% -lt% -ms% -my% -nb% -nds% -nl% -pl% -pt% -pt_BR% -ro% -ru% -se% -si% -sk% -sl% -sr% -sv% -ta% -te% -th% -tr% -ug% -uk% -uz% -vi% -zh_CN% -zh_TW%"
[ebuild     U  ] sys-libs/libavc1394-0.5.4-r1 [0.5.4] ABI_X86="32%* (64%*) (-x32)"
[ebuild  NS    ] dev-lang/spidermonkey-17.0.0-r1 [1.8.5-r4] USE="-debug -jit -minimal -static-libs {-test}"
[ebuild     U  ] dev-libs/libcdio-0.90-r1 [0.90] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-libs/libshout-2.3.1-r1 [2.3.1] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] app-admin/eselect-php-0.7.1-r2 [0.7.1] USE="fpm*"
[ebuild  N     ] media-libs/libiec61883-1.2.0-r1  USE="-examples -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild  N     ] media-libs/portaudio-19_pre20111121-r1  USE="alsa cxx -debug -jack oss -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] dev-tex/bibtexu-3.71_p20130530 [3.71_p20120701] USE="-doc% -source%"
[ebuild     U  ] sys-libs/tevent-0.9.19 [0.9.18] PYTHON_SINGLE_TARGET="-python2_6% python2_7%*" PYTHON_TARGETS="-python2_6% python2_7%*"
[ebuild     U  ] sys-power/acpid-2.0.19 [2.0.18]
[ebuild     U  ] sys-apps/openrc-0.12 [0.11.8] USE="netifrc%* -tools%"
[ebuild  N     ] net-misc/netifrc-0.1
[ebuild  N     ] dev-libs/libusb-compat-0.1.5-r2  USE="-debug -examples -static-libs" ABI_X86="32 (64) (-x32)"
[uninstall     ] dev-libs/libusb-0.1.12-r7
[blocks b      ] dev-libs/libusb:0 ("dev-libs/libusb:0" is blocking dev-libs/libusb-compat-0.1.5-r2)
[blocks b      ] dev-libs/libusb-compat ("dev-libs/libusb-compat" is blocking dev-libs/libusb-0.1.12-r7)
[ebuild     U  ] virtual/libusb-0-r1 [0] ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] virtual/service-manager-0  USE="(-prefix)"
[ebuild     U  ] sys-apps/lshw-02.17b [02.16b-r2]
[ebuild     U  ] net-firewall/iptables-1.4.20 [1.4.19.1]
[ebuild     U  ] sys-apps/attr-2.4.47-r1 [2.4.47] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] sys-libs/zlib-1.2.8-r1 [1.2.8] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] dev-lang/perl-5.16.3 [5.16.1]
[ebuild     U  ] media-libs/libpng-1.6.3-r1 [1.6.3] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] sys-apps/util-linux-2.23.2 [2.23.1] USE="-udev*"
[ebuild     U  ] net-misc/curl-7.32.0 [7.31.0]
[ebuild     U  ] dev-libs/libgcrypt-1.5.3 [1.5.2-r1]
[ebuild     U  ] x11-libs/pixman-0.30.2 [0.30.0]
[ebuild     U  ] sys-devel/binutils-2.23.2 [2.23.1]
[ebuild     U  ] app-text/libpaper-1.1.24-r2 [1.1.24-r1] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-libs/libjpeg-turbo-1.3.0-r2 [1.3.0] ABI_X86="32%* (64%*) (-x32)"
[ebuild  NS    ] virtual/jpeg-62 [0] ABI_X86="32 (64) (-x32)"
[ebuild     U  ] virtual/jpeg-0-r2 [0] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-libs/tiff-4.0.3-r3 [4.0.3-r2] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-libs/lcms-2.5-r1 [2.5] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] sys-libs/cracklib-2.9.0-r1 [2.9.0]
[ebuild     U  ] sys-devel/llvm-3.3-r1 [3.3] USE="-clang% python%* static-analyzer%*" ABI_X86="32%* (64%*) (-x32)" PYTHON_TARGETS="(-pypy1_9) -pypy2_0% (-python2_5) -python2_6% python2_7%*"
[ebuild     U  ] sys-devel/patch-2.7.1-r2 [2.7.1-r1]
[ebuild     U  ] sys-apps/portage-2.2.0 [2.2.0_alpha188]
[ebuild     U  ] media-libs/libpng-1.2.50-r1 [1.2.50] ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] dev-libs/udis86-1.7-r2  USE="{-test}" ABI_X86="32 (64) (-x32)"
[ebuild  NS    ] media-libs/tiff-3.9.7-r1 [4.0.3-r2] USE="cxx -jbig jpeg zlib" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] app-crypt/p11-kit-0.19.3 [0.18.4]
[ebuild     U  ] dev-lang/orc-0.4.17-r1 [0.4.17] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-libs/libdvdread-4.2.0-r1 [4.2.0] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] dev-libs/nss-3.15.1-r1 [3.15]
[ebuild     U  ] media-libs/libsndfile-1.0.25-r1 [1.0.25] USE="{-test%}" ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] dev-lang/ruby-1.8.7_p374-r1 [1.8.7_p374]
[ebuild     U  ] media-libs/a52dec-0.7.4-r7 [0.7.4-r6] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-libs/libmad-0.15.1b-r8 [0.15.1b-r7] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-libs/libdvdnav-4.2.0-r1 [4.2.0] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] dev-libs/libcdio-paranoia-0.90_p1-r1 [0.90_p1] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-sound/cdparanoia-3.10.2-r6 [3.10.2-r5] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] net-libs/gnutls-3.2.3 [3.2.1-r1]
[ebuild     U  ] media-libs/libsamplerate-0.1.8-r1 [0.1.8] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] net-libs/neon-0.30.0 [0.29.6-r5]
[ebuild     U  ] media-libs/speex-1.2_rc1-r2 [1.2_rc1-r1] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-libs/libid3tag-0.15.1b-r4 [0.15.1b-r3] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-libs/schroedinger-1.0.11-r1 [1.0.11] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] x11-apps/iceauth-1.0.6 [1.0.5]
[ebuild     U  ] media-libs/libgphoto2-2.5.2 [2.5.1.1]
[ebuild     U  ] media-libs/libdca-0.0.5-r3 [0.0.5-r2] ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] media-libs/libvisual-0.4.0-r3  USE="-debug nls -static-libs -threads" ABI_X86="32 (64) (-x32)"
[ebuild  N     ] media-video/dirac-1.0.2-r1  USE="-debug -doc mmx -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] media-sound/jack-audio-connection-kit-0.121.3-r1 [0.121.3] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] media-sound/twolame-0.3.13-r1 [0.3.13] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] gnome-extra/yelp-xsl-3.8.1 [3.6.1]
[ebuild     U  ] media-libs/gavl-1.4.0-r1 [1.4.0] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] perl-core/Scalar-List-Utils-1.300.0 [1.270.0]
[ebuild     U  ] virtual/perl-Scalar-List-Utils-1.300.0 [1.270.0]
[ebuild     U  ] perl-core/Archive-Tar-1.920.0 [1.900.0] USE="{-test%}"
[ebuild     U  ] virtual/perl-Archive-Tar-1.920.0 [1.900.0]
[ebuild     U  ] perl-core/Digest-MD5-2.530.0 [2.520.0]
[ebuild     U  ] virtual/perl-Digest-MD5-2.530.0 [2.520.0]
[ebuild     U  ] perl-core/Storable-2.450.0 [2.390.0]
[ebuild     U  ] virtual/perl-Storable-2.450.0 [2.390.0]
[ebuild     U  ] x11-themes/gnome-icon-theme-symbolic-3.8.3 [3.6.2]
[ebuild     U  ] x11-themes/gnome-icon-theme-3.8.3 [3.6.2]
[ebuild     U  ] virtual/perl-PodParser-1.610.0 [1.600.0]
[ebuild     U  ] perl-core/Digest-SHA-5.850.0 [5.820.0] USE="{-test%}"
[ebuild     U  ] perl-core/Encode-2.510.0 [2.490.0]
[ebuild     U  ] virtual/perl-Encode-2.510.0 [2.490.0]
[ebuild     U  ] perl-core/Parse-CPAN-Meta-1.440.500 [1.440.400]
[ebuild     U  ] virtual/perl-Parse-CPAN-Meta-1.440.500 [1.440.400]
[ebuild     U  ] dev-lang/ruby-2.0.0_p247-r1 [2.0.0_p247]
[ebuild     U  ] dev-lang/ruby-1.9.3_p448-r1 [1.9.3_p448]
[ebuild     U  ] perl-core/ExtUtils-MakeMaker-6.720.0 [6.640.0]
[ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-6.720.0 [6.640.0]
[ebuild     U  ] perl-core/CPAN-Meta-2.132.140 [2.120.921]
[ebuild     U  ] virtual/perl-CPAN-Meta-2.132.140 [2.120.921]
[ebuild     U  ] dev-libs/glib-2.36.3-r2 [2.34.3] ABI_X86="32%* (64%*) (-x32)" PYTHON_TARGETS="(-python2_5) -python2_6% python2_7%*"
[ebuild     U  ] dev-perl/File-MimeInfo-0.170.0 [0.160.0]
[ebuild     U  ] dev-cpp/glibmm-2.36.2 [2.34.1]
[ebuild     U  ] dev-libs/fribidi-0.19.5-r2 [0.19.5-r1] ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] media-libs/libmimic-1.0.4-r2  USE="-doc -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild  N     ] media-libs/libmms-0.6.2-r1  USE="-static-libs" ABI_X86="32 (64) (-x32)"
[ebuild  N     ] dev-libs/liboil-0.3.17-r2  USE="examples -static-libs {-test}" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] app-admin/syslog-ng-3.4.3 [3.4.2]
[ebuild     U  ] media-gfx/gphoto2-2.5.2 [2.5.0]
[ebuild     U  ] net-fs/nfs-utils-1.2.8-r1 [1.2.7]
[ebuild     U  ] app-admin/testdisk-6.14 [6.13]
[ebuild     U  ] media-libs/openexr-2.0.1-r1 [2.0.1] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] virtual/perl-Digest-SHA-5.850.0 [5.820.0]
[ebuild     U  ] dev-vcs/subversion-1.7.11 [1.7.10]
[ebuild  N     ] sys-fs/eudev-1.2-r1  USE="-doc gudev hwdb -introspection keymap -kmod modutils openrc rule-generator (-selinux) -static-libs {-test}" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] virtual/udev-206-r2 [200] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] app-emulation/emul-linux-x86-baselibs-20130224-r11 [20130224] ABI_X86="32%*"
[blocks b      ] <=app-emulation/emul-linux-x86-baselibs-20130224-r2 ("<=app-emulation/emul-linux-x86-baselibs-20130224-r2" is blocking sys-devel/llvm-3.3-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-baselibs-20130224 ("<=app-emulation/emul-linux-x86-baselibs-20130224" is blocking app-arch/bzip2-1.0.6-r4, sys-libs/zlib-1.2.8-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-baselibs-20130224-r5 ("<=app-emulation/emul-linux-x86-baselibs-20130224-r5" is blocking media-libs/libjpeg-turbo-1.3.0-r2)
[blocks b      ] <=app-emulation/emul-linux-x86-baselibs-20130224-r10 ("<=app-emulation/emul-linux-x86-baselibs-20130224-r10" is blocking app-text/libpaper-1.1.24-r2)
[blocks b      ] <=app-emulation/emul-linux-x86-baselibs-20130224-r1 ("<=app-emulation/emul-linux-x86-baselibs-20130224-r1" is blocking dev-libs/libffi-3.0.13-r1, dev-libs/udis86-1.7-r2, media-libs/libpng-1.6.3-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-baselibs-20130224-r6 ("<=app-emulation/emul-linux-x86-baselibs-20130224-r6" is blocking dev-libs/expat-2.1.0-r3)
[blocks b      ] <=app-emulation/emul-linux-x86-baselibs-20130224-r10 ("<=app-emulation/emul-linux-x86-baselibs-20130224-r10" is blocking media-libs/lcms-2.5-r1, media-libs/tiff-3.9.7-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-baselibs-20130224-r7 ("<=app-emulation/emul-linux-x86-baselibs-20130224-r7" is blocking dev-libs/libusb-1.0.9-r2, dev-libs/libusb-compat-0.1.5-r2, sys-fs/eudev-1.2-r1)
[blocks b      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking sys-libs/libraw1394-2.1.0-r1, sys-libs/libavc1394-0.5.4-r1, sys-libs/zlib-1.2.8-r1, app-arch/bzip2-1.0.6-r4, sys-apps/attr-2.4.47-r1, app-text/libpaper-1.1.24-r2)
[blocks b      ] <=app-emulation/emul-linux-x86-baselibs-20130224-r9 ("<=app-emulation/emul-linux-x86-baselibs-20130224-r9" is blocking dev-libs/glib-2.36.3-r2, media-libs/tiff-4.0.3-r3)
[blocks b      ] <=app-emulation/emul-linux-x86-baselibs-20130224-r3 ("<=app-emulation/emul-linux-x86-baselibs-20130224-r3" is blocking media-libs/libpng-1.2.50-r1)
[blocks b      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking dev-libs/libusb-1.0.9-r2, sys-devel/llvm-3.3-r1, media-libs/tiff-3.9.7-r1, dev-libs/glib-2.36.3-r2, dev-libs/udis86-1.7-r2, dev-libs/libusb-compat-0.1.5-r2, media-libs/lcms-2.5-r1, media-libs/tiff-4.0.3-r3, media-libs/libjpeg-turbo-1.3.0-r2, dev-libs/libffi-3.0.13-r1, media-libs/libpng-1.2.50-r1, dev-libs/expat-2.1.0-r3, sys-fs/eudev-1.2-r1, media-libs/libpng-1.6.3-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-baselibs-20130224-r4 ("<=app-emulation/emul-linux-x86-baselibs-20130224-r4" is blocking sys-libs/libavc1394-0.5.4-r1, sys-libs/libraw1394-2.1.0-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-baselibs-20130224-r9 ("<=app-emulation/emul-linux-x86-baselibs-20130224-r9" is blocking sys-apps/attr-2.4.47-r1)
[ebuild     U  ] sys-fs/lvm2-2.02.99-r2 [2.02.98] USE="-lvm2create_initrd% -static*"
[ebuild     U  ] dev-libs/libatasmart-0.19-r1 [0.19]
[ebuild     U  ] dev-libs/gobject-introspection-1.36.0 [1.34.2-r1] USE="-cairo%"
[blocks b      ] <dev-libs/gobject-introspection-1.36 ("<dev-libs/gobject-introspection-1.36" is blocking dev-libs/glib-2.36.3-r2)
[uninstall     ] dev-lang/vala-0.18.1
[blocks b      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0)
[ebuild     U  ] dev-libs/atk-2.8.0 [2.6.0] USE="{-test%}"
[ebuild     U  ] media-libs/gstreamer-1.0.8 [1.0.7]
[ebuild     U  ] gnome-base/gsettings-desktop-schemas-3.8.2 [3.6.1]
[ebuild     U  ] dev-python/pygobject-3.8.3 [3.4.2-r1]
[ebuild     U  ] net-libs/telepathy-glib-0.20.4 [0.20.3]
[ebuild     U  ] gnome-base/gnome-menus-3.8.0-r1 [3.6.2]
[ebuild     U  ] dev-libs/gjs-1.36.1 [1.34.0] USE="cairo%*"
[ebuild     U  ] dev-libs/libgee-0.10.3 [0.10.2]
[ebuild     U  ] net-libs/glib-networking-2.36.2 [2.34.2]
[ebuild     U  ] dev-cpp/atkmm-2.22.7 [2.22.6]
[ebuild     U  ] net-libs/libsoup-2.42.2 [2.40.3]
[uninstall     ] net-libs/libsoup-gnome-2.40.3
[blocks b      ] net-libs/libsoup-gnome ("net-libs/libsoup-gnome" is blocking net-libs/libsoup-2.42.2)
[blocks b      ] >=net-libs/libsoup-2.42 (">=net-libs/libsoup-2.42" is blocking net-libs/libsoup-gnome-2.40.3)
[ebuild     U  ] x11-libs/libX11-1.6.1 [1.6.0]
[ebuild     U  ] media-libs/mesa-9.1.6 [9.1.4]
[ebuild     U  ] x11-apps/xprop-1.2.2 [1.2.1]
[ebuild     U  ] x11-apps/xset-1.2.3 [1.2.2]
[ebuild     U  ] x11-libs/libvdpau-0.7 [0.6]
[ebuild     U  ] media-libs/fontconfig-2.10.92 [2.10.2-r1]
[ebuild  NS    ] media-video/ffmpeg-0.10.8 [1.2.1] USE="-3dnow -3dnowext X aac -aacplus alsa (-altivec) -amr -avx -bindist bzip2 -cdio (-celt) -cpudetection -debug dirac -doc encode faac (-frei0r) (-gnutls) -gsm hardcoded-tables -ieee1394 -jack -jpeg2k (-libass) -libv4l mmx -mmxext -modplug mp3 (-neon) network (-openal) (-openssl) oss -pic (-pulseaudio) (-rtmp) schroedinger (-sdl) -speex -ssse3 -static-libs {-test} -theora -threads truetype -v4l (-vaapi) -vdpau (-vis) vorbis -vpx x264 -xvid zlib" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] net-misc/openssh-6.2_p2-r4 [6.2_p2-r3]
[ebuild     U  ] dev-perl/perl-tk-804.31.0 [804.30.0]
[ebuild     U  ] sys-boot/grub-2.00_p5086 [2.00-r4]
[ebuild     U  ] media-gfx/argyllcms-1.5.1 [1.4.0-r2]
[ebuild     U  ] x11-libs/pango-1.34.1 [1.32.5]
[ebuild     U  ] gnome-base/librsvg-2.37.0 [2.36.4]
[ebuild     U  ] media-libs/cogl-1.14.0 [1.12.2-r1] USE="-profile%"
[ebuild     U  ] dev-cpp/pangomm-2.34.0 [2.28.4]
[ebuild   R    ] xfce-extra/xfce4-weather-plugin-0.8.3  USE="-udev*"
[ebuild     U  ] www-client/firefox-23.0 [22.0]
[ebuild  NS    ] media-libs/gst-plugins-bad-1.0.7 [0.10.23-r1] USE="nls orc"
[ebuild     U  ] x11-drivers/nvidia-drivers-325.15 [319.32]
[ebuild     U  ] media-libs/libv4l-1.0.0 [0.9.5] ABI_X86="32%* (64%*) (-x32)"
[ebuild  NS    ] media-plugins/gst-plugins-cdparanoia-1.0.7 [0.10.36]
[ebuild     U  ] media-gfx/imagemagick-6.8.6.8 [6.8.6.1]
[ebuild  N     ] media-libs/libwebp-0.3.1  USE="-experimental gif jpeg opengl png -static-libs -swap-16bit-csp tiff" ABI_X86="32 (64) (-x32)"
[ebuild  NS    ] media-plugins/gst-plugins-faad-1.0.7 [0.10.23]
[ebuild  NS    ] media-plugins/gst-plugins-dvdread-1.0.6 [0.10.19]
[ebuild  NS    ] media-plugins/gst-plugins-x264-1.0.6 [0.10.19]
[ebuild  NS    ] media-plugins/gst-plugins-a52dec-1.0.6 [0.10.19] USE="orc"
[ebuild  NS    ] media-plugins/gst-plugins-oss-1.0.7 [0.10.31]
[ebuild  NS    ] media-plugins/gst-plugins-flac-1.0.7 [0.10.31]
[ebuild  NS    ] media-plugins/gst-plugins-resindvd-1.0.7 [0.10.23]
[ebuild     U  ] app-emulation/emul-linux-x86-xlibs-20130224-r2 [20130224-r1] ABI_X86="32%*"
[blocks b      ] app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]" is blocking x11-libs/libX11-1.6.1, media-libs/fontconfig-2.10.92, x11-libs/libvdpau-0.7)
[ebuild  N     ] media-libs/libreplaygain-477-r1  ABI_X86="32 (64) (-x32)"
[ebuild  N     ] media-libs/libcuefile-477-r1  ABI_X86="32 (64) (-x32)"
[ebuild  N     ] media-sound/musepack-tools-465-r1  ABI_X86="32 (64) (-x32)"
[ebuild     U  ] app-text/texlive-core-2013 [2012-r1]
[blocks b      ] <app-text/texlive-core-2013 ("<app-text/texlive-core-2013" is blocking dev-tex/bibtexu-3.71_p20130530, dev-libs/kpathsea-6.1.1_p20130530, dev-texlive/texlive-fontutils-2013)
[ebuild     U  ] dev-tex/luatex-0.76.0 [0.70.1-r2]
[ebuild     U  ] dev-texlive/texlive-basic-2013 [2012]
[uninstall     ] dev-texlive/texlive-documentation-base-2012
[blocks b      ] dev-texlive/texlive-documentation-base ("dev-texlive/texlive-documentation-base" is blocking dev-texlive/texlive-basic-2013)
[ebuild     U  ] dev-texlive/texlive-latex-2013 [2012]
[ebuild     U  ] dev-texlive/texlive-fontutils-2013 [2012]
[ebuild     U  ] dev-texlive/texlive-genericrecommended-2013 [2012]
[ebuild     U  ] dev-texlive/texlive-fontsrecommended-2013 [2012]
[ebuild     U  ] dev-texlive/texlive-langenglish-2013 [2012]
[ebuild     U  ] dev-texlive/texlive-genericextra-2013 [2012]
[ebuild     U  ] dev-texlive/texlive-latexrecommended-2013 [2012-r1]
[ebuild     U  ] dev-texlive/texlive-pstricks-2013 [2012]
[ebuild     U  ] dev-texlive/texlive-bibtexextra-2013 [2012-r1]
[ebuild     U  ] dev-texlive/texlive-pictures-2013 [2012]
[ebuild     U  ] dev-texlive/texlive-latexextra-2013 [2012]
[ebuild     U  ] app-text/texlive-2013 [2012] LINGUAS="-br% -rm% -sco% -sq%"
[ebuild     U  ] media-libs/libmpeg2-0.5.1-r2 [0.5.1-r1] ABI_X86="32%* (64%*) (-x32)"
[ebuild  NS    ] media-plugins/gst-plugins-mpeg2dec-1.0.6 [0.10.19]
[ebuild     U  ] app-emulation/emul-linux-x86-medialibs-20130224-r12 [20130224-r2]
[blocks b      ] <=app-emulation/emul-linux-x86-medialibs-20130224-r9 ("<=app-emulation/emul-linux-x86-medialibs-20130224-r9" is blocking sys-libs/libieee1284-0.2.11-r3)
[blocks b      ] <=app-emulation/emul-linux-x86-medialibs-20130224-r5 ("<=app-emulation/emul-linux-x86-medialibs-20130224-r5" is blocking media-libs/libv4l-1.0.0)
[blocks b      ] <=app-emulation/emul-linux-x86-medialibs-20130224-r2 ("<=app-emulation/emul-linux-x86-medialibs-20130224-r2" is blocking media-libs/libcuefile-477-r1, media-libs/libreplaygain-477-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-medialibs-20130224-r3 ("<=app-emulation/emul-linux-x86-medialibs-20130224-r3" is blocking media-libs/libdca-0.0.5-r3, media-libs/speex-1.2_rc1-r2, media-libs/libmad-0.15.1b-r8)
[blocks b      ] <=app-emulation/emul-linux-x86-medialibs-20130224-r11 ("<=app-emulation/emul-linux-x86-medialibs-20130224-r11" is blocking media-video/ffmpeg-0.10.8)
[blocks b      ] <=app-emulation/emul-linux-x86-medialibs-20130224-r7 ("<=app-emulation/emul-linux-x86-medialibs-20130224-r7" is blocking media-libs/x264-0.0.20130731, media-libs/libiec61883-1.2.0-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-medialibs-20130224-r10 ("<=app-emulation/emul-linux-x86-medialibs-20130224-r10" is blocking dev-libs/libcdio-0.90-r1, dev-libs/fribidi-0.19.5-r2, dev-libs/libcdio-paranoia-0.90_p1-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-medialibs-20130224-r4 ("<=app-emulation/emul-linux-x86-medialibs-20130224-r4" is blocking media-libs/libdvdread-4.2.0-r1, media-libs/libdvdnav-4.2.0-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-medialibs-20130224-r6 ("<=app-emulation/emul-linux-x86-medialibs-20130224-r6" is blocking media-libs/libsidplay-2.1.1-r4, media-libs/libsidplay-1.36.59-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-medialibs-20130224-r8 ("<=app-emulation/emul-linux-x86-medialibs-20130224-r8" is blocking media-libs/libmms-0.6.2-r1, media-libs/libmimic-1.0.4-r2, media-libs/a52dec-0.7.4-r7)
[blocks b      ] <=app-emulation/emul-linux-x86-medialibs-20130224-r9 ("<=app-emulation/emul-linux-x86-medialibs-20130224-r9" is blocking media-libs/libmpeg2-0.5.1-r2, dev-libs/liboil-0.3.17-r2, media-libs/libvisual-0.4.0-r3)
[blocks b      ] >=media-libs/libv4l-0.8.9-r1[abi_x86_32] (">=media-libs/libv4l-0.8.9-r1[abi_x86_32]" is blocking app-emulation/emul-linux-x86-medialibs-20130224-r2)
[blocks b      ] <=app-emulation/emul-linux-x86-medialibs-20130224-r6 ("<=app-emulation/emul-linux-x86-medialibs-20130224-r6" is blocking media-libs/libshout-2.3.1-r1, media-libs/libid3tag-0.15.1b-r4)
[ebuild  N     ] media-plugins/gst-plugins-libav-1.1.0_pre20130128-r1  USE="orc"
[ebuild     U  ] media-plugins/frei0r-plugins-1.4 [1.3]
[ebuild     U  ] sci-mathematics/rstudio-0.97.551 [0.97.336]
[ebuild     U  ] x11-libs/wxGTK-2.8.12.1-r1 [2.8.12.1]
[ebuild     U  ] x11-libs/wxGTK-2.9.4.1-r1 [2.9.4.1]
[ebuild     U  ] dev-util/android-sdk-update-manager-22.0.5 [22.0.1-r1]
[ebuild     U  ] www-client/opera-12.16_p1860-r1 [12.16_p1860]
[ebuild     U  ] x11-libs/gtk+-3.8.2 [3.6.3-r2]
[ebuild     U  ] gnome-base/gnome-desktop-3.8.3 [3.6.3]
[ebuild     U  ] media-libs/clutter-1.14.4-r1 [1.12.2-r1]
[ebuild     U  ] x11-themes/gnome-themes-standard-3.8.3 [3.6.5]
[ebuild     U  ] net-wireless/gnome-bluetooth-3.8.1 [3.6.1]
[ebuild     U  ] x11-libs/vte-0.34.7 [0.34.2]
[ebuild     U  ] dev-libs/libgweather-3.8.2 [3.6.2]
[ebuild     U  ] dev-libs/libpeas-1.8.1 [1.6.2-r1] PYTHON_TARGETS="python3_2%* -python3_3%"
[ebuild     U  ] x11-libs/gtksourceview-3.8.2 [3.6.3]
[ebuild     U  ] dev-cpp/gtkmm-3.8.1 [3.6.0]
[ebuild     U  ] media-libs/clutter-gtk-1.4.4 [1.4.2]
[ebuild     U  ] media-gfx/gthumb-3.2.3 [3.0.2] USE="-json% -libsecret% -webkit% -webp%"
[ebuild   R    ] sys-apps/dbus-1.6.12  USE="systemd*"
[ebuild     U  ] app-crypt/gcr-3.8.2 [3.6.2] USE="gtk%*"
[ebuild     U  ] app-accessibility/at-spi2-core-2.8.0 [2.6.3]
[ebuild   R    ] app-editors/emacs-24.3-r2  USE="-gpm*"
[ebuild     U  ] gnome-base/dconf-0.16.1 [0.14.1]
[ebuild     U  ] app-accessibility/at-spi2-atk-2.8.1 [2.6.2]
[ebuild     U  ] app-i18n/ibus-1.5.3 [1.5.2]
[ebuild     U  ] net-libs/webkit-gtk-2.0.4 [1.10.2-r300] USE="-libsecret%"
[ebuild     U  ] dev-python/pyatspi-2.8.0 [2.6.0-r1]
[ebuild     U  ] gnome-extra/zenity-3.8.0 [3.6.0]
[ebuild     U  ] net-print/cups-1.6.3-r2 [1.6.3-r1] PYTHON_SINGLE_TARGET="(-python2_5) -python2_6% python2_7%*" PYTHON_TARGETS="(-python2_5) -python2_6% python2_7%*"
[ebuild     U  ] net-print/cups-filters-1.0.36-r1 [1.0.35]
[ebuild     U  ] net-fs/samba-3.6.18 [3.6.16]
[ebuild     U  ] dev-python/pycups-1.9.63 [1.9.62] PYTHON_TARGETS="(-pypy1_9) -pypy2_0% (-python2_5) -python2_6% python2_7%*"
[ebuild     U  ] app-office/libreoffice-4.1.0.4 [4.1.0.2]
[ebuild     U  ] dev-java/icedtea-bin-6.1.12.6 [6.1.12.5]
[ebuild     U  ] net-print/foomatic-filters-4.0.17-r1 [4.0.17]
[ebuild     U  ] gnome-base/gnome-keyring-3.8.2 [3.6.3]
[ebuild     U  ] gnome-base/libgnome-keyring-3.8.0 [3.6.0]
[ebuild     U  ] net-libs/gnome-online-accounts-3.8.2 [3.6.3]
[ebuild     U  ] dev-libs/libgdata-0.13.4 [0.13.3]
[ebuild     U  ] gnome-extra/evolution-data-server-3.8.4-r1 [3.6.4] USE="gtk%*"
[ebuild     U  ] gnome-base/nautilus-3.8.2 [3.6.3]
[ebuild     U  ] x11-terms/gnome-terminal-3.8.4 [3.6.2] USE="nautilus%*"
[ebuild   R    ] sys-apps/systemd-204  USE="static-libs*"
[ebuild     U  ] sys-auth/polkit-0.111-r1 [0.111] USE="systemd*"
[ebuild   R    ] media-sound/pulseaudio-4.0  USE="systemd*"
[ebuild     U  ] gnome-base/gvfs-1.16.3 [1.14.2] USE="-gnome-online-accounts% -mtp% systemd* {-test%}"
[ebuild     U  ] net-p2p/transmission-2.81 [2.80] USE="systemd*"
[ebuild     U  ] dev-lang/php-5.5.1-r1 [5.5.1] USE="fpm* systemd%*"
[ebuild   R    ] media-libs/libcanberra-0.30-r1  USE="-udev*"
[ebuild     U  ] sys-power/upower-0.9.21 [0.9.20-r2] USE="systemd*"
[ebuild     U  ] x11-misc/colord-0.1.34 [0.1.28] USE="scanner%* systemd*"
[ebuild   R    ] sys-apps/accountsservice-0.6.34  USE="systemd*"
[ebuild     U  ] media-video/ffmpeg-1.2.2 [1.2.1]
[ebuild     U  ] media-sound/mpg123-1.15.4-r1 [1.15.4] ABI_X86="32%* (64%*) (-x32)"
[ebuild   R    ] media-gfx/gimp-2.8.6  USE="(-aqua) -udev*"
[ebuild  NS    ] media-plugins/gst-plugins-pulse-1.0.7 [0.10.31]
[ebuild     U  ] www-plugins/google-talkplugin-4.4.2.0 [4.1.3.0]
[ebuild     U  ] app-editors/gedit-3.8.3 [3.6.2-r1] PYTHON_TARGETS="python3_2%* -python3_3%"
[ebuild   R    ] media-sound/mpd-0.17.4-r2  USE="systemd*"
[ebuild     U  ] net-print/hplip-3.13.7 [3.13.6]
[ebuild   R    ] xfce-base/xfce4-session-4.10.1  USE="systemd* -udev*"
[ebuild   R    ] net-misc/networkmanager-0.9.8.2-r3  USE="systemd*"
[ebuild     U  ] gnome-base/gnome-settings-daemon-3.8.4 [3.6.4]
[ebuild     U  ] x11-misc/lightdm-1.7.7 [1.4.0-r2]
[ebuild     U  ] app-emulation/emul-linux-x86-soundlibs-20130224-r10 [20130224-r4]
[blocks b      ] <=app-emulation/emul-linux-x86-soundlibs-20130224-r4 ("<=app-emulation/emul-linux-x86-soundlibs-20130224-r4" is blocking media-sound/cdparanoia-3.10.2-r6, media-sound/wavpack-4.60.1-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-soundlibs-20130224-r6 ("<=app-emulation/emul-linux-x86-soundlibs-20130224-r6" is blocking media-sound/twolame-0.3.13-r1, media-libs/libsndfile-1.0.25-r1, media-libs/libsamplerate-0.1.8-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-soundlibs-20130224-r5 ("<=app-emulation/emul-linux-x86-soundlibs-20130224-r5" is blocking media-sound/musepack-tools-465-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-soundlibs-20130224-r9 ("<=app-emulation/emul-linux-x86-soundlibs-20130224-r9" is blocking media-sound/mpg123-1.15.4-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-soundlibs-20130224-r8 ("<=app-emulation/emul-linux-x86-soundlibs-20130224-r8" is blocking media-libs/portaudio-19_pre20111121-r1)
[blocks b      ] <=app-emulation/emul-linux-x86-soundlibs-20130224-r7 ("<=app-emulation/emul-linux-x86-soundlibs-20130224-r7" is blocking media-sound/jack-audio-connection-kit-0.121.3-r1)
[ebuild     U  ] x11-wm/mutter-3.8.4 [3.6.3]
[ebuild     U  ] gnome-extra/gnome-color-manager-3.8.2 [3.6.1]
[ebuild     U  ] media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r1 [0.10.13_p201211]
[ebuild  NS    ] media-plugins/gst-plugins-meta-1.0-r1 [0.10-r8] USE="X a52 aac alsa cdda -dts -dv -dvb dvd ffmpeg flac -http -jack -lame -libass -libvisual -mms mp3 mpeg ogg -opus oss pulseaudio -taglib -theora -v4l -vcd vorbis (-vpx) -wavpack x264"
[ebuild     U  ] xfce-extra/xfce4-power-manager-1.2.0-r2 [1.2.0-r1]
[ebuild   R    ] media-video/vlc-2.0.7  USE="-udev*"
[ebuild     U  ] media-video/mplayer-1.2_pre20130729 [1.1.1-r1] USE="-dts* -dv* -faad* -live* -rar* -rtc* -speex* -theora* -toolame* -tremor* -twolame* -xvid*"
[ebuild     U  ] gnome-base/gnome-session-3.8.4 [3.6.2-r2] USE="systemd*"
[ebuild     U  ] gnome-extra/nm-applet-0.9.8.2 [0.9.6.4-r1] USE="introspection%* -modemmanager%"
[ebuild     U  ] app-cdr/brasero-3.8.0 [3.6.1]
[ebuild     U  ] app-admin/system-config-printer-common-1.4.1 [1.3.12] PYTHON_SINGLE_TARGET="-python2_6% python2_7%*" PYTHON_TARGETS="-python2_6% python2_7%*"
[ebuild     U  ] app-admin/system-config-printer-gnome-1.4.1 [1.3.12] PYTHON_SINGLE_TARGET="-python2_6% python2_7%*" PYTHON_TARGETS="-python2_6% python2_7%*"
[blocks b      ] <app-admin/system-config-printer-gnome-1.4.1 ("<app-admin/system-config-printer-gnome-1.4.1" is blocking app-admin/system-config-printer-common-1.4.1)
[ebuild     U  ] gnome-base/gnome-control-center-3.8.4.1-r1 [3.6.3-r1] USE="-modemmanager%"
[ebuild     U  ] gnome-base/gnome-shell-3.8.4 [3.6.3.1]
[ebuild     U  ] gnome-base/gdm-3.8.4 [3.6.2-r1]
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/eudev-1.2-r1)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/x264:0

  (media-libs/x264-0.0.20130506::gentoo, installed) pulled in by
    media-libs/x264:0/132= required by (media-video/handbrake-0.9.9::gentoo, installed)

  (media-libs/x264-0.0.20130731::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/x264-0.0.20130731[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-medialibs-20130224-r12::gentoo, ebuild scheduled for merge)
    >=media-libs/x264-0.0.20111017:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_x86_32(-)?,abi_x86_64(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-video/ffmpeg-0.10.8::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/eudev-1.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/eudev-1.2-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_x86_32(-)?,abi_x86_64(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,keymap,modutils,gudev?,hwdb,introspection?,selinux?,static-libs?] (>=sys-fs/eudev-1.2-r1[abi_x86_32(-),abi_x86_64(-),abi_x86_32(-),abi_x86_64(-),keymap,modutils,gudev,hwdb]) required by (virtual/udev-206-r2::gentoo, ebuild scheduled for merge)

  (sys-apps/systemd-204::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/systemd required by (net-p2p/transmission-2.81::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-39 required by (media-sound/pulseaudio-4.0::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (dev-lang/php-5.5.1-r1::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-197 required by (app-admin/openrc-settingsd-1.0.1::gentoo, installed)
    >=sys-apps/systemd-186 required by (sys-apps/accountsservice-0.6.34::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-44-r1[pam] required by (sys-auth/pambase-20120417-r2::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-shell-3.8.4::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-183 required by (gnome-base/gnome-session-3.8.4::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (gnome-base/gnome-settings-daemon-3.8.4::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (sys-auth/polkit-0.111-r1::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (media-sound/mpd-0.17.4-r2::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (gnome-base/gvfs-1.16.3::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-186[pam] required by (gnome-base/gdm-3.8.4::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-183 required by (net-misc/networkmanager-0.9.8.2-r3::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (sys-apps/dbus-1.6.12::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-44 required by (x11-misc/colord-0.1.34::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-200 required by (sys-power/upower-0.9.21::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked



My emerge --info

I read elsewhere in a thread on similar issues the other day about unmerging some of the emul-linux packages, but that doesn't seem to be an issue here.

Any pointers on how to reconcile the udev/systemd problems would be very much appreciated,

Cheers,

slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
broken_chaos
Guru
Guru


Joined: 18 Jan 2006
Posts: 370
Location: Ontario, Canada

PostPosted: Thu Aug 15, 2013 10:13 pm    Post subject: Reply with quote

What happens if you set USE="-abi_x86_32" for virtual/udev?
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3598
Location: USA

PostPosted: Thu Aug 15, 2013 10:47 pm    Post subject: Reply with quote

I thought eudev and systemd are mutually exclusive (since systemd includes udev)?

And yes, there have been a lot of mess with abi_x86_32 ... since they conflict with emul_linux...

As far as I can see, the two options are to just use x86_64 abi and have the emul_linux packages installed (non-multilib),
or get rid of all the emul_linux packages and have both abi_* set. (this is multilib, which seems to be causing problems)

I currently do not have abi_x86 set on my x86_64 machine and am not seeing any of these problems at all... I am using
emul_linux binaries however.

https://forums.gentoo.org/viewtopic-t-953900-start-0.html
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1265

PostPosted: Thu Aug 15, 2013 10:50 pm    Post subject: Reply with quote

Have you tried masking the one you don't want? For example eudev and udev? Systemd and udev are mutually exclusive and portage seems to have trouble deciding which one to use.

Also, if you are switching to systemd, do not enable that use flag until after it has been installed. You should also be aware that this flag may make some packages drop their support for openRC.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2204
Location: UK

PostPosted: Fri Aug 16, 2013 2:56 am    Post subject: Reply with quote

Whichever udev thing you want installed needs USE="hwdb keymap" now. Put the others in package.mask.
Back to top
View user's profile Send private message
broken_chaos
Guru
Guru


Joined: 18 Jan 2006
Posts: 370
Location: Ontario, Canada

PostPosted: Fri Aug 16, 2013 4:43 am    Post subject: Reply with quote

Ant P. wrote:
Whichever udev thing you want installed needs USE="hwdb keymap" now.

And, in this case, "udev thing" means any of sys-fs/udev, sys-fs-eudev, or sys-apps/systemd (or, in the future, anything listed in virtual/udev).
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1313
Location: /uk/sheffield

PostPosted: Fri Aug 16, 2013 6:16 am    Post subject: Reply with quote

Brilliant thank you all for the pointers/tips..

What has worked has been to drop 32-bit from ABI_X86 in make.conf (i.e. now ABI_X86="64") and also as advised mask sys-fs/udev and sys-fs/eudev and crucially virtual/udev (otherwise it tries to pull them back in) in /etc/portage/package.mask.

From the dependency tree and what I've read I gather that sys-fs/systemd is pulled in due to changes in GNOME, is that right?

I've also read that systemd includes a lot of the functions/features/services that udev does.

However, I'm marginally concerned about the mentioned loss of openrc support. There doesn't appear to be any packages being rebuilt with USE="-openrc" but is this something I should be worried about?

Thanks again,

slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1337

PostPosted: Fri Aug 16, 2013 8:14 am    Post subject: Reply with quote

slackline wrote:
From the dependency tree and what I've read I gather that sys-fs/systemd is pulled in due to changes in GNOME, is that right?


Yes.

slackline wrote:
However, I'm marginally concerned about the mentioned loss of openrc support. There doesn't appear to be any packages being rebuilt with USE="-openrc" but is this something I should be worried about?


`emerge -N @world` should rebuild them; if not, there's nothing that needs to be rebuild and thus nothing to worry about.
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1313
Location: /uk/sheffield

PostPosted: Fri Aug 16, 2013 8:31 am    Post subject: Reply with quote

[quote="TomWij"]
slackline wrote:

slackline wrote:
However, I'm marginally concerned about the mentioned loss of openrc support. There doesn't appear to be any packages being rebuilt with USE="-openrc" but is this something I should be worried about?


`emerge -N @world` should rebuild them; if not, there's nothing that needs to be rebuild and thus nothing to worry about.


Thats great, was in the process of performing `emerge -uDN @world` anyway.


Unfortunately I've hit another stopper that I can't seem to get around, this time with sys-fs/static-dev, it reports...

Code:

 * We have detected that you currently use udev or devfs or devtmpfs
 * and this ebuild cannot install to the same mount-point.
 * Please reinstall the ebuild (as root) like follows:
 *
 * mkdir /tmp/newroot
 * mount -o bind / /tmp/newroot
 * ROOT=/tmp/newroot/ emerge sys-fs/static-dev
 * umount /tmp/newroot
 * ERROR: sys-fs/static-dev-0.1 failed (preinst phase):
 *   Cannot install on udev/devfs tmpfs.
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called pkg_preinst
 *   environment, line 168:  Called die
 * The specific snippet of code:
 *           die "Cannot install on udev/devfs tmpfs.";
 *
 * If you need support, post the output of `emerge --info '=sys-fs/static-dev-0.1'`,
 * the complete build log and the output of `emerge -pqv '=sys-fs/static-dev-0.1'`.
 * The complete build log is located at '/var/tmp/portage/sys-fs/static-dev-0.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-fs/static-dev-0.1/temp/environment'.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/var/tmp/portage/sys-fs/static-dev-0.1/work/static-dev-0.1'
!!! FAILED preinst: 1



I duly created he directory and mounted it as advised but am told the same thing...

Code:

# df -h | grep newroot
/                      20G   13G  6.4G  66% /tmp/newroot
# grep newroot /etc/mtab
/ /tmp/newroot none rw,bind 0 0
# ROOT=/tmp/newroot/ emerge -1 sys-fs/static-dev
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-fs/static-dev-0.1 for /tmp/newroot/
>>> Unpacking source...
>>> Source unpacked in /var/tmp/portage/sys-fs/static-dev-0.1/work
>>> Compiling source in /var/tmp/portage/sys-fs/static-dev-0.1/work ...
>>> Source compiled.
>>> Test phase [not enabled]: sys-fs/static-dev-0.1

>>> Install static-dev-0.1 into /var/tmp/portage/sys-fs/static-dev-0.1/image/ category sys-fs
>>> Completed installing static-dev-0.1 into /var/tmp/portage/sys-fs/static-dev-0.1/image/


>>> Installing (1 of 1) sys-fs/static-dev-0.1 to /tmp/newroot/

 * We have detected that you currently use udev or devfs or devtmpfs
 * and this ebuild cannot install to the same mount-point.
 * Please reinstall the ebuild (as root) like follows:
 *
 * mkdir /tmp/newroot
 * mount -o bind / /tmp/newroot
 * ROOT=/tmp/newroot/ emerge sys-fs/static-dev
 * umount /tmp/newroot
 * ERROR: sys-fs/static-dev-0.1 failed (preinst phase):
 *   Cannot install on udev/devfs tmpfs.
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called pkg_preinst
 *   environment, line 168:  Called die
 * The specific snippet of code:
 *           die "Cannot install on udev/devfs tmpfs.";
 *
 * If you need support, post the output of `emerge --info '=sys-fs/static-dev-0.1'`,
 * the complete build log and the output of `emerge -pqv '=sys-fs/static-dev-0.1'`.
 * The complete build log is located at '/var/tmp/portage/sys-fs/static-dev-0.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-fs/static-dev-0.1/temp/environment'.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/var/tmp/portage/sys-fs/static-dev-0.1/work/static-dev-0.1'
!!! FAILED preinst: 1


Can't see why its not using the alternative root which is correctly mounted?

Thanks again for all the assistance.
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3598
Location: USA

PostPosted: Fri Aug 16, 2013 1:40 pm    Post subject: Reply with quote

Uh no... you don't want static-dev ... I think this error means you can only do this merge if you are doing a "stage1" type build, like if you were using ROOT= to build an environment not the same as your root environment, if that makes sense.

But just to be very clear - you are installing gnome-3.8 right?

If this is the case, and from what I read in other posts, you need systemd and need to get rid of eudev. I have a feeling you may have a bit of a mess to clean up here as I'm not sure you can simply unmerge eudev end merge systemd - though this seems like it should be an option.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
broken_chaos
Guru
Guru


Joined: 18 Jan 2006
Posts: 370
Location: Ontario, Canada

PostPosted: Fri Aug 16, 2013 3:42 pm    Post subject: Reply with quote

slackline wrote:
also as advised mask sys-fs/udev and sys-fs/eudev and crucially virtual/udev (otherwise it tries to pull them back in) in /etc/portage/package.mask

You shouldn't mask virtual/udev. That drops udev entirely, which is definitely not what you want. You could mask sys-fs/udev and sys-fs/eudev, but not virtual/udev.

slackline wrote:
From the dependency tree and what I've read I gather that sys-fs/systemd is pulled in due to changes in GNOME, is that right?

Correct. GNOME 3.8 is set to depend on systemd in Gentoo. It doesn't strictly depend on it at build time, IIRC, but it loses a number of bits of functionality without (such as power control).

slackline wrote:
I've also read that systemd includes a lot of the functions/features/services that udev does.

The systemd ebuild installs its own copy of udev.
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1313
Location: /uk/sheffield

PostPosted: Sat Aug 17, 2013 7:14 am    Post subject: Reply with quote

eccerr0r wrote:
Uh no... you don't want static-dev ... I think this error means you can only do this merge if you are doing a "stage1" type build, like if you were using ROOT= to build an environment not the same as your root environment, if that makes sense.


That makes sense, but its a dependency thats just been pulled in.


eccerr0r wrote:
But just to be very clear - you are installing gnome-3.8 right?

If this is the case, and from what I read in other posts, you need systemd and need to get rid of eudev. I have a feeling you may have a bit of a mess to clean up here as I'm not sure you can simply unmerge eudev end merge systemd - though this seems like it should be an option.


No, not explicity, I use Xfce4 and a few GNOME programs like gdm, gthumb and gedit which pull in a host of dependencies.


I'm quickly realising its very messy and its causing me all sorts of headaches. I've been considering switching my OS drive to SSD so may bite the bullet buy one and do a fresh install on that.

For now though...

broken_chaos wrote:
slackline wrote:
also as advised mask sys-fs/udev and sys-fs/eudev and crucially virtual/udev (otherwise it tries to pull them back in) in /etc/portage/package.mask

You shouldn't mask virtual/udev. That drops udev entirely, which is definitely not what you want. You could mask sys-fs/udev and sys-fs/eudev, but not virtual/udev.


Another stab at `emerge -uDN @world` and I'm now being told to unmask virtual/udev and in turn sys-fs/udev which is pulled in by dev-libs/libatasmart....

Code:

...
[ebuild     U  ]    dev-libs/gobject-introspection-1.36.0 [1.34.2-r1] USE="-cairo%"
[nomerge       ] media-gfx/gtkam-0.2.0
[nomerge       ]  gnome-base/libgnomeui-2.24.5
[nomerge       ]   gnome-base/libgnome-2.32.1-r1
[nomerge       ]    gnome-base/gvfs-1.16.3 [1.14.2] USE="-gnome-online-accounts% -mtp% systemd* {-test%}"
[nomerge       ]     gnome-base/libgdu-3.0.2
[nomerge       ]      sys-fs/udisks-1.0.4-r5
[ebuild     U  ]       dev-libs/libatasmart-0.19-r1 [0.19]
[ebuild  N    #]        virtual/udev-206-r2  USE="gudev -introspection kmod (-selinux) -static-libs" ABI_X86="-32 (64) (-x32)"
[ebuild  N    #]         sys-fs/udev-206-r3  USE="acl -doc firmware-loader gudev -introspection kmod openrc (-selinux) static-libs" ABI_X86="-32 (64) (-x32)"
...
[blocks B      ]     x11-libs/libXdmcp[abi_x86_32(-)] ("x11-libs/libXdmcp[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20130224-r2)
[blocks B      ] app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)]" is blocking media-libs/libvpx-1.2.0_pre20130625)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-206-r3)
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-204)
 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-206-r3::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-206-r2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_x86_32(-)?,abi_x86_64(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev?,introspection?,kmod?,selinux?,static-libs?] (>=sys-fs/udev-206-r2[abi_x86_64(-),abi_x86_64(-),gudev,kmod]) required by (virtual/udev-206-r2::gentoo, ebuild scheduled for merge)

  (sys-apps/systemd-204::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/systemd required by (net-p2p/transmission-2.81::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-39 required by (media-sound/pulseaudio-4.0::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (dev-lang/php-5.5.1-r1::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-197 required by (app-admin/openrc-settingsd-1.0.1::gentoo, installed)
    >=sys-apps/systemd-186 required by (sys-apps/accountsservice-0.6.34::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-44-r1[pam] required by (sys-auth/pambase-20120417-r2::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-shell-3.8.4::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-183 required by (gnome-base/gnome-session-3.8.4::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (gnome-base/gnome-settings-daemon-3.8.4::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (sys-auth/polkit-0.111-r1::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (media-sound/mpd-0.17.4-r2::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (gnome-base/gvfs-1.16.3::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-186[pam] required by (gnome-base/gdm-3.8.4::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-183 required by (net-misc/networkmanager-0.9.8.2-r3::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (sys-apps/dbus-1.6.12::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-44 required by (x11-misc/colord-0.1.34::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-200 required by (sys-power/upower-0.9.21::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by virtual/udev-206-r2
# required by gnome-extra/nm-applet-0.9.8.2
# required by gnome-base/gnome-control-center-3.8.4.1-r1
# required by net-libs/gnome-online-accounts-3.8.2[gnome]
# required by dev-libs/libgdata-0.13.4[gnome]
# required by gnome-extra/evolution-data-server-3.8.4-r1
# required by gnome-base/gnome-shell-3.8.4
# required by gnome-base/gdm-3.8.4[gnome-shell]
# required by @selected
# required by @world (argument)
=sys-fs/udev-206-r3 ~amd64

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by virtual/udev-206-r2
# required by gnome-extra/nm-applet-0.9.8.2
# required by gnome-base/gnome-control-center-3.8.4.1-r1
# required by net-libs/gnome-online-accounts-3.8.2[gnome]
# required by dev-libs/libgdata-0.13.4[gnome]
# required by gnome-extra/evolution-data-server-3.8.4-r1
# required by gnome-base/gnome-shell-3.8.4
# required by gnome-base/gdm-3.8.4[gnome-shell]
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=sys-fs/udev-206-r3
# required by sys-fs/udisks-1.0.4-r5
# required by xfce-extra/xfce4-power-manager-1.2.0-r2[udisks]
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
#sys-fs/static-dev
=virtual/udev-206-r2

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by virtual/udev-206-r2
# required by gnome-extra/nm-applet-0.9.8.2
# required by gnome-base/gnome-control-center-3.8.4.1-r1
# required by net-libs/gnome-online-accounts-3.8.2[gnome]
# required by dev-libs/libgdata-0.13.4[gnome]
# required by gnome-extra/evolution-data-server-3.8.4-r1
# required by gnome-base/gnome-shell-3.8.4
# required by gnome-base/gdm-3.8.4[gnome-shell]
# required by @selected
# required by @world (argument)
=sys-fs/udev-206-r3 gudev

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.


Unmasking virtual/udev didn't help. It would be nice if virtual/udev recognised that sys-fs/systemd . Seriously considering purging my system of all GNOME things to avoid this mess!
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1337

PostPosted: Sat Aug 17, 2013 7:26 am    Post subject: Reply with quote

Quote:
[blocks B ] x11-libs/libXdmcp[abi_x86_32(-)] ("x11-libs/libXdmcp[abi_x86_32(-)]" is blocking app-emulation/emul-linux-x86-xlibs-20130224-r2)
[blocks B ] app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)]" is blocking media-libs/libvpx-1.2.0_pre20130625)
[blocks B ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-206-r3)
[blocks B ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-204)


For the first ore you want either libXdmcp or emul-linux-x86-xlibs, you can't have both; so, unmerge one. For the second one, same story.

For the latter two you need to unmerge sys-fs/udev and mask it, then you need to make sure that virtual/udev and sys-apps/systemd have their common USE flags set the same way.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum