Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
texlive-core fails to build [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2061
Location: Near Toronto

PostPosted: Fri Jul 27, 2012 5:55 pm    Post subject: texlive-core fails to build [SOLVED] Reply with quote

Here are the errors:

Code:
checking requested system `ptexenc' library... failed
checking requested system `zlib' library... failed
checking requested system `libpng' library... failed
checking requested system `xpdf' library... failed
configure: error: some requested system libraries failed

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/app-text/texlive-core-2012/work/texlive-core-2012_build/config.log
 * ERROR: app-text/texlive-core-2012 failed (configure phase):


any advice appreciated. TIA
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)


Last edited by albright on Fri Jul 27, 2012 8:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1044

PostPosted: Fri Jul 27, 2012 6:42 pm    Post subject: Re: texlive-core fails to build Reply with quote

albright wrote:
Here are the errors:

Code:
checking requested system `ptexenc' library... failed
checking requested system `zlib' library... failed
checking requested system `libpng' library... failed
checking requested system `xpdf' library... failed
configure: error: some requested system libraries failed

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/app-text/texlive-core-2012/work/texlive-core-2012_build/config.log
 * ERROR: app-text/texlive-core-2012 failed (configure phase):


any advice appreciated. TIA


i did a re-sync, then built texlive-core by itself before others. and it compiled.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2061
Location: Near Toronto

PostPosted: Fri Jul 27, 2012 8:00 pm    Post subject: Reply with quote

Quote:
re-sync, then built texlive-core by itself


that got it - many thanks!
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
papapenguin
l33t
l33t


Joined: 20 Sep 2005
Posts: 694
Location: Bellevue

PostPosted: Sun Aug 18, 2013 7:46 pm    Post subject: Reply with quote

...was getting the same error with app-text/texlive-core-2013...

had to add it to
Code:
/etc/portage/package.accept_keywords

then still build it by itself to get past the error message (which wouldn't let anything else compile)
_________________
--------------
Compaq Presario V6120US
AMD Turion 64X2
------------------------
Back to top
View user's profile Send private message
papapenguin
l33t
l33t


Joined: 20 Sep 2005
Posts: 694
Location: Bellevue

PostPosted: Sun Aug 18, 2013 8:34 pm    Post subject: Reply with quote

so here's the latest...just downgraded to the stable app-text/texlive-core...rebuilt it by itself, then tried:
Code:
papapenguin ~ # emerge -avuDN world
!!! Repository 'proaudio' is missing masters attribute in '/var/lib/layman/pro-audio/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=app-text/texlive-core-2013" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-text/texlive-core-2013::gentoo (masked by: ~amd64 keyword)

(dependency required by "dev-texlive/texlive-luatex-2013" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

papapenguin ~ #

and it still tries to pull in the hardmasked texlive-core-2013

...I'm going to try stable texlive-luatex...and see if that does anything...
_________________
--------------
Compaq Presario V6120US
AMD Turion 64X2
------------------------
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum