Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nvidia drivers failed to install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Sirserega
n00b
n00b


Joined: 05 Jul 2013
Posts: 23

PostPosted: Sat Aug 24, 2013 8:13 am    Post subject: Nvidia drivers failed to install Reply with quote

Hello i made new fresh instalation and when i'm trying to install nvidia drivers i got problem with compile.

Code:
 * ERROR: x11-drivers/nvidia-drivers-319.32 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-319.32'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-319.32'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-319.32/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-319.32/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-319.32/work/kernel'
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-319.32/work/'

>>> Failed to emerge x11-drivers/nvidia-drivers-319.32, Log file:

>>>  '/var/tmp/portage/x11-drivers/nvidia-drivers-319.32/temp/build.log'

 * Messages for package x11-drivers/nvidia-drivers-319.32:

 * Gentoo supports kernels which are supported by NVIDIA
 * which are limited to the following kernels:
 * <sys-kernel/gentoo-sources-3.10
 * <sys-kernel/vanilla-sources-3.10
 *
 * You are free to utilize epatch_user to provide whatever
 * support you feel is appropriate, but will not receive
 * support as a result of those changes.
 *
 * Do not file a bug report about this.

 * Messages for package x11-drivers/nvidia-drivers-319.32:

 * ERROR: x11-drivers/nvidia-drivers-319.32 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-319.32'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-319.32'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-319.32/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-319.32/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-319.32/work/kernel'
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-319.32/work/'


thats my make.conf

Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=corei7 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="udisks polkit consolekit dvd cdr acpi dbus opengl X symlink udev pulseaudio alsa xinerama qt4 kde $
MAKEOPTS="-j9"
INPUT_DEVICES="keyboard mouse evdev"
VIDEO_CARDS="nvidia"
ACCEPT_KEYWORDS="amd64"
PYTHON_TARGETS="python2_7 python3_2 pypy1_9 jython2_5"
LANGUAGE="48"
LINGUAS="pl pl_PL"


`emerge --info '=x11-drivers/nvidia-drivers-319.32'`

Code:
Portage 2.1.12.2 (default/linux/amd64/13.0/desktop, gcc-4.6.3, glibc-2.15-r3, 3.10.7-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.10.7-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:     8166532 total,   7626864 free
KiB Swap:    8000364 total,   8000364 free
Timestamp of tree: Fri, 23 Aug 2013 14:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.5-r2, 3.2.5-r2
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=corei7 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv ipv6 jpeg kde lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit polkit ppds pulseaudio qt3support qt4 readline sdl session spell sse sse2 ssl startup-notification svg symlink tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xinerama xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl pl_PL" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2 jython2_5" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 757

PostPosted: Sat Aug 24, 2013 3:12 pm    Post subject: Re: Nvidia drivers failed to install Reply with quote

Sirserega wrote:
...
Code:
 * Gentoo supports kernels which are supported by NVIDIA
 * which are limited to the following kernels:
 * <sys-kernel/gentoo-sources-3.10
 * <sys-kernel/vanilla-sources-3.10
...
and you have a 3.10.7 version.
Back to top
View user's profile Send private message
Sirserega
n00b
n00b


Joined: 05 Jul 2013
Posts: 23

PostPosted: Sat Aug 24, 2013 3:21 pm    Post subject: Reply with quote

i'm sorry i'm quite newbie how to fix it than ?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31341
Location: 56N 3W

PostPosted: Sat Aug 24, 2013 3:40 pm    Post subject: Reply with quote

Sirserega,

You have three or four choices ...

1. Downgrade your kernel to 3.9.x, so its supported by gentoo.
2. Find one of the unofficial patches floating around the net to address this and learn how to apply it.
3. Don't use the nvidia-drivers package, until its been updated. That's an nVidia problem.
4. Something else I've overlooked.

Option 2 is well documented on the forums BUT from time to time, these unofficial patches have been reported to destroy the odd video card.
Gentoo is about choice - you choose.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4560
Location: Saint Amant, Acadiana

PostPosted: Sat Aug 24, 2013 3:57 pm    Post subject: Reply with quote

4. Use newest nVidia drivers. (325.15)
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Sirserega
n00b
n00b


Joined: 05 Jul 2013
Posts: 23

PostPosted: Sat Aug 24, 2013 3:59 pm    Post subject: Reply with quote

Jaglover wrote:
4. Use newest nVidia drivers. (325.15)


ok :) but how to download and compile it becouse if i use emerge its always same version
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4560
Location: Saint Amant, Acadiana

PostPosted: Sat Aug 24, 2013 4:03 pm    Post subject: Reply with quote

It actually seems to be a bug, gentoo-sources-3.10.7 are declared stable, yet require unmasking nvidia-drivers for ~arch.

Yes, you have to unmask them.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Sirserega
n00b
n00b


Joined: 05 Jul 2013
Posts: 23

PostPosted: Sat Aug 24, 2013 4:07 pm    Post subject: Reply with quote

ok but when i do emerge --search nvidia i see only 1 driver

i'm quite sure it dumb problem sorry for that but i rly have problem with it ;/
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6250
Location: Goose Creek SC

PostPosted: Sat Aug 24, 2013 4:07 pm    Post subject: Reply with quote

add
Quote:
x11-drivers/nvidia-drivers ~amd64
to /etc/portage/package.keywords then emerge nvidia-drivers again

three newest versions are still in testing branch
Working with Gentoo and Working with portaqge sections of the gentoo handbook are welll worth the reading.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
paneloux
n00b
n00b


Joined: 29 Aug 2013
Posts: 1

PostPosted: Thu Aug 29, 2013 11:02 pm    Post subject: Re: Nvidia drivers failed to install Reply with quote

Sirserega wrote:
Hello i made new fresh instalation and when i'm trying to install nvidia drivers i got problem with compile.


This solution worked for me. Hope all goes well.
_________________
Kind Regards,

Paneloux


Last edited by paneloux on Tue Sep 03, 2013 3:28 am; edited 1 time in total
Back to top
View user's profile Send private message
AchilleTalon
Apprentice
Apprentice


Joined: 11 Apr 2004
Posts: 230
Location: not far Montreal, Quebec, Canada

PostPosted: Fri Aug 30, 2013 2:46 am    Post subject: Reply with quote

If the solution is to use nvidia-drivers 325.15, why is it still masked?
_________________
Achille Talon Hop!
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1223
Location: 42.68n 85.41w

PostPosted: Fri Aug 30, 2013 3:11 am    Post subject: Reply with quote

x11-drivers/nvidia-drivers-319.49 built against 3.10.9 and installed. ill test it in 2 seconds..... ill also test out 325.15 if 319.49 fails.
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
http://ecx.images-amazon.com/images/I/81Ku-vxIb3L._SL1500_.jpg
http://wiki.gentoo.org/wiki/Special:Contributions/666threesixes666
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6250
Location: Goose Creek SC

PostPosted: Fri Aug 30, 2013 3:11 am    Post subject: Reply with quote

Quote:
If the solution is to use nvidia-drivers 325.15, why is it still masked?
It is not masked. It is keyworded ~x86 and ~amd64. As the handbook says,"~arch keyword means that the application is not tested sufficiently to be put in the stable branch. Wait a few days or weeks and try again."
_________________
Defund the FCC.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1223
Location: 42.68n 85.41w

PostPosted: Fri Aug 30, 2013 3:18 am    Post subject: Reply with quote

nvidia-drivers 319.49 & vanilla-sources-3.10.9 works for me. no need to ~....
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
http://ecx.images-amazon.com/images/I/81Ku-vxIb3L._SL1500_.jpg
http://wiki.gentoo.org/wiki/Special:Contributions/666threesixes666
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6250
Location: Goose Creek SC

PostPosted: Fri Aug 30, 2013 3:34 am    Post subject: Reply with quote

as of 27 Aug 2013; Jeroen Roovers (jer) nvidia-drivers-319.49.ebuild: Stable for AMD64 x86 too. alpha, amd64, arm, hppa, ia64, ppc, ppc64, sparc, x86. 325.15, ~, ~.
packages.gentoo.org/package/x11-drivers/nvidia-drivers
progress progresses and someday soon 325.15 also will not need ~
_________________
Defund the FCC.
Back to top
View user's profile Send private message
mreff555
Apprentice
Apprentice


Joined: 10 Mar 2011
Posts: 169
Location: Philadelphia

PostPosted: Sat Aug 31, 2013 5:54 pm    Post subject: Reply with quote

after trying all of the listed kernels that were supported, with out any luck. Upgrading to the newest nvidia drivers fixed the problem :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum