Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ath9k - wlan0 failed to load
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Cruel
n00b
n00b


Joined: 25 Jun 2011
Posts: 54

PostPosted: Tue Aug 13, 2013 6:11 pm    Post subject: Ath9k - wlan0 failed to load Reply with quote

Hello all,

after I have installed my new gentoo system I have a problem with my wifi card.
I have a ASUS Travelmate 5542G with a "Atheros Communications Inc. AR9287 Wireless Network Adapter (PCI-Express)".
I've enabled the ath9k module in the kernel:

Quote:

CONFIG_ATH9K_HW=m
CONFIG_ATH9K_COMMON=m
CONFIG_ATH9K_BTCOEX_SUPPORT=y
CONFIG_ATH9K=m
CONFIG_ATH9K_PCI=y


and loaded, of course: lsmod

Quote:

Module Size Used by
ath9k .... 0
ath9k_common .... 1 ath9k
ath9k_hw .... 2 ath9k_common,ath9k
ath .... 3 ath9k_common,ath9k,ath9k_hw


The wired thing I have noticed is when I run "dmesg | grep -i ath":

Quote:

ath9k 0000:08:00.0: No memory for ieee80211_hw
ath9k: probe of 0000:08:00.0 failed with error -12


Someone of you an idea what could be the problem?
Thanks in advance
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Tue Aug 13, 2013 8:02 pm    Post subject: Reply with quote

have you?

Networking --->
Wireless --->
<M> Improved wireless configuration API
<M> Generic IEEE 802.11 Networking Stack (mac80211)
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Cruel
n00b
n00b


Joined: 25 Jun 2011
Posts: 54

PostPosted: Wed Aug 14, 2013 7:04 pm    Post subject: Reply with quote

DONAHUE wrote:
have you?

Networking --->
Wireless --->
<M> Improved wireless configuration API
<M> Generic IEEE 802.11 Networking Stack (mac80211)



Thank you for your response.
The "Generic IEEE 802.11 Networking Stack (mac80211)" is compiled in the kernel, is that okay?
I can't find " Improved wireless configuration API" instead of this I have "cfg80211 - wireless configuration API"
and this is also compiled in the kernel.

Thanks in advance
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Wed Aug 14, 2013 7:42 pm    Post subject: Reply with quote

My extraction from linuxwireless.org appears to have been dated. You might try:
Quote:
[*] Networking support --->
-*- Wireless --->
--- Wireless
<M> cfg80211 - wireless configuration API
[*] cfg80211 wireless extensions compatibility
<M> Generic IEEE 802.11 Networking Stack (mac80211)
<M> RF switch subsystem support --->
in kernel config.
Code:
emerge rfkill
rfkill list # for info
rfkill unblock all # if blocks exist
any btcoex 's in lsmod? in dmesg?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Cruel
n00b
n00b


Joined: 25 Jun 2011
Posts: 54

PostPosted: Wed Aug 14, 2013 9:13 pm    Post subject: Reply with quote

DONAHUE wrote:
My extraction from linuxwireless.org appears to have been dated. You might try:
Quote:
[*] Networking support --->
-*- Wireless --->
--- Wireless
<M> cfg80211 - wireless configuration API
[*] cfg80211 wireless extensions compatibility
<M> Generic IEEE 802.11 Networking Stack (mac80211)
<M> RF switch subsystem support --->
in kernel config.
Code:
emerge rfkill
rfkill list # for info
rfkill unblock all # if blocks exist
any btcoex 's in lsmod? in dmesg?


After I recompiled the kernel with the new settings and I restarted the laptop I got this from my dmesg:

Quote:

[ 68.606508] ------------[ cut here ]------------
[ 68.606520] WARNING: at net/mac80211/main.c:560 ieee80211_alloc_hw+0x7f/0x5d0()
[ 68.606522] Hardware name: TravelMate 5542G
[ 68.606524] Modules linked in: ath9k(+) ath9k_common ath9k_hw ath k10temp
[ 68.606531] Pid: 4, comm: kworker/0:0 Not tainted 3.8.13-gentoo #3
[ 68.606533] Call Trace:
[ 68.606539] [<ffffffff8103a23a>] warn_slowpath_common+0x7a/0xb0
[ 68.606542] [<ffffffff8103a285>] warn_slowpath_null+0x15/0x20
[ 68.606545] [<ffffffff817c35cf>] ieee80211_alloc_hw+0x7f/0x5d0
[ 68.606557] [<ffffffffa008e9ed>] ath_pci_probe+0x16d/0x320 [ath9k]
[ 68.606561] [<ffffffff81072940>] ? dequeue_task_fair+0x400/0x8f0
[ 68.606566] [<ffffffff812c793e>] local_pci_probe+0x1e/0x40
[ 68.606569] [<ffffffff81053a23>] work_for_cpu_fn+0x13/0x20
[ 68.606573] [<ffffffff8105579f>] process_one_work+0x12f/0x470
[ 68.606575] [<ffffffff81055b04>] process_scheduled_works+0x24/0x40
[ 68.606578] [<ffffffff810572ea>] worker_thread+0x33a/0x3f0
[ 68.606581] [<ffffffff81056fb0>] ? manage_workers+0x290/0x290
[ 68.606585] [<ffffffff8105c1fb>] kthread+0xbb/0xc0
[ 68.606588] [<ffffffff8105c140>] ? flush_kthread_work+0x120/0x120
[ 68.606592] [<ffffffff818338ec>] ret_from_fork+0x7c/0xb0
[ 68.606594] [<ffffffff8105c140>] ? flush_kthread_work+0x120/0x120
[ 68.606596] ---[ end trace 2e41e752060512ed ]---
[ 68.606600] ath9k 0000:08:00.0: No memory for ieee80211_hw
[ 68.606644] ath9k: probe of 0000:08:00.0 failed with error -12
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Thu Aug 15, 2013 1:21 am    Post subject: Reply with quote

is the bluetooth portion working?
you might try a different kernel.
your symptoms are new to me and are not popping up in google; does the nic work with a sysresccd booted? or windows or ubuntu?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Cruel
n00b
n00b


Joined: 25 Jun 2011
Posts: 54

PostPosted: Thu Aug 15, 2013 3:33 pm    Post subject: Reply with quote

DONAHUE wrote:
is the bluetooth portion working?


Sorry but I don't get what you mean with "bluetooth portion"?

Quote:

you might try a different kernel.


Which one should I choose?

Quote:

your symptoms are new to me and are not popping up in google; does the nic work with a sysresccd booted? or windows or ubuntu?


Yes it works one the latest gentoo livedvd and on windows.
I had gentoo installed before on my laptop (last year) and the wlan card worked without any issue.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Thu Aug 15, 2013 9:02 pm    Post subject: Reply with quote

ar9287 supports wifi and bluetooth
if you are on a 3.8 kernel you might try 3.9 or 3.10 version http://packages.gentoo.org/package/sys-kernel/gentoo-sources
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum