Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
udev nvidia use extra CPU
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
inspoliaria
n00b
n00b


Joined: 13 Aug 2013
Posts: 1

PostPosted: Tue Aug 13, 2013 12:35 pm    Post subject: udev nvidia use extra CPU Reply with quote

Hi, all

I am new and have a fresh install. I use a hybrid graphic card.

nvidia GT 525M / Intel HD Graphics 3000 on Dell N5110

I have installed bumblebee and add to rc-init list it works well.

When I open a adobeflash file or work under multi tab laptop fans begin to cause an annoying noise and doesnt stop !

I ran top it tells udevd use over %16 CPU, modprobe %7

it's my udevdam monitor output

Code:

...
KERNEL[1364.240264] remove   /module/nvidia (module)
UDEV  [1364.241413] add      /module/nvidia (module)
UDEV  [1364.245884] remove   /module/nvidia (module)
KERNEL[1364.267438] add      /module/nvidia (module)
KERNEL[1364.268386] add      /bus/pci/drivers/nvidia (drivers)
KERNEL[1364.268398] remove   /bus/pci/drivers/nvidia (drivers)
UDEV  [1364.271841] add      /bus/pci/drivers/nvidia (drivers)
UDEV  [1364.276557] remove   /bus/pci/drivers/nvidia (drivers)
KERNEL[1364.320244] remove   /module/nvidia (module)
...

rc-update
Code:
            alsasound | boot                         
             bootmisc | boot                         
            bumblebee |      default                 
                 dbus |      default                 
                devfs |                       sysinit
                dmesg |                       sysinit
                 fsck | boot                         
             hostname | boot                         
              hwclock | boot                         
              keymaps | boot                         
            killprocs |              shutdown       
           localmount | boot                         
              modules | boot                         
             mount-ro |              shutdown       
                 mtab | boot                         
               net.lo | boot                         
             netmount |      default                 
               procfs | boot                         
                 root | boot                         
            savecache |              shutdown       
                 swap | boot                         
            swapfiles | boot                         
               sysctl | boot                         
                sysfs |                       sysinit
         termencoding | boot                         
       tmpfiles.setup | boot                         
                 udev |                       sysinit
              urandom | boot                         
                  xdm |      default                 


/etc/portage/make.conf
Code:

...
VIDEO_CARDS="intel nvidia"
....


and my Xorg use intel driver
Back to top
View user's profile Send private message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 85
Location: JiangSu,China

PostPosted: Sun Sep 15, 2013 2:14 pm    Post subject: Reply with quote

hello
I meet this question too

just stop bumblebeed ,udevd won't cost so much CPU
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum